summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Kustov <ktrace@yandex.ru>2022-04-17 20:58:28 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-04-25 09:56:56 +0300
commit988bbcc04c1f98aa018ee1891379e52176e94c79 (patch)
tree87e2a81f78a6e0ee7bfe1796e00ffdc54de880fa /sci-electronics
parentdev-util/radare2: verbump to 5.6.8 (diff)
downloadgentoo-988bbcc04c1f98aa018ee1891379e52176e94c79.tar.gz
gentoo-988bbcc04c1f98aa018ee1891379e52176e94c79.tar.bz2
gentoo-988bbcc04c1f98aa018ee1891379e52176e94c79.zip
sci-electronics/librepcb: up to 0.1.6
- switch from qmake to cmake - unbundle dev-cpp/muParser and dev-libs/quazip - backport librepcb-0.1.6-muparser-fix.patch from master - bugreport QA warning to upstream Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Victor Kustov <ktrace@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/25069 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/librepcb/Manifest1
-rw-r--r--sci-electronics/librepcb/files/librepcb-0.1.6-muparser-fix.patch28
-rw-r--r--sci-electronics/librepcb/librepcb-0.1.6.ebuild50
3 files changed, 79 insertions, 0 deletions
diff --git a/sci-electronics/librepcb/Manifest b/sci-electronics/librepcb/Manifest
index 61e8f60ff028..febaf25c929b 100644
--- a/sci-electronics/librepcb/Manifest
+++ b/sci-electronics/librepcb/Manifest
@@ -1,2 +1,3 @@
DIST librepcb-0.1.3-source.zip 12148919 BLAKE2B 2be3455c9be3e60a7cb314292e2a6ffe10d98f0c647d9c79f223ee5c5ef50675685d914889f772448dba699742d3bcd5b6636d489e630c8033912f3c9f223715 SHA512 28d45800bbbbcee8d30973c1a1e1e561c0fe2c65339eda4f6170779d921a9f5b2f5fb8c1cda00477e59976b88a3c368bb4985f31331bb16f761823642138c78b
DIST librepcb-0.1.5-source.zip 13111207 BLAKE2B 3a8c5f8b310971e1a6bd5b1fa8eb8059cd1c571e9ab369bf80c946ccbd320c258d5e8c65bea3b5a5bc4d85a38cac8205d5bbfbaad6aebf0a031315b73e9b99f4 SHA512 ed8c8fc154a03082bcbfe414bdb934870d09cf137811036a3ce59d70e1ad0b582fea64c31037c84e76a939bf1d087caabb9aa349578b525bce882e853a969653
+DIST librepcb-0.1.6-source.zip 12671974 BLAKE2B bed8d6134159ec663dd88f9933ef0dad6d3bca70776537bf2e16397f0e4fd968a41661d95a118008fcf9d7d6d2432ebac81d78153b3c3ce8d69c64fb59aaf70e SHA512 a51ac2830d65bbd10be8904ecdcc6a7781d80c95e1423ed5bd04fcd009a0b7135ff3a49a87afe9e99006ae1f6ae44f2341021e5733675f2f20b05525860da5d7
diff --git a/sci-electronics/librepcb/files/librepcb-0.1.6-muparser-fix.patch b/sci-electronics/librepcb/files/librepcb-0.1.6-muparser-fix.patch
new file mode 100644
index 000000000000..2abb26b18b59
--- /dev/null
+++ b/sci-electronics/librepcb/files/librepcb-0.1.6-muparser-fix.patch
@@ -0,0 +1,28 @@
+diff --git a/./libs/librepcb/common/utils/mathparser.cpp.orig b/./libs/librepcb/common/utils/mathparser.cpp
+index 618de36..e0903de 100644
+--- a/./libs/librepcb/common/utils/mathparser.cpp.orig
++++ b/./libs/librepcb/common/utils/mathparser.cpp
+@@ -22,7 +22,7 @@
+ ******************************************************************************/
+ #include "mathparser.h"
+
+-#include "muparser/include/muParser.h"
++#include <muParser.h>
+
+ /*******************************************************************************
+ * Namespace
+diff --git a/./cmake/FindMuParser.cmake.orig b/./cmake/FindMuParser.cmake
+--- a/./cmake/FindMuParser.cmake.orig 2021-11-03 01:04:32.000000000 +0300
++++ b/./cmake/FindMuParser.cmake 2022-04-24 18:01:23.996260205 +0300
+@@ -37,6 +37,11 @@
+ if(muparser_FOUND)
+ message(STATUS "Using system MuParser")
+
++ # Add uppercase alias if only the lowercase target is defined
++ if(NOT TARGET MuParser::MuParser)
++ add_library(MuParser::MuParser ALIAS muparser::muparser)
++ endif()
++
+ # Stop here, we're done
+ return()
+ endif()
diff --git a/sci-electronics/librepcb/librepcb-0.1.6.ebuild b/sci-electronics/librepcb/librepcb-0.1.6.ebuild
new file mode 100644
index 000000000000..69a4c50b530d
--- /dev/null
+++ b/sci-electronics/librepcb/librepcb-0.1.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2009-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake virtualx xdg
+
+DESCRIPTION="Free EDA software to develop printed circuit boards"
+HOMEPAGE="https://librepcb.org/"
+SRC_URI="https://download.librepcb.org/releases/${PV}/${P}-source.zip"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ app-arch/unzip
+ dev-qt/linguist-tools:5"
+
+RDEPEND="
+ dev-cpp/muParser:=
+ dev-libs/quazip:=
+ dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsql:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}
+ dev-qt/qttest:5"
+
+PATCHES=( "${FILESDIR}"/${P}-muparser-fix.patch )
+
+src_configure() {
+ local mycmakeargs+=(
+ -DUNBUNDLE_QUAZIP=ON
+ -DUNBUNDLE_MUPARSER=ON )
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}"/tests/unittests || die
+ virtx ./librepcb-unittests --gtest_filter=-SystemInfoTest.testGetUsername || die
+}