summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-09-23 23:35:38 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-09-23 23:35:38 +0700
commit358ab910c6138f9e421681ee8deb37a881c1e04e (patch)
tree3341580dfeeffc55b105eb24708e97e9faefa46f /sci-geosciences/qmapshack
parentsci-physics/rivet: add 4.0.1 (diff)
downloadgentoo-358ab910c6138f9e421681ee8deb37a881c1e04e.tar.gz
gentoo-358ab910c6138f9e421681ee8deb37a881c1e04e.tar.bz2
gentoo-358ab910c6138f9e421681ee8deb37a881c1e04e.zip
_p600: correcting dependencies
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-geosciences/qmapshack')
-rw-r--r--sci-geosciences/qmapshack/files/dbus.patch15
-rw-r--r--sci-geosciences/qmapshack/qmapshack-1.17.1_p600-r2.ebuild48
2 files changed, 63 insertions, 0 deletions
diff --git a/sci-geosciences/qmapshack/files/dbus.patch b/sci-geosciences/qmapshack/files/dbus.patch
new file mode 100644
index 000000000000..39018124d64e
--- /dev/null
+++ b/sci-geosciences/qmapshack/files/dbus.patch
@@ -0,0 +1,15 @@
+diff '--color=auto' -U3 -r qmapshack-1f009ac0be1d1c2a4c31aa1283f4009e88685d34.orig/CMakeLists.txt qmapshack-1f009ac0be1d1c2a4c31aa1283f4009e88685d34/CMakeLists.txt
+--- qmapshack-1f009ac0be1d1c2a4c31aa1283f4009e88685d34.orig/CMakeLists.txt 2024-09-04 18:48:55.000000000 +0700
++++ qmapshack-1f009ac0be1d1c2a4c31aa1283f4009e88685d34/CMakeLists.txt 2024-09-23 22:32:02.157927751 +0700
+@@ -200,9 +200,9 @@
+
+ if(USE_QT6DBus)
+ find_package(Qt6DBus REQUIRED)
+- if(Qt5DBus_FOUND)
++ if(Qt6DBus_FOUND)
+ add_definitions(-DHAVE_DBUS)
+- endif(Qt5DBus_FOUND)
++ endif(Qt6DBus_FOUND)
+ endif(USE_QT6DBus)
+
+ # Everything included. Let's finetune the mess a bit more
diff --git a/sci-geosciences/qmapshack/qmapshack-1.17.1_p600-r2.ebuild b/sci-geosciences/qmapshack/qmapshack-1.17.1_p600-r2.ebuild
new file mode 100644
index 000000000000..c97e39c4ae0f
--- /dev/null
+++ b/sci-geosciences/qmapshack/qmapshack-1.17.1_p600-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="GPS mapping utility"
+HOMEPAGE="https://github.com/Maproom/qmapshack/wiki"
+COMMIT="1f009ac0be1d1c2a4c31aa1283f4009e88685d34"
+SRC_URI="https://github.com/kiozen/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${COMMIT}
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+RDEPEND="
+ dev-db/sqlite
+ >=dev-libs/quazip-1.3:0=[qt6]
+ dev-qt/qt5compat:6
+ dev-qt/qtbase:6[dbus,gui,network,sql,widgets,xml]
+ dev-qt/qtdeclarative:6
+ dev-qt/qttools:6[assistant,widgets]
+ dev-qt/qtwebengine:6[widgets]
+ sci-geosciences/routino
+ sci-libs/alglib
+ sci-libs/gdal:=
+ sci-libs/proj:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/qttools:6[linguist]"
+
+PATCHES=( "${FILESDIR}"/dbus.patch )
+
+src_configure() {
+ local mycmakeargs=( -DUSE_QT6DBus=$(usex dbus) )
+ cmake_src_configure
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}/html
+ cmake_src_install
+ mv "${D}"/usr/share/doc/HTML "${D}"/usr/share/doc/${PF}/html || die "mv Qt help failed"
+ ewarn "An experimental Qt6 port"
+ ewarn "Translations and the help system are broken"
+ ewarn "Other bugs to https://github.com/Maproom/qmapshack/issues"
+}