summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-08-13 19:32:00 +0800
committerJason Zaman <perfinion@gentoo.org>2018-08-13 19:34:36 +0800
commit5fb2349448fcb5ebffdfa9d4872d2525ffb55298 (patch)
treef74392cb0d7b98fa32ea156e3e1bb891d832784f /sci-libs/keras-preprocessing
parentsci-libs/keras-applications: new package (diff)
downloadgentoo-5fb2349448fcb5ebffdfa9d4872d2525ffb55298.tar.gz
gentoo-5fb2349448fcb5ebffdfa9d4872d2525ffb55298.tar.bz2
gentoo-5fb2349448fcb5ebffdfa9d4872d2525ffb55298.zip
sci-libs/keras-preprocessing: new package
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sci-libs/keras-preprocessing')
-rw-r--r--sci-libs/keras-preprocessing/Manifest1
-rw-r--r--sci-libs/keras-preprocessing/keras-preprocessing-1.0.2.ebuild22
-rw-r--r--sci-libs/keras-preprocessing/metadata.xml14
3 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/keras-preprocessing/Manifest b/sci-libs/keras-preprocessing/Manifest
new file mode 100644
index 000000000000..df69c924a482
--- /dev/null
+++ b/sci-libs/keras-preprocessing/Manifest
@@ -0,0 +1 @@
+DIST keras-preprocessing-1.0.2.tar.gz 34762 BLAKE2B 3b4766aa48d6e6cfd50817af97c8f2faf9ae7e78007f7dddcbf1f4ded072657a5b94ac4b563d090dd8a8437a249b64fea61a1cd5f680767f14611fa6fe92dd3a SHA512 d5a558c3d9741c298ea3737bfb04788bd2cbecefe14aa53e0f6ccde891ad9304ec673a888dc53a2f954c0b718ce31d9d35095d3f21e15d73248acfc8105457d9
diff --git a/sci-libs/keras-preprocessing/keras-preprocessing-1.0.2.ebuild b/sci-libs/keras-preprocessing/keras-preprocessing-1.0.2.ebuild
new file mode 100644
index 000000000000..930bd5dcf266
--- /dev/null
+++ b/sci-libs/keras-preprocessing/keras-preprocessing-1.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Easy data preprocessing and data augmentation for deep learning models"
+HOMEPAGE="https://keras.io/"
+SRC_URI="https://github.com/keras-team/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/sci-libs/keras-preprocessing/metadata.xml b/sci-libs/keras-preprocessing/metadata.xml
new file mode 100644
index 000000000000..833dd3977c1a
--- /dev/null
+++ b/sci-libs/keras-preprocessing/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>perfinion@gentoo.org</email>
+ <name>Jason Zaman</name>
+ </maintainer>
+ <longdescription lang="en">
+ Keras Preprocessing is the data preprocessing and data augmentation module of the Keras deep learning library. It provides utilities for working with image data, text data, and sequence data.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">keras-team/keras-preprocessing</remote-id>
+ </upstream>
+</pkgmetadata>