summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /sci-libs/mkl
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/mkl')
-rw-r--r--sci-libs/mkl/mkl-10.0.5.025-r1.ebuild4
-rw-r--r--sci-libs/mkl/mkl-10.0.5.025.ebuild7
2 files changed, 5 insertions, 6 deletions
diff --git a/sci-libs/mkl/mkl-10.0.5.025-r1.ebuild b/sci-libs/mkl/mkl-10.0.5.025-r1.ebuild
index 0a4d33acc080..33fe7c30d1d4 100644
--- a/sci-libs/mkl/mkl-10.0.5.025-r1.ebuild
+++ b/sci-libs/mkl/mkl-10.0.5.025-r1.ebuild
@@ -307,7 +307,7 @@ src_install() {
# install license
if [[ ! -f ${INTEL_LIC_DIR}/${MKL_LIC} ]]; then
insinto ${INTEL_LIC_DIR}
- doins "${WORKDIR}"/${MKL_LIC} || die "install license failed"
+ doins "${WORKDIR}"/${MKL_LIC}
fi
# install main stuff: cp faster than doins
@@ -317,7 +317,7 @@ src_install() {
cp -pPR ${cpdirs} "${D}"${MKL_DIR} \
|| die "installing mkl failed"
insinto ${MKL_DIR}
- doins -r ${doinsdirs} || die "doins ${doinsdirs} failed"
+ doins -r ${doinsdirs}
dosym mkl_cblas.h ${MKL_DIR}/include/cblas.h
# install blas/lapack profiles
diff --git a/sci-libs/mkl/mkl-10.0.5.025.ebuild b/sci-libs/mkl/mkl-10.0.5.025.ebuild
index 4de67341b9e1..dce78de61457 100644
--- a/sci-libs/mkl/mkl-10.0.5.025.ebuild
+++ b/sci-libs/mkl/mkl-10.0.5.025.ebuild
@@ -215,8 +215,7 @@ src_test() {
emake \
compiler=${MKL_FC} \
${myconf} \
- so${MKL_ARCH} \
- || die "emake ${x} failed"
+ so${MKL_ARCH}
popd
done
}
@@ -310,7 +309,7 @@ src_install() {
# install license
if [[ ! -f ${INTEL_LIC_DIR}/${MKL_LIC} ]]; then
insinto ${INTEL_LIC_DIR}
- doins "${WORKDIR}"/${MKL_LIC} || die "install license failed"
+ doins "${WORKDIR}"/${MKL_LIC}
fi
# install main stuff: cp faster than doins
@@ -320,7 +319,7 @@ src_install() {
cp -pPR ${cpdirs} "${D}"${MKL_DIR} \
|| die "installing mkl failed"
insinto ${MKL_DIR}
- doins -r ${doinsdirs} || die "doins ${doinsdirs} failed"
+ doins -r ${doinsdirs}
dosym mkl_cblas.h ${MKL_DIR}/include/cblas.h
# install blas/lapack profiles