summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-19 21:03:06 +0000
committerSam James <sam@gentoo.org>2022-02-19 22:37:33 +0000
commit4da6773013ed9699393143b73b5cbb76131887d8 (patch)
tree59fdd7a521e97042e3bc229890b69f667a8a0a96 /sci-libs/scotch
parentnet-news/sfeed: new ebuild (diff)
downloadgentoo-4da6773013ed9699393143b73b5cbb76131887d8.tar.gz
gentoo-4da6773013ed9699393143b73b5cbb76131887d8.tar.bz2
gentoo-4da6773013ed9699393143b73b5cbb76131887d8.zip
sci-libs/scotch: add 7.0.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/scotch')
-rw-r--r--sci-libs/scotch/Manifest1
-rw-r--r--sci-libs/scotch/scotch-7.0.1.ebuild176
2 files changed, 177 insertions, 0 deletions
diff --git a/sci-libs/scotch/Manifest b/sci-libs/scotch/Manifest
index fcf76ab6b400..9c1ce2781f46 100644
--- a/sci-libs/scotch/Manifest
+++ b/sci-libs/scotch/Manifest
@@ -1,3 +1,4 @@
DIST scotch-v6.1.0.tar.gz 6292006 BLAKE2B 5b76b01c0fa752468a36830a15c190cd78efc851c3b6831eb2d16b7cf34a71d55463b266ffdee4c6addd4e66ca7caf75e63825051e600ee8a32494e5033cabbd SHA512 e6d217a23e39635f8749811a3fc64c8da14d0396a71b4042a4f8f3ce32ff1f0b4ed033ebae90f3785443dae9b35ded68ea512ed1e3e7f9ea9a471a499ae26b89
DIST scotch-v6.1.1.tar.gz 6363384 BLAKE2B 337c81608fd245dde5b19bb6c79924e0ee80181ce3c935ae37e6248be2511a2f4d70bdda5b9217e5e1ed79fc00269de15755c3b6829579aa190ca6da9c3c2dac SHA512 daa62463f25416764250fe0452ae84bc6a2e485ee62a387418b4686c2ab93a2ca2d5a12cba922857c99a1c9ec67fc82951b0f9563ab97f5f3a6b86bb9da22b0c
DIST scotch-v6.1.2.tar.gz 6395320 BLAKE2B 07aa4f56c097cf364d7d63613f3c5d5d3f2a8419ce27da95a4a20d5ea48fcf2f036acaa62ab1f591b5d1dc672151562bc0721a66f203c60d5ee26a501cf90352 SHA512 dcf63c65bf8155590a70483f80ad21b4a303debf50d47a3c154983935dc056f3df93a61c3d88304f3d1a4517ab3a355e176d72b3835382cd65c1556fbbd21702
+DIST scotch-v7.0.1.tar.gz 6838403 BLAKE2B 48cb928bf8586bbbe206dcb4f685e6c392ae078f5493e0384776cf6788137361286adbebceb7ad5c171eced34f5dda3f4852092413e79cbb791bd3ced204784c SHA512 c3267d5c8785a2258af3baf999d2c1eb75ef361062e74962b6e985a75cc4f5ef1f79919759ba1b7cf028f94d06a5ddf3818108a97eca4123a11d7750b5d7093d
diff --git a/sci-libs/scotch/scotch-7.0.1.ebuild b/sci-libs/scotch/scotch-7.0.1.ebuild
new file mode 100644
index 000000000000..5f7ec4a8c16f
--- /dev/null
+++ b/sci-libs/scotch/scotch-7.0.1.ebuild
@@ -0,0 +1,176 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs flag-o-matic multilib
+
+SOVER=$(ver_cut 1)
+
+DESCRIPTION="Software for graph, mesh and hypergraph partitioning"
+HOMEPAGE="https://www.labri.u-bordeaux.fr/perso/pelegrin/scotch/ https://gitlab.inria.fr/scotch/scotch"
+SRC_URI="https://gitlab.inria.fr/${PN}/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
+S="${WORKDIR}/${PN}-v${PV}"
+
+LICENSE="CeCILL-2"
+SLOT="0/${SOVER}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc int64 mpi static-libs test tools +threads"
+# bug #532620
+REQUIRED_USE="test? ( threads )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ sys-libs/zlib
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+static_to_shared() {
+ local libstatic=${1}; shift
+ local libname=$(basename ${libstatic%.a})
+ local soname=${libname}$(get_libname ${SOVER})
+ local libdir=$(dirname ${libstatic})
+
+ einfo "Making ${soname} from ${libstatic}"
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ ${LINK:-$(tc-getCC)} ${LDFLAGS} \
+ -dynamiclib -install_name "${EPREFIX}"/usr/lib/"${soname}" \
+ -Wl,-all_load -Wl,${libstatic} \
+ "$@" -o ${libdir}/${soname} || die "${soname} failed"
+ else
+ ${LINK:-$(tc-getCC)} ${LDFLAGS} \
+ -shared -Wl,-soname=${soname} \
+ -Wl,--whole-archive ${libstatic} -Wl,--no-whole-archive \
+ "$@" -o ${libdir}/${soname} || die "${soname} failed"
+ VERS_COMP=${PV//.}
+ [[ "${#VERS_COMP}" -gt 1 ]] && \
+ ln -s ${soname} ${libdir}/${libname}$(get_libname ${SOVER})
+ ln -s ${soname} ${libdir}/${libname}$(get_libname)
+ fi
+}
+
+src_prepare() {
+ default
+ use int64 && append-cflags -DIDXSIZE64
+ if use threads; then
+ append-cflags "-DSCOTCH_PTHREAD_NUMBER=$(nproc)"
+ else
+ append-cflags "-DSCOTCH_PTHREAD_NUMBER=1"
+ sed -i \
+ -e 's/ -DSCOTCH_PTHREAD//' \
+ src/Make.inc/Makefile.inc.i686_pc_linux3 || die
+ fi
+
+ # Be careful with replacing here, bug #577272
+ sed -e "s/= gcc$/= $(tc-getCC)/" \
+ -e "s/-O3/${CFLAGS} -pthread/" \
+ -e "s/= ar$/= $(tc-getAR)/" \
+ -e "s/= ranlib$/= $(tc-getRANLIB)/" \
+ -e "s/= ranlib$/= $(tc-getRANLIB)/" \
+ -e "/^LDFLAGS/ s/$/ ${LDFLAGS}/" \
+ src/Make.inc/Makefile.inc.i686_pc_linux3 > src/Makefile.inc || die
+}
+
+src_compile() {
+ emake -C src CLIBFLAGS=-fPIC scotch esmumps
+ static_to_shared lib/libscotcherr.a
+ static_to_shared lib/libscotcherrexit.a
+ static_to_shared lib/libscotch.a -Llib -lz -lm -lrt -lpthread -lscotcherr
+ static_to_shared lib/libesmumps.a -Llib -lscotch
+ static_to_shared lib/libscotchmetisv3.a -Llib -lscotch
+ static_to_shared lib/libscotchmetisv5.a -Llib -lscotch
+
+ if use mpi; then
+ emake -C src CLIBFLAGS=-fPIC ptscotch ptesmumps
+ export LINK=mpicc
+ static_to_shared lib/libptscotcherr.a
+ static_to_shared lib/libptscotcherrexit.a
+ static_to_shared lib/libptscotch.a -Llib -lscotch -lptscotcherr -lz -lm -lrt
+ static_to_shared lib/libptesmumps.a -Llib -lscotch -lptscotch
+ static_to_shared lib/libptscotchparmetis.a -Llib -lscotch -lptscotch
+ fi
+ if use static-libs; then
+ emake -C src clean
+ emake -C src
+ use mpi && emake -C src ptscotch
+ fi
+}
+
+src_test() {
+ tc-export FC
+ LD_LIBRARY_PATH="${S}/lib" emake -C src check
+}
+
+src_install() {
+ dolib.so lib/lib*$(get_libname)*
+ use static-libs && dolib.a lib/*.a
+
+ # Install metis headers into a subdir
+ # to allow usage of real metis and scotch
+ # in the same code
+ insinto /usr/include/scotch/metis
+ doins include/*metis*
+ rm include/*metis* || die
+
+ insinto /usr/include/scotch
+ doins include/*
+
+ cat <<-EOF > scotchmetis.pc
+ prefix=${EPREFIX}/usr
+ libdir=\${prefix}/$(get_libdir)
+ includedir=\${prefix}/include
+ Name: scotchmetis
+ Description: ${DESCRIPTION}
+ Version: ${PV}
+ URL: ${HOMEPAGE}
+ Libs: -L\${libdir} -lscotchmetis -lscotcherr -lscotch
+ Private: -lm -lz -lrt
+ Cflags: -I\${includedir}/scotch/metis
+ EOF
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins scotchmetis.pc
+
+ # Not sure it is actually a full replacement of metis
+ #alternatives_for metis scotch 0 \
+ # /usr/$(get_libdir)/pkgconfig/metis.pc scotchmetis.pc
+
+ if use mpi; then
+ cat <<-EOF > ptscotchparmetis.pc
+ prefix=${EPREFIX}/usr
+ libdir=\${prefix}/$(get_libdir)
+ includedir=\${prefix}/include
+ Name: ptscotchparmetis
+ Description: ${DESCRIPTION}
+ Version: ${PV}
+ URL: ${HOMEPAGE}
+ Libs: -L\${libdir} -lptscotchparmetis -lptscotcherr -lptscotch
+ Private: -lm -lz -lrt
+ Cflags: -I\${includedir}/scotch/metis
+ Requires: scotchmetis
+ EOF
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins ptscotchparmetis.pc
+ # Not sure it is actually a full replacement of parmetis
+ #alternatives_for metis-mpi ptscotch 0 \
+ # /usr/$(get_libdir)/pkgconfig/metis-mpi.pc ptscotchparmetis.pc
+ fi
+
+ dodoc README.txt
+
+ if use tools; then
+ local b m
+ pushd bin > /dev/null || die
+ for b in *; do
+ newbin ${b} scotch_${b}
+ done
+ popd > /dev/null || die
+
+ pushd man/man1 > /dev/null || die
+ for m in *.1; do
+ newman ${m} scotch_${m}
+ done
+ popd > /dev/null || die
+ fi
+
+ use doc && dodoc doc/*.pdf
+}