summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-05-06 10:28:45 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-05-06 10:29:12 +0200
commit64cc571e76135e6f06c0ef4bcef86bc8586c12ea (patch)
treee5fd9e17d2df72c06e60e2a2e9c5968a89eb6a65 /sci-libs
parentpackage.mask: Last rite dev-perl/Net-Twitter (diff)
downloadgentoo-64cc571e76135e6f06c0ef4bcef86bc8586c12ea.tar.gz
gentoo-64cc571e76135e6f06c0ef4bcef86bc8586c12ea.tar.bz2
gentoo-64cc571e76135e6f06c0ef4bcef86bc8586c12ea.zip
sci-libs/onnx: add 1.16.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/onnx/Manifest1
-rw-r--r--sci-libs/onnx/onnx-1.16.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sci-libs/onnx/Manifest b/sci-libs/onnx/Manifest
index e7517b3f3567..9b84f011ad21 100644
--- a/sci-libs/onnx/Manifest
+++ b/sci-libs/onnx/Manifest
@@ -1,2 +1,3 @@
DIST onnx-1.14.1.tar.gz 11570627 BLAKE2B df478219b5d557ad7e0717377996eefc02baa88a89d9681b17e00670e42fa3c8e47db0f5c5fdfab682fa7d80032559da8276c5106a91a7599d190427e2b6e4a8 SHA512 f846fffb286c4aeadc01462f220515f0a5c2ce1cbec849da7092a08c2676f8308af7315318a2866e9182f9aed719984ef95a9ddc69ffe0e62e40664395df5efd
DIST onnx-1.15.0.tar.gz 12360484 BLAKE2B 4d35b82c128a69124b9bfcb3e56b3d584b7451ae739a91039e201dd485efa3e90e34e6cf135993317622f8f524160a38556231b2b0561e93d8cd0487abf35c1b SHA512 b46a4ab70af88053318eba45251c1f71528f15e45a33042877570e8d857febd3ec66e2e811fcda2105a4f17b84c9a1c6a0aaa22756c3287321b3ea29e83127fd
+DIST onnx-1.16.0.tar.gz 12428161 BLAKE2B b0d16212c527078fcbe46af8efaf8bfccb0a22825cfee3c88728314599bc90f5b43ae407cc9ec10300ed19367dff769a5d6ba29d2faa61fd8e27029e2d64e83a SHA512 ef641447d8d6c4ed9f083793fe14a8568d6aa7b9b7e7b859a4082e9b892acd801230da2027d097ceaa0d68bbd37b2422b89bb7d1d55d5c3b5955c0f9c7c657c5
diff --git a/sci-libs/onnx/onnx-1.16.0.ebuild b/sci-libs/onnx/onnx-1.16.0.ebuild
new file mode 100644
index 000000000000..e5a6b1c71b41
--- /dev/null
+++ b/sci-libs/onnx/onnx-1.16.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 cmake
+
+DESCRIPTION="Open Neural Network Exchange (ONNX)"
+HOMEPAGE="https://github.com/onnx/onnx"
+SRC_URI="https://github.com/onnx/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ dev-libs/protobuf:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-1.15.0-hidden.patch
+ cmake_src_prepare
+ distutils-r1_src_prepare
+}
+
+python_configure_all()
+{
+ mycmakeargs=(
+ -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
+ -DONNX_USE_LITE_PROTO=ON
+ -DONNX_BUILD_SHARED_LIBS=ON
+ )
+ cmake_src_configure
+}
+
+src_configure() {
+ distutils-r1_src_configure
+}
+
+src_compile() {
+ mycmakeargs=(
+ -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
+ -DONNX_USE_LITE_PROTO=ON
+ -DONNX_BUILD_SHARED_LIBS=ON
+ )
+ CMAKE_ARGS="${mycmakeargs[@]}" distutils-r1_src_compile
+}
+
+python_compile_all() {
+ cmake_src_compile
+}
+
+python_install_all() {
+ cmake_src_install
+ distutils-r1_python_install_all
+}
+
+src_install() {
+ distutils-r1_src_install
+}