summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-16 10:12:22 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-16 10:12:22 +0200
commit65c9ccf3e0e396a82ef25c30d6eb5639b61e7ddf (patch)
treec0ae8299aeb04d85f18e88818b27f2e9b66a40eb /sci-libs
parentsci-libs/m4ri: [QA] use tc-check-openmp correctly (diff)
downloadgentoo-65c9ccf3e0e396a82ef25c30d6eb5639b61e7ddf.tar.gz
gentoo-65c9ccf3e0e396a82ef25c30d6eb5639b61e7ddf.tar.bz2
gentoo-65c9ccf3e0e396a82ef25c30d6eb5639b61e7ddf.zip
sci-libs/openblas: [QA] use tc-check-openmp correctly
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/openblas/openblas-0.3.18.ebuild4
-rw-r--r--sci-libs/openblas/openblas-0.3.19.ebuild4
-rw-r--r--sci-libs/openblas/openblas-0.3.20.ebuild4
3 files changed, 9 insertions, 3 deletions
diff --git a/sci-libs/openblas/openblas-0.3.18.ebuild b/sci-libs/openblas/openblas-0.3.18.ebuild
index 3ac219fa41cf..ec15a244d0b8 100644
--- a/sci-libs/openblas/openblas-0.3.18.ebuild
+++ b/sci-libs/openblas/openblas-0.3.18.ebuild
@@ -30,6 +30,8 @@ PATCHES=(
)
pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
elog "This software has a massive number of options that"
elog "are configurable and it is *impossible* for all of"
elog "those to fit inside any manageable ebuild."
@@ -57,7 +59,7 @@ pkg_setup() {
export HOSTCC="$(tc-getBUILD_CC)"
# threading options
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
USE_THREAD=0
if use openmp; then
USE_THREAD=1; USE_OPENMP=1;
diff --git a/sci-libs/openblas/openblas-0.3.19.ebuild b/sci-libs/openblas/openblas-0.3.19.ebuild
index 3ac219fa41cf..ec15a244d0b8 100644
--- a/sci-libs/openblas/openblas-0.3.19.ebuild
+++ b/sci-libs/openblas/openblas-0.3.19.ebuild
@@ -30,6 +30,8 @@ PATCHES=(
)
pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
elog "This software has a massive number of options that"
elog "are configurable and it is *impossible* for all of"
elog "those to fit inside any manageable ebuild."
@@ -57,7 +59,7 @@ pkg_setup() {
export HOSTCC="$(tc-getBUILD_CC)"
# threading options
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
USE_THREAD=0
if use openmp; then
USE_THREAD=1; USE_OPENMP=1;
diff --git a/sci-libs/openblas/openblas-0.3.20.ebuild b/sci-libs/openblas/openblas-0.3.20.ebuild
index 518fd79fedef..01fd54d252c4 100644
--- a/sci-libs/openblas/openblas-0.3.20.ebuild
+++ b/sci-libs/openblas/openblas-0.3.20.ebuild
@@ -32,6 +32,8 @@ PATCHES=(
)
pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
elog "This software has a massive number of options that"
elog "are configurable and it is *impossible* for all of"
elog "those to fit inside any manageable ebuild."
@@ -59,7 +61,7 @@ pkg_setup() {
export HOSTCC="$(tc-getBUILD_CC)"
# threading options
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
USE_THREAD=0
if use openmp; then
USE_THREAD=1; USE_OPENMP=1;