summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-06-30 17:16:40 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-07-01 17:28:37 -0400
commit6550c689d0c7df3d328ec792b0737cf27a7b986d (patch)
tree94b89af22ad4926ce8c3aed7bf26abb85bdbb0a4 /sci-mathematics/arb/arb-2.23.0.ebuild
parentsci-mathematics/flint: new upstream v2.9.0. (diff)
downloadgentoo-6550c689d0c7df3d328ec792b0737cf27a7b986d.tar.gz
gentoo-6550c689d0c7df3d328ec792b0737cf27a7b986d.tar.bz2
gentoo-6550c689d0c7df3d328ec792b0737cf27a7b986d.zip
sci-mathematics/arb: new upstream v2.23.0.
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/arb/arb-2.23.0.ebuild')
-rw-r--r--sci-mathematics/arb/arb-2.23.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-mathematics/arb/arb-2.23.0.ebuild b/sci-mathematics/arb/arb-2.23.0.ebuild
new file mode 100644
index 000000000000..870cc91b5694
--- /dev/null
+++ b/sci-mathematics/arb/arb-2.23.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE=Release
+inherit cmake
+
+DESCRIPTION="C library for arbitrary-precision interval arithmetic"
+HOMEPAGE="https://fredrikj.net/arb/"
+SRC_URI="https://github.com/fredrik-johansson/arb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+LICENSE="GPL-2+"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ >=sci-mathematics/flint-2.9.0:="
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ )
+
+ cmake_src_configure
+}