summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-14 23:30:28 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-14 23:30:28 +0200
commita7a2df0f47be3f3bf59d2839755914f962eb91bb (patch)
treecda445ab1f89971a525896d5bda3844289d33f70 /sci-mathematics/normaliz
parentsci-libs/sundials: [QA] tc-has-openmp → tc-check-openmp (diff)
downloadgentoo-a7a2df0f47be3f3bf59d2839755914f962eb91bb.tar.gz
gentoo-a7a2df0f47be3f3bf59d2839755914f962eb91bb.tar.bz2
gentoo-a7a2df0f47be3f3bf59d2839755914f962eb91bb.zip
sci-mathematics/normaliz: [QA] tc-has-openmp → tc-check-openmp
Closes: https://github.com/gentoo/gentoo/pull/25486 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-mathematics/normaliz')
-rw-r--r--sci-mathematics/normaliz/normaliz-3.1.3-r1.ebuild13
-rw-r--r--sci-mathematics/normaliz/normaliz-3.8.10-r1.ebuild8
-rw-r--r--sci-mathematics/normaliz/normaliz-3.9.3.ebuild6
3 files changed, 20 insertions, 7 deletions
diff --git a/sci-mathematics/normaliz/normaliz-3.1.3-r1.ebuild b/sci-mathematics/normaliz/normaliz-3.1.3-r1.ebuild
index bc18fd6a3868..a2d3890c2854 100644
--- a/sci-mathematics/normaliz/normaliz-3.1.3-r1.ebuild
+++ b/sci-mathematics/normaliz/normaliz-3.1.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -26,15 +26,20 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MYP}
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
src_prepare() {
./bootstrap.sh || die
default
}
src_configure() {
- if use openmp && ! tc-has-openmp ; then
- die "You requested openmp, but your toolchain does not support it."
- fi
econf $(use_enable openmp)
}
diff --git a/sci-mathematics/normaliz/normaliz-3.8.10-r1.ebuild b/sci-mathematics/normaliz/normaliz-3.8.10-r1.ebuild
index 74f541639c16..d696ca7b9817 100644
--- a/sci-mathematics/normaliz/normaliz-3.8.10-r1.ebuild
+++ b/sci-mathematics/normaliz/normaliz-3.8.10-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,8 +25,12 @@ DEPEND="
"
# Only a boost header is needed -> not RDEPEND
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {
diff --git a/sci-mathematics/normaliz/normaliz-3.9.3.ebuild b/sci-mathematics/normaliz/normaliz-3.9.3.ebuild
index 7b7436eeb4e9..9fa89e9d001b 100644
--- a/sci-mathematics/normaliz/normaliz-3.9.3.ebuild
+++ b/sci-mathematics/normaliz/normaliz-3.9.3.ebuild
@@ -24,8 +24,12 @@ DEPEND="
"
# Only a boost header is needed -> not RDEPEND
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {