summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-08 00:35:06 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-08 01:29:18 +0100
commitc2cefd413637c6d457d9a552f93c617f834fca70 (patch)
tree32214b5722aeabcc99f6293d1390ac385fc30b00 /sci-mathematics
parentnet-misc/rclone: Stabilize 1.60.1 amd64, #890160 (diff)
downloadgentoo-c2cefd413637c6d457d9a552f93c617f834fca70.tar.gz
gentoo-c2cefd413637c6d457d9a552f93c617f834fca70.tar.bz2
gentoo-c2cefd413637c6d457d9a552f93c617f834fca70.zip
sci-mathematics/acl2: new package; add 8.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/acl2/Manifest1
-rw-r--r--sci-mathematics/acl2/acl2-8.5.ebuild92
-rw-r--r--sci-mathematics/acl2/files/50acl2-gentoo.el6
-rw-r--r--sci-mathematics/acl2/metadata.xml20
4 files changed, 119 insertions, 0 deletions
diff --git a/sci-mathematics/acl2/Manifest b/sci-mathematics/acl2/Manifest
new file mode 100644
index 000000000000..7d370521a91f
--- /dev/null
+++ b/sci-mathematics/acl2/Manifest
@@ -0,0 +1 @@
+DIST acl2-8.5.tar.gz 222696244 BLAKE2B e5aa8360d9f94ed398d11c4e0873818f8f49ed0e072192c7d62dde99b4a7f98b4240b352818e7691ebc98f85ab3c10981c36bb1e35317e50a111c9c7f3f57b33 SHA512 5a2e004713350ae41ced830aa8620c27963eb108baa499f7e52a1c60961b220ef7a026efdfef6cea1063f731b50f3cccbe1583a9957c9cf269b0a958ec83fe48
diff --git a/sci-mathematics/acl2/acl2-8.5.ebuild b/sci-mathematics/acl2/acl2-8.5.ebuild
new file mode 100644
index 000000000000..bea58cd4e997
--- /dev/null
+++ b/sci-mathematics/acl2/acl2-8.5.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: Only SBCL (dev-lisp/sbcl) is tested for now, but probably
+# more CL implementations can be added as alternative dependencies.
+# With ClozureCL (dev-lisp/clozurecl) ACL2 fails to build,
+# this might need in-depth investigation...
+
+EAPI=8
+
+inherit elisp-common
+
+DESCRIPTION="Industrial strength theorem prover, logic and programming language"
+HOMEPAGE="https://www.cs.utexas.edu/users/moore/acl2/
+ https://github.com/acl2/acl2/"
+SRC_URI="https://github.com/acl2/acl2/archive/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs"
+REQUIRED_USE="emacs? ( doc )"
+
+RDEPEND="
+ dev-lisp/sbcl
+ emacs? ( >=app-editors/emacs-25:* )
+"
+BDEPEND="
+ ${RDEPEND}
+ doc? ( dev-lang/perl )
+"
+
+DOCS=( books/README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ find . -type f -name "*.bak" -delete || die
+ find . -type f -name "*.orig" -delete || die
+ rm books/workshops/2003/schmaltz-al-sammane-et-al/support/acl2link || die
+
+ default
+}
+
+src_compile() {
+ emake LISP="sbcl --no-sysinit --no-userinit --disable-debugger"
+
+ use doc && emake ACL2="${S}"/saved_acl2 basic DOC
+
+ if use emacs ; then
+ local elisp_dir
+ for elisp_dir in books/emacs books/interface/emacs ; do
+ BYTECOMPFLAGS="-L ${S}/${elisp_dir}" \
+ elisp-compile "${S}"/${elisp_dir}/*.el
+ done
+ fi
+}
+
+src_install() {
+ local saved_name=saved_acl2
+
+ sed "s|${S}|/usr/share/acl2|g" -i ${saved_name} || die
+ sed "5iexport ACL2_SYSTEM_BOOKS=/usr/share/acl2/books/" \
+ -i ${saved_name} || die
+
+ exeinto /usr/share/acl2
+ doexe ${saved_name}
+ insinto /usr/share/acl2
+ doins ${saved_name}.core
+ doins TAGS
+ dosym -r /usr/share/acl2/${saved_name} /usr/bin/acl2
+
+ if use doc ; then
+ doins -r books
+
+ HTML_DOCS=( doc/HTML/. )
+ einstalldocs
+ fi
+ if use emacs ; then
+ elisp-install ${PN} \
+ books/emacs/*.el{,c} \
+ books/interface/emacs/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-mathematics/acl2/files/50acl2-gentoo.el b/sci-mathematics/acl2/files/50acl2-gentoo.el
new file mode 100644
index 000000000000..d61224e84506
--- /dev/null
+++ b/sci-mathematics/acl2/files/50acl2-gentoo.el
@@ -0,0 +1,6 @@
+(add-to-list 'load-path "@SITELISP@")
+(defvar *acl2-sources-dir* "/usr/share/acl2/")
+(autoload 'inferior-acl2 "inf-acl2.el"
+ "Run an inferior Acl2 process" t)
+(autoload 'run-acl2 "inf-acl2.el"
+ "Run an inferior Acl2 process" t)
diff --git a/sci-mathematics/acl2/metadata.xml b/sci-mathematics/acl2/metadata.xml
new file mode 100644
index 000000000000..df9ae811037d
--- /dev/null
+++ b/sci-mathematics/acl2/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ ACL2 is a logic and programming language in which you can model computer
+ systems, together with a tool to help you prove properties of those models.
+ "ACL2" denotes "A Computational Logic for Applicative Common Lisp". ACL2 is
+ part of the Boyer-Moore family of provers, for which its authors have
+ received the 2005 ACM Software System Award.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/acl2/acl2/issues/</bugs-to>
+ <remote-id type="github">acl2/acl2</remote-id>
+ </upstream>
+</pkgmetadata>