summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-09-01 12:05:50 -0700
committerMatt Turner <mattst88@gentoo.org>2019-09-01 12:06:50 -0700
commitdddbfdc5e126305824f80274265b4601d28562ec (patch)
treecd8688294df7663350228ba1e78e478a53bfaa98 /sci-mathematics
parentmail-filter/anubis: Remove (diff)
downloadgentoo-dddbfdc5e126305824f80274265b4601d28562ec.tar.gz
gentoo-dddbfdc5e126305824f80274265b4601d28562ec.tar.bz2
gentoo-dddbfdc5e126305824f80274265b4601d28562ec.zip
sci-mathematics/drgeo: Remove
Closes: https://bugs.gentoo.org/592188 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/drgeo/Manifest2
-rw-r--r--sci-mathematics/drgeo/drgeo-1.1.0-r1.ebuild47
-rw-r--r--sci-mathematics/drgeo/files/drgeo-1.1.0-gcc45.patch61
-rw-r--r--sci-mathematics/drgeo/metadata.xml19
4 files changed, 0 insertions, 129 deletions
diff --git a/sci-mathematics/drgeo/Manifest b/sci-mathematics/drgeo/Manifest
deleted file mode 100644
index bc4719925b1c..000000000000
--- a/sci-mathematics/drgeo/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST drgeo-1.1.0.tar.gz 1608361 BLAKE2B b7c89fb5010f7e140f891c839a0ca66fa77f47814ce15097ce7e4781faeef4d2b2269a2c5b722af0d04be76adb8b1724c252387d35d382182bc27f327143be99 SHA512 6dee654e674d76e9725ddb4c8b4374c34c93a8cd367ff827f1a8816168a85cabb6341a9b8770659e15f26d3888181b0c13e9d92ee2290df664fda55bed625f6d
-DIST drgeo-doc-1.5.tar.gz 2730242 BLAKE2B fd7b0ec0c3468a1258db47fe78476661b09d49a53d3f68314c97c60d80883a638bb7515dee02191a777eee93b90b5071ab4ecba3279949b61db05832fbb3d165 SHA512 a8010eaca8e5f8aec365317aaec277a61579f217510ffe6c0585371f139f891041388437765d6e67c3373bc87267b864f159067e142f55396a782dec9a61ff54
diff --git a/sci-mathematics/drgeo/drgeo-1.1.0-r1.ebuild b/sci-mathematics/drgeo/drgeo-1.1.0-r1.ebuild
deleted file mode 100644
index c80f79a9a0cf..000000000000
--- a/sci-mathematics/drgeo/drgeo-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils
-
-DOC="${PN}-doc-1.5"
-
-DESCRIPTION="Interactive geometry package"
-HOMEPAGE="http://www.ofset.org/drgeo"
-SRC_URI="
- mirror://sourceforge/ofset/${P}.tar.gz
- mirror://sourceforge/ofset/${DOC}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="nls"
-
-RDEPEND="
- dev-libs/libxml2:2
- dev-scheme/guile:=[deprecated]
- gnome-base/libglade:2.0
- x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}"/${P}-gcc45.patch )
-
-src_configure() {
- default
- # Can't make the documentation as it depends on Hyperlatex which isn't
- # yet in portage. Fortunately HTML is already compiled for us in the
- # tarball and so can be installed. Just create the make install target.
- cd "${WORKDIR}"/${DOC} || die
- econf
-}
-
-src_install() {
- sed -i -e "s/gnome-drgenius.png/${PN}/" \
- -e '/^Categories=/s/Application;//' \
- ${PN}.desktop || die
- default
- emake -C "${WORKDIR}"/${DOC}/$(usex nls "" c) DESTDIR="${D}" install
- doicon glade/${PN}.png
-}
diff --git a/sci-mathematics/drgeo/files/drgeo-1.1.0-gcc45.patch b/sci-mathematics/drgeo/files/drgeo-1.1.0-gcc45.patch
deleted file mode 100644
index 257cbb23d111..000000000000
--- a/sci-mathematics/drgeo/files/drgeo-1.1.0-gcc45.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-Fix build with GCC 4.5, fix random SIGSEGV
-
-http://bugs.gentoo.org/show_bug.cgi?id=322211
-https://bugzilla.redhat.com/show_bug.cgi?id=454045
-
---- a/geo/drgeo_figure.h
-+++ b/geo/drgeo_figure.h
-@@ -322,4 +322,11 @@
- gboolean showGrid;
- };
-
-+struct
-+{
-+ drgeoPoint mouse;
-+ drgeoFigure *figure;
-+}
-+drgeoDialogData;
-+
- #endif
---- a/geo/drgeo_figure.cc
-+++ b/geo/drgeo_figure.cc
-@@ -48,13 +48,6 @@
- #include "drgeo_dialog.h"
- #include "traite.h"
-
--extern struct
--{
-- drgeoPoint mouse;
-- drgeoFigure *figure;
--}
--drgeoDialogData;
--
- typedef struct drgeoSearchValue
- {
- gpointer value;
-@@ -1309,7 +1302,7 @@
- gint
- drgeoFigure::preferedUndoLevel ()
- {
-- atoi (drgeoConfigGet (":undoLevel"));
-+ return atoi (drgeoConfigGet (":undoLevel"));
- }
-
- void
---- a/geo/drgeo_dialog.cc
-+++ b/geo/drgeo_dialog.cc
-@@ -38,14 +38,6 @@
- // Used in the style dialod callback, I know it's ugly, but so easy
- static drgeoFigure *selected_figure;
-
--struct
--{
-- drgeoPoint mouse;
-- drgeoFigure *figure;
--}
--drgeoDialogData;
--
--
- static void drgeo_edit_dialog_cb (GtkWidget * dialog,
- gint button, gpointer entry);
-
diff --git a/sci-mathematics/drgeo/metadata.xml b/sci-mathematics/drgeo/metadata.xml
deleted file mode 100644
index 433ad5443362..000000000000
--- a/sci-mathematics/drgeo/metadata.xml
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-mathematics@gentoo.org</email>
- <name>Gentoo Mathematics Project</name>
- </maintainer>
- <longdescription lang="en">
- Dr. Geo is a GTK2 interactive geometry software. It allows one to
- create geometric figure plus the interactive manipulation of
- such figure in respect with their geometric constraints. It is
- useable in teaching situation with students from primary or
- secondary level. It also features an integrated Scheme
- programming language to define scripts within a figure.
- </longdescription>
- <upstream>
- <remote-id type="sourceforge">ofset</remote-id>
- </upstream>
-</pkgmetadata>