summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-09-22 19:26:20 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-09-23 16:32:29 +0200
commit0e6e7d3be2e1181309ad34ef53bf86ae9bff1753 (patch)
tree8ca75d558f5b3fc783245dec054de853bd27facf /sci-physics
parentperl-core/File-Temp: Stabilize 0.231.100-r1 ppc, #940162 (diff)
downloadgentoo-0e6e7d3be2e1181309ad34ef53bf86ae9bff1753.tar.gz
gentoo-0e6e7d3be2e1181309ad34ef53bf86ae9bff1753.tar.bz2
gentoo-0e6e7d3be2e1181309ad34ef53bf86ae9bff1753.zip
sci-physics/yoda: add 2.0.1, 9999
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/yoda/Manifest1
-rw-r--r--sci-physics/yoda/yoda-2.0.1.ebuild95
-rw-r--r--sci-physics/yoda/yoda-9999.ebuild101
3 files changed, 197 insertions, 0 deletions
diff --git a/sci-physics/yoda/Manifest b/sci-physics/yoda/Manifest
index aa6f35fa911b..ce0096d11e74 100644
--- a/sci-physics/yoda/Manifest
+++ b/sci-physics/yoda/Manifest
@@ -4,3 +4,4 @@ DIST YODA-1.9.5.tar.bz2 1077442 BLAKE2B 010ab725c57dfab8160e0304d461dc44c140d1ce
DIST YODA-1.9.6.tar.bz2 1069530 BLAKE2B 23d782723c5b2429e9e9a70abe8dbf3d58a2204437a46b6e2e196cacc9b6ce55464d5600dd53492f43801866fc7da0e82d1e765cc04c493f40b2da95413aba25 SHA512 2433f2d685ccc97aa41e5f44e0c7ca560de01e3b746f2e4837ee6259cd142106e9aa0066aaa106e5298f8d4d9df3a09f5a2d058d6b1593792c9afe06b65d1a22
DIST YODA-1.9.7.tar.bz2 1084794 BLAKE2B 86a1d061c6c16ceb994878d734642fe2be18dcce4391e7f8cb57df27b5944ba4edc6573915b150993c921a4a7b5eda2b3f598b7984466f6706348ca137e4981a SHA512 923e51a5783638304841bdc7aad6351c109c1806ce3f87d1ed9d965c4c95179bb1e416c9db77e39cd8f81417d08a7668cdde4f56cd893ce528b7cf9fe0e67c01
DIST YODA-1.9.9.tar.bz2 1278231 BLAKE2B 74b759d5e152a28359ab244690a0c8e8cf10d2eb130bbf4017d602a98b28264b4f9f05842b6ef261b990e62908db6cad490aa85dde54cae3dc948eaa5f9f8440 SHA512 76e80891878712c6576cc13013b332dc48711c9b19ba1257a6c2128bdde5eb483c61f9a7d7f7946b8f0c44fd3940afe699c8dd6a45083917bf8f30351d9ce191
+DIST YODA-2.0.1.tar.bz2 1842004 BLAKE2B 56c2de8acad92510a49abab0d19568f19de3442f1f941784b85c9bded9c14f82fc2cf0eb555721cedcab81e024a9d89ffcf200b54598ed87c1d6de4c7bc59824 SHA512 abd2728e4dc76474d3bf4d478143f4b2b15a596259c49080be37269386f8353cb3f961cc850718ff8fec5d73f96377d6a9103b5bf3cc7f7c703f47c91d929549
diff --git a/sci-physics/yoda/yoda-2.0.1.ebuild b/sci-physics/yoda/yoda-2.0.1.ebuild
new file mode 100644
index 000000000000..14b1bcbf85a9
--- /dev/null
+++ b/sci-physics/yoda/yoda-2.0.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit bash-completion-r1 python-single-r1 optfeature
+
+DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
+HOMEPAGE="https://yoda.hepforge.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/hepcedar/yoda"
+else
+ SRC_URI="https://yoda.hepforge.org/downloads?f=${P^^}.tar.bz2 -> ${P^^}.tar.bz2"
+ S="${WORKDIR}/${P^^}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+IUSE="root test +python +zlib"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ) root? ( python )"
+
+RDEPEND="
+ root? ( sci-physics/root:=[${PYTHON_SINGLE_USEDEP}] )
+ python? ( ${PYTHON_DEPS} )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-python/cython-0.29.24[${PYTHON_USEDEP}]
+ ')
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ ')
+ )
+ )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ # we need to use the prefix cython here
+ econf --disable-static \
+ $(use_enable root) \
+ $(use_enable python pyext) \
+ $(use_with zlib zlib "${ESYSROOT}/usr") \
+ $(usex python CYTHON="${ESYSROOT}/usr/bin/cython")
+}
+
+src_test() {
+ # PYTESTS and SHTESTS both require python tools
+ if use python; then
+ emake check
+ else
+ emake check PYTESTS= SHTESTS= NO_PYTHON=1
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${ED}"
+
+ if use python ; then
+ newbashcomp "${ED}"/etc/bash_completion.d/${PN}-completion ${PN}-config
+ bashcomp_alias ${PN}-config \
+ ${PN}ls \
+ ${PN}diff \
+ ${PN}merge \
+ ${PN}stack \
+ ${PN}scale \
+ ${PN}plot \
+ ${PN}envelope \
+ ${PN}cnv \
+ ${PN}2root
+ rm "${ED}"/etc/bash_completion.d/${PN}-completion || die
+ python_optimize
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ optfeature "latex plotting support" virtual/latex-base
+ optfeature "python plotting support" dev-python/matplotlib
+}
diff --git a/sci-physics/yoda/yoda-9999.ebuild b/sci-physics/yoda/yoda-9999.ebuild
new file mode 100644
index 000000000000..658d4c265c1a
--- /dev/null
+++ b/sci-physics/yoda/yoda-9999.ebuild
@@ -0,0 +1,101 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit bash-completion-r1 python-single-r1 optfeature autotools
+
+DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
+HOMEPAGE="https://yoda.hepforge.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/hepcedar/yoda"
+else
+ SRC_URI="https://yoda.hepforge.org/downloads?f=${P^^}.tar.bz2 -> ${P^^}.tar.bz2"
+ S="${WORKDIR}/${P^^}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+IUSE="root test +python +zlib"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ) root? ( python )"
+
+RDEPEND="
+ root? ( sci-physics/root:=[${PYTHON_SINGLE_USEDEP}] )
+ python? ( ${PYTHON_DEPS} )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-python/cython-0.29.24[${PYTHON_USEDEP}]
+ ')
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ ')
+ )
+ )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ # reconf due to 9999 version
+ eautoreconf
+}
+
+src_configure() {
+ # we need to use the prefix cython here
+ econf --disable-static \
+ $(use_enable root) \
+ $(use_enable python pyext) \
+ $(use_with zlib zlib "${ESYSROOT}/usr") \
+ $(usex python CYTHON="${ESYSROOT}/usr/bin/cython")
+}
+
+src_test() {
+ # PYTESTS and SHTESTS both require python tools
+ if use python; then
+ emake check
+ else
+ emake check PYTESTS= SHTESTS= NO_PYTHON=1
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${ED}"
+
+ if use python ; then
+ newbashcomp "${ED}"/etc/bash_completion.d/${PN}-completion ${PN}-config
+ bashcomp_alias ${PN}-config \
+ ${PN}ls \
+ ${PN}diff \
+ ${PN}merge \
+ ${PN}stack \
+ ${PN}scale \
+ ${PN}plot \
+ ${PN}envelope \
+ ${PN}cnv \
+ ${PN}2root
+ rm "${ED}"/etc/bash_completion.d/${PN}-completion || die
+ python_optimize
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ optfeature "latex plotting support" virtual/latex-base
+ optfeature "python plotting support" dev-python/matplotlib
+}