summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2019-08-08 16:39:26 +0200
committerGuilherme Amadio <amadio@gentoo.org>2019-08-08 16:49:34 +0200
commit516351ec1f1104fee68c4e5688f47a16a8a22d30 (patch)
tree2a074ae433f8b0aa7d747f01b9fabf70f3b8d3de /sci-physics
parentx11-misc/enlightenment-extra: add correct BDEPEND (diff)
downloadgentoo-516351ec1f1104fee68c4e5688f47a16a8a22d30.tar.gz
gentoo-516351ec1f1104fee68c4e5688f47a16a8a22d30.tar.bz2
gentoo-516351ec1f1104fee68c4e5688f47a16a8a22d30.zip
sci-physics/root: add debug USE flag
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/root-6.12.06-r11.ebuild (renamed from sci-physics/root/root-6.12.06-r10.ebuild)4
-rw-r--r--sci-physics/root/root-6.14.08-r4.ebuild (renamed from sci-physics/root/root-6.14.08-r3.ebuild)14
-rw-r--r--sci-physics/root/root-6.16.00-r3.ebuild (renamed from sci-physics/root/root-6.16.00-r2.ebuild)14
-rw-r--r--sci-physics/root/root-6.18.00-r2.ebuild (renamed from sci-physics/root/root-6.18.00-r1.ebuild)12
-rw-r--r--sci-physics/root/root-9999.ebuild8
5 files changed, 26 insertions, 26 deletions
diff --git a/sci-physics/root/root-6.12.06-r10.ebuild b/sci-physics/root/root-6.12.06-r11.ebuild
index 43923b51d70d..9a28b0fd7fbd 100644
--- a/sci-physics/root/root-6.12.06-r10.ebuild
+++ b/sci-physics/root/root-6.12.06-r11.ebuild
@@ -3,7 +3,6 @@
EAPI=6
-CMAKE_BUILD_TYPE=Release
# ninja does not work due to fortran
CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
@@ -16,7 +15,7 @@ DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
-IUSE="+X aqua +asimage +davix emacs +examples fits fftw fortran
+IUSE="+X aqua +asimage +davix debug emacs +examples fits fftw fortran
+gdml graphviz +gsl http jemalloc kerberos ldap libcxx memstat
+minuit mysql nosplash odbc +opengl oracle postgres prefix pythia6
pythia8 +python qt5 R +roofit root7 shadow sqlite +ssl table +tbb
@@ -266,6 +265,7 @@ src_configure() {
${EXTRA_ECONF}
)
+ CMAKE_BUILD_TYPE=$(usex debug Debug Release) \
cmake-utils_src_configure
}
diff --git a/sci-physics/root/root-6.14.08-r3.ebuild b/sci-physics/root/root-6.14.08-r4.ebuild
index 58b0d4a14fbe..e3ab9e14f94b 100644
--- a/sci-physics/root/root-6.14.08-r3.ebuild
+++ b/sci-physics/root/root-6.14.08-r4.ebuild
@@ -3,7 +3,6 @@
EAPI=6
-CMAKE_BUILD_TYPE=Release
# ninja does not work due to fortran
CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
@@ -16,12 +15,12 @@ DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
-IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix emacs +examples
- fits fftw fortran +gdml graphviz +gsl http jemalloc kerberos ldap
- libcxx memstat +minuit mysql nosplash odbc +opengl oracle postgres
- prefix pythia6 pythia8 +python qt5 R +roofit root7 shadow sqlite
- +ssl table +tbb test +threads +tiff +tmva +unuran vc xinetd +xml
- xrootd zeroconf"
+IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix debug emacs
+ +examples fits fftw fortran +gdml graphviz +gsl http jemalloc
+ kerberos ldap libcxx memstat +minuit mysql nosplash odbc +opengl
+ oracle postgres prefix pythia6 pythia8 +python qt5 R +roofit root7
+ shadow sqlite +ssl table +tbb test +threads +tiff +tmva +unuran vc
+ xinetd +xml xrootd zeroconf"
SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
@@ -272,6 +271,7 @@ src_configure() {
${EXTRA_ECONF}
)
+ CMAKE_BUILD_TYPE=$(usex debug Debug Release) \
cmake-utils_src_configure
}
diff --git a/sci-physics/root/root-6.16.00-r2.ebuild b/sci-physics/root/root-6.16.00-r3.ebuild
index 62d33225b7aa..c57209cefee7 100644
--- a/sci-physics/root/root-6.16.00-r2.ebuild
+++ b/sci-physics/root/root-6.16.00-r3.ebuild
@@ -3,7 +3,6 @@
EAPI=6
-CMAKE_BUILD_TYPE=Release
# ninja does not work due to fortran
CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
@@ -16,12 +15,12 @@ DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
-IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix emacs +examples
- fits fftw fortran +gdml graphviz +gsl http jemalloc kerberos ldap
- libcxx memstat +minuit mysql nosplash odbc +opengl oracle postgres
- prefix pythia6 pythia8 +python qt5 R +roofit root7 shadow sqlite
- +ssl table +tbb test +threads +tiff +tmva +unuran vc xinetd +xml
- xrootd zeroconf"
+IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix debug emacs
+ +examples fits fftw fortran +gdml graphviz +gsl http jemalloc
+ kerberos ldap libcxx memstat +minuit mysql nosplash odbc +opengl
+ oracle postgres prefix pythia6 pythia8 +python qt5 R +roofit root7
+ shadow sqlite +ssl table +tbb test +threads +tiff +tmva +unuran vc
+ xinetd +xml xrootd zeroconf"
SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
@@ -275,6 +274,7 @@ src_configure() {
${EXTRA_ECONF}
)
+ CMAKE_BUILD_TYPE=$(usex debug Debug Release) \
cmake-utils_src_configure
}
diff --git a/sci-physics/root/root-6.18.00-r1.ebuild b/sci-physics/root/root-6.18.00-r2.ebuild
index a9a02ada21d2..18d23f22fd53 100644
--- a/sci-physics/root/root-6.18.00-r1.ebuild
+++ b/sci-physics/root/root-6.18.00-r2.ebuild
@@ -3,7 +3,6 @@
EAPI=6
-CMAKE_BUILD_TYPE=Release
# ninja does not work due to fortran
CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
@@ -16,11 +15,11 @@ DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
-IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix emacs +examples
- fits fftw fortran +gdml graphviz +gsl http jemalloc libcxx memstat
- +minuit mysql nosplash odbc +opengl oracle postgres prefix pythia6
- pythia8 +python qt5 R +roofit root7 shadow sqlite +ssl +tbb test
- +threads +tiff +tmva +unuran vc +vmc +xml xrootd"
+IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix debug emacs
+ +examples fits fftw fortran +gdml graphviz +gsl http jemalloc
+ libcxx memstat +minuit mysql nosplash odbc +opengl oracle postgres
+ prefix pythia6 pythia8 +python qt5 R +roofit root7 shadow sqlite
+ +ssl +tbb test +threads +tiff +tmva +unuran vc +vmc +xml xrootd"
SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
@@ -254,6 +253,7 @@ src_configure() {
${EXTRA_ECONF}
)
+ CMAKE_BUILD_TYPE=$(usex debug Debug Release) \
cmake-utils_src_configure
}
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index c537b3c26ebc..0b58a32c0138 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -3,7 +3,6 @@
EAPI=6
-CMAKE_BUILD_TYPE=Release
# ninja does not work due to fortran
CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
@@ -15,9 +14,9 @@ inherit cmake-utils cuda eapi7-ver elisp-common eutils fortran-2 \
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
-IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix emacs +examples
- fits fftw fortran +gdml graphviz +gsl http libcxx +minuit mysql
- nosplash odbc +opengl oracle postgres prefix pythia6 pythia8
+IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix debug emacs
+ +examples fits fftw fortran +gdml graphviz +gsl http libcxx +minuit
+ mysql nosplash odbc +opengl oracle postgres prefix pythia6 pythia8
+python qt5 R +roofit root7 shadow sqlite +ssl +tbb test +tmva
+unuran vc vmc +xml xrootd"
@@ -255,6 +254,7 @@ src_configure() {
${EXTRA_ECONF}
)
+ CMAKE_BUILD_TYPE=$(usex debug Debug Release) \
cmake-utils_src_configure
}