summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2023-11-06 10:45:48 -0500
committerKenton Groombridge <concord@gentoo.org>2023-11-14 16:47:24 -0500
commit1bf83bcb2351c75602b07f4b339d8e64d30ecbd8 (patch)
tree6d4db564886ee6485236a45740ee03798e3793e8 /sys-apps/bolt
parentsys-power/switcheroo-control: add USE=selinux (diff)
downloadgentoo-1bf83bcb2351c75602b07f4b339d8e64d30ecbd8.tar.gz
gentoo-1bf83bcb2351c75602b07f4b339d8e64d30ecbd8.tar.bz2
gentoo-1bf83bcb2351c75602b07f4b339d8e64d30ecbd8.zip
sys-apps/bolt: add USE=selinux
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'sys-apps/bolt')
-rw-r--r--sys-apps/bolt/bolt-0.9.1.ebuild7
-rw-r--r--sys-apps/bolt/bolt-0.9.2.ebuild5
-rw-r--r--sys-apps/bolt/bolt-0.9.3.ebuild5
3 files changed, 10 insertions, 7 deletions
diff --git a/sys-apps/bolt/bolt-0.9.1.ebuild b/sys-apps/bolt/bolt-0.9.1.ebuild
index 3c46d3566a5c..cb34716378bc 100644
--- a/sys-apps/bolt/bolt-0.9.1.ebuild
+++ b/sys-apps/bolt/bolt-0.9.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,7 @@ SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ~riscv x86"
-IUSE="doc systemd"
+IUSE="doc selinux systemd"
DEPEND="
>=dev-libs/glib-2.56.0:2
@@ -23,7 +23,8 @@ DEPEND="
sys-auth/polkit[introspection]
systemd? ( sys-apps/systemd )
doc? ( app-text/asciidoc )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-thunderbolt )"
pkg_pretend() {
if use kernel_linux && kernel_is lt 5 6; then
diff --git a/sys-apps/bolt/bolt-0.9.2.ebuild b/sys-apps/bolt/bolt-0.9.2.ebuild
index d1044fd43ad2..3275183ef322 100644
--- a/sys-apps/bolt/bolt-0.9.2.ebuild
+++ b/sys-apps/bolt/bolt-0.9.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1 GPL-2+"
SLOT="0"
KEYWORDS="amd64 ~riscv x86"
-IUSE="test"
+IUSE="selinux test"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -20,6 +20,7 @@ RDEPEND="
virtual/libudev:=
virtual/udev
sys-auth/polkit[introspection]
+ selinux? ( sec-policy/selinux-thunderbolt )
"
DEPEND="
${RDEPEND}
diff --git a/sys-apps/bolt/bolt-0.9.3.ebuild b/sys-apps/bolt/bolt-0.9.3.ebuild
index 3e80af202e25..16e2be81e05b 100644
--- a/sys-apps/bolt/bolt-0.9.3.ebuild
+++ b/sys-apps/bolt/bolt-0.9.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1 GPL-2+"
SLOT="0"
KEYWORDS="amd64 ~loong ~riscv x86"
-IUSE="test"
+IUSE="selinux test"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -20,6 +20,7 @@ RDEPEND="
virtual/libudev:=
virtual/udev
sys-auth/polkit[introspection]
+ selinux? ( sec-policy/selinux-thunderbolt )
"
DEPEND="
${RDEPEND}