summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2022-02-27 18:58:21 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2022-02-27 18:59:22 +0100
commit12b516b46793e5eee544a90e98476a201615ed97 (patch)
tree15c1065a07ab109a5fc9ad09139969bc02cc191b /sys-apps/bubblewrap
parentmail-client/aerc: 0.8.2-r1 bump (diff)
downloadgentoo-12b516b46793e5eee544a90e98476a201615ed97.tar.gz
gentoo-12b516b46793e5eee544a90e98476a201615ed97.tar.bz2
gentoo-12b516b46793e5eee544a90e98476a201615ed97.zip
sys-apps/bubblewrap: 0.6.1 version bump; switch to meson.
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'sys-apps/bubblewrap')
-rw-r--r--sys-apps/bubblewrap/Manifest1
-rw-r--r--sys-apps/bubblewrap/bubblewrap-0.6.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-apps/bubblewrap/Manifest b/sys-apps/bubblewrap/Manifest
index 558902c44023..4711dbc8c871 100644
--- a/sys-apps/bubblewrap/Manifest
+++ b/sys-apps/bubblewrap/Manifest
@@ -1 +1,2 @@
DIST bubblewrap-0.5.0.tar.xz 137796 BLAKE2B 36aef94335d61ae55076a0a94cd6f2c335a87f8df9900c0c603c7ee870cf84c617a0c2ad99a5979cc1dd22740d652155fa6049e717eb210c9a83afe516daa107 SHA512 b1f5bde9562bf3176c51fdc22304b901e00e1de5189d9b5479aed7b651b84bed5539fc5bb3b1db58a05da4a57d69c9f41c40e15aa5a575746630e015674a02b7
+DIST bubblewrap-0.6.1.tar.xz 145500 BLAKE2B 8f8f69c5314843be1ac8c52d462ce2b17fc88760274b71837793a3e8dbf87623b80b7ae094131cee896644b53f4761388638d21b1575d1887eb755880bb05845 SHA512 68e07812ff5e01de2b7a0ce66e8386ca3662fd071d4e9b4c4afa611c1589c0ed116e0ebb4c03eae3f707f908d86945e157f8b26ff872c2814889dde92df9c60b
diff --git a/sys-apps/bubblewrap/bubblewrap-0.6.1.ebuild b/sys-apps/bubblewrap/bubblewrap-0.6.1.ebuild
new file mode 100644
index 000000000000..cc06208a257a
--- /dev/null
+++ b/sys-apps/bubblewrap/bubblewrap-0.6.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 linux-info meson
+
+DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
+HOMEPAGE="https://github.com/containers/bubblewrap/"
+SRC_URI="https://github.com/containers/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="selinux +suid"
+
+RDEPEND="
+ sys-libs/libseccomp
+ sys-libs/libcap
+ selinux? ( >=sys-libs/libselinux-2.1.9 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.3
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+# tests require root priviledge
+RESTRICT="test"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ CONFIG_CHECK="~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ '-Dbash_completion=enabled'
+ '-Dman=enabled'
+ '-Dzsh_completion=enabled'
+ "$(meson_feature selinux)"
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use suid; then
+ chmod u+s "${ED}"/usr/bin/bwrap
+ fi
+}