summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/nawk/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/nawk/files')
-rw-r--r--sys-apps/nawk/files/nawk-20121220-parallel-build.patch61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/nawk/files/nawk-20121220-parallel-build.patch b/sys-apps/nawk/files/nawk-20121220-parallel-build.patch
new file mode 100644
index 000000000000..45a3e5624a40
--- /dev/null
+++ b/sys-apps/nawk/files/nawk-20121220-parallel-build.patch
@@ -0,0 +1,61 @@
+--- makefile.orig 2013-02-06 10:26:36.452829647 -0700
++++ makefile 2013-02-07 09:12:13.293898947 -0700
+@@ -44,7 +44,7 @@
+ LISTING = awk.h proto.h awkgram.y lex.c b.c main.c maketab.c parse.c \
+ lib.c run.c tran.c
+
+-SHIP = README FIXES $(SOURCE) ytab[ch].bak makefile \
++SHIP = README FIXES $(SOURCE) makefile \
+ awk.1
+
+ a.out: ytab.o $(OFILES)
+@@ -52,11 +52,15 @@
+
+ $(OFILES): awk.h ytab.h proto.h
+
+-ytab.o: awk.h proto.h awkgram.y
++#Clear dependency for parallel build: (make -j)
++#YACC generated y.tab.c and y.tab.h at the same time
++#this needs to be a static pattern rules otherwise multiple target
++#are mapped onto multiple executions of yacc, which overwrite
++#each others outputs.
++y%.c y%.h: awk.h proto.h awkgram.y
+ $(YACC) $(YFLAGS) awkgram.y
+- mv y.tab.c ytab.c
+- mv y.tab.h ytab.h
+- $(CC) $(CFLAGS) -c ytab.c
++ mv y.$*.c y$*.c
++ mv y.$*.h y$*.h
+
+ proctab.c: maketab
+ ./maketab >proctab.c
+@@ -64,23 +68,23 @@
+ maketab: ytab.h maketab.c
+ $(CC) $(CFLAGS) maketab.c -o maketab
+
+-bundle:
++bundle: $(SHIP)
+ @cp ytab.h ytabh.bak
+ @cp ytab.c ytabc.bak
+- @bundle $(SHIP)
++ @bundle $(SHIP) ytabh.bak ytabc.bak
+
+-tar:
++tar: $(SHIP)
+ @cp ytab.h ytabh.bak
+ @cp ytab.c ytabc.bak
+ @bundle $(SHIP) >awk.shar
+- @tar cf awk.tar $(SHIP)
++ @tar cf awk.tar $(SHIP) ytabh.bak ytabc.bak
+ gzip awk.tar
+ ls -l awk.tar.gz
+- @zip awk.zip $(SHIP)
++ @zip awk.zip $(SHIP) ytabh.bak ytabc.bak
+ ls -l awk.zip
+
+ names:
+ @echo $(LISTING)
+
+ clean:
+- rm -f a.out *.o *.obj maketab maketab.exe *.bb *.bbg *.da *.gcov *.gcno *.gcda # proctab.c
++ rm -f a.out *.o *.obj maketab maketab.exe *.bb *.bbg *.da *.gcov *.gcno *.gcda ytab.c ytab.h # proctab.c