summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-11-29 21:14:32 -0500
committerMatt Turner <mattst88@gentoo.org>2022-11-29 21:15:42 -0500
commit3570e4e4ef6ae182bc91f6ae0f9fbb113574feb3 (patch)
tree78dd40492b736d103200722a9970936b3738ff06 /sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.1.ebuild
parentsys-kernel/gentoo-sources: Stabilize 4.9.334 x86, #883319 (diff)
downloadgentoo-3570e4e4ef6ae182bc91f6ae0f9fbb113574feb3.tar.gz
gentoo-3570e4e4ef6ae182bc91f6ae0f9fbb113574feb3.tar.bz2
gentoo-3570e4e4ef6ae182bc91f6ae0f9fbb113574feb3.zip
sys-apps/xdg-desktop-portal-gtk: Version bump to 1.14.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.1.ebuild')
-rw-r--r--sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.1.ebuild b/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.1.ebuild
new file mode 100644
index 000000000000..011da45afd39
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+MY_PV="${PV//_pre*}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using GTK+"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal-gtk"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="wayland X"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DEPEND="
+ dev-libs/glib:2
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.14.0
+ x11-libs/cairo[X?]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[wayland?,X?]
+"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # As done in Fedora:
+ # All backends that are disabled are instead provided by
+ # xdg-desktop-portal-gnome to keep this package free of GNOME dependencies.
+ # The appchooser and settings backends are enabled for non-GNOME GTK
+ # applications.
+ local myeconfargs=(
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ --enable-appchooser
+ --enable-settings
+ --disable-background
+ --disable-lockdown
+ --disable-screencast
+ --disable-screenshot
+ --disable-wallpaper
+ )
+
+ econf "${myeconfargs[@]}"
+}