summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-22 00:31:22 +0100
committerSam James <sam@gentoo.org>2022-04-22 00:31:22 +0100
commit455656cb75b154ce41f9a5334dd8d43a729dcac8 (patch)
tree6df98a268d5326ed6ed2f7a1e44ed49b800e5128 /sys-block/parted
parentmedia-libs/libsfml: fix build with musl 1.2.3 (diff)
downloadgentoo-455656cb75b154ce41f9a5334dd8d43a729dcac8.tar.gz
gentoo-455656cb75b154ce41f9a5334dd8d43a729dcac8.tar.bz2
gentoo-455656cb75b154ce41f9a5334dd8d43a729dcac8.zip
sys-block/parted: add 3.5
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-block/parted')
-rw-r--r--sys-block/parted/Manifest2
-rw-r--r--sys-block/parted/parted-3.5.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/sys-block/parted/Manifest b/sys-block/parted/Manifest
index 3e081f596438..fea5b797d3d8 100644
--- a/sys-block/parted/Manifest
+++ b/sys-block/parted/Manifest
@@ -1,2 +1,4 @@
DIST parted-3.4.tar.xz 1860300 BLAKE2B c724d3d1490c62d440b9e5dc359fef7ff623bc77ae5f867d8905245cb279ec391fa07a1a774488ad3bf7a2c477007264d7bab2635a544be8f94dc706a654a711 SHA512 e69bd1b610778e980d4595d04892f2ea1faf4ae9bfc98cd62abfc70066423f08ddaa396f9461c7beb1330d023232274606b6b26091a0458aeedd0f3f57536690
DIST parted-3.4.tar.xz.sig 508 BLAKE2B 112ad0158b1100bd9150a7c87e8f93e67d42870b82a17d4d0aa8bb5e46306f837f3f99feabaf301f8cd640c299174e5f5acf152dd1f20ea2b7ace73d57d31f14 SHA512 6b11812267e66470ba2908ee1cc78b232b0bc2519787f5a17b92cd5f8ba904b1a836833f19c5244b23d4c7810437eeb26fbbd68fac819391b342709682345472
+DIST parted-3.5.tar.xz 1871824 BLAKE2B 5a63987f4d2c0bfd28f36112c2354f8dce7f87e962f4772bb0db34c070dd773b280959c6c33128422e8d60efe454c825401551c3c88541839b9a859a3d207f55 SHA512 87fc69e947de5f0b670ee5373a7cdf86180cd782f6d7280f970f217f73f55ee1b1b018563f48954f3a54fdde5974b33e07eee68c9ccdf08e621d3dc0e3ce126a
+DIST parted-3.5.tar.xz.sig 488 BLAKE2B 001d01be154b3c2fd232c6436d7a5d21a2d006a5b894aef1caff5297f993cae53fd6590a0eb3f40e34be5b5fcfbb20cd53d6c8949b8521f848bb7c0bde7dff0e SHA512 2ea1209325595416aa9ee27a0e85ca38bce50ca885d3b52ab1c1fb1b68b78d7887386ea3120274648056d2f1d9dca00b77236991765d84ad226c1b1f5a3f5c62
diff --git a/sys-block/parted/parted-3.5.ebuild b/sys-block/parted/parted-3.5.ebuild
new file mode 100644
index 000000000000..0f5b5f649c82
--- /dev/null
+++ b/sys-block/parted/parted-3.5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/bcl.asc
+inherit verify-sig
+
+DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
+HOMEPAGE="https://www.gnu.org/software/parted/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ verify-sig? ( mirror://gnu/${PN}/${P}.tar.xz.sig )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+debug device-mapper nls readline"
+
+# util-linux for libuuid
+RDEPEND="
+ >=sys-fs/e2fsprogs-1.27
+ sys-apps/util-linux
+ device-mapper? ( >=sys-fs/lvm2-2.02.45 )
+ readline? (
+ >=sys-libs/ncurses-5.7-r7:0=
+ >=sys-libs/readline-5.2:0=
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ nls? ( >=sys-devel/gettext-0.12.1-r2 )
+ verify-sig? ( sec-keys/openpgp-keys-bcl )
+ virtual/pkgconfig
+"
+
+DOCS=(
+ AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/{API,FAT,USER.jp}
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2-po4a-mandir.patch
+ "${FILESDIR}"/${PN}-3.3-atari.patch
+ # https://lists.gnu.org/archive/html/bug-parted/2022-02/msg00000.html
+ "${FILESDIR}"/${PN}-3.4-posix-printf.patch
+)
+
+src_prepare() {
+ default
+
+ touch doc/pt_BR/Makefile.in || die
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug)
+ $(use_enable device-mapper)
+ $(use_enable nls)
+ $(use_with readline)
+ --disable-rpath
+ --disable-static
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}