summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-29 15:41:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-29 15:41:36 +0200
commit24d7224ac9e01b3da45520f9204d4d4393f5cb4b (patch)
tree5084f641a1e34e9e56b0672fd5d3d0ead56b7d90 /sys-boot
parentx11-themes/fvwm-themes: add mv call for configure.in to fix QA warnings (diff)
downloadgentoo-24d7224ac9e01b3da45520f9204d4d4393f5cb4b.tar.gz
gentoo-24d7224ac9e01b3da45520f9204d4d4393f5cb4b.tar.bz2
gentoo-24d7224ac9e01b3da45520f9204d4d4393f5cb4b.zip
sys-boot/unetbootin: 661 version bump w/ Qt5 patch
Disabling FTP sources. See also: https://github.com/unetbootin/unetbootin/pull/137 Bug: https://bugs.gentoo.org/644360 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/unetbootin/Manifest2
-rw-r--r--sys-boot/unetbootin/unetbootin-661.ebuild97
2 files changed, 99 insertions, 0 deletions
diff --git a/sys-boot/unetbootin/Manifest b/sys-boot/unetbootin/Manifest
index b88b338d6af7..17aef8fed7e2 100644
--- a/sys-boot/unetbootin/Manifest
+++ b/sys-boot/unetbootin/Manifest
@@ -1 +1,3 @@
DIST unetbootin-657.tar.gz 16258176 BLAKE2B 7124e3a4cace41b1ca61ca468e37adc90ae7d3099f54dc5da200cc7b7d94567afa5b4a597ba7d7e3a1327951fd7e61f320bc676b72ba68c7255e9145e5791adc SHA512 69ffdbc23f372c795e84267dfbed2221783a7efc9b1d5f589e7c308384cdfd0d9cf0950058f665e2c10bf6f17e0efd3eff81a1bedb98da316583f2462dfed2d9
+DIST unetbootin-661-qt5.patch.tar.xz 8060 BLAKE2B 58cb323166e344ecabf5d372e80ff0367a1344866a6e8dea4b2677a85ea6ae0b5591480a3bcbbfc3a51d391b07adf0d5f370ee77e4c7e1d6f2b727aedf274cf0 SHA512 c1226575484fa63c94ca4da875a26c7bd64bcb27d8e07ea5b67bb3f2546f31d1360d10c363cd7301476811e332c9524c96d6ba482c894b86a5b28ca8a1c8b385
+DIST unetbootin-661.tar.gz 16257579 BLAKE2B 2f92cf286c8010a80d4d4cc48a7ece55e159af9f3729277d97eb99ef2ebe8945023d03c51d6e97d7101d8547240e3c2152004222ec4c825ef4ab954c4018e7b0 SHA512 bbf74a4c4ca9b52f4da672eb54524b7fcb796c65ba80700dc3c6f2677bde37574f42a11c213cc4d4eee38783aed650beee1e2894f60185745e509a2e9571f70a
diff --git a/sys-boot/unetbootin/unetbootin-661.ebuild b/sys-boot/unetbootin/unetbootin-661.ebuild
new file mode 100644
index 000000000000..7f9aafaf7b26
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-661.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PATCHSET="${P}-qt5.patch.tar.xz"
+inherit desktop qmake-utils
+
+DESCRIPTION="UNetbootin installs Linux/BSD distributions to a partition or USB drive"
+HOMEPAGE="https://github.com/unetbootin/unetbootin"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~asturm/distfiles/${PATCHSET}"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+UNBI_LINGUAS="
+ am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
+ ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
+ zh_CN zh_TW
+"
+
+for lingua in ${UNBI_LINGUAS}; do
+ IUSE="${IUSE} l10n_${lingua/_/-}"
+done
+
+S=${WORKDIR}/${P}/src/${PN}
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="
+ ${DEPEND}
+ app-arch/p7zip
+ sys-boot/syslinux
+ sys-fs/mtools
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-581-desktop.patch"
+ "${WORKDIR}"/${PATCHSET/.tar.xz/}
+)
+
+src_prepare() {
+ default
+
+ # QA check in case linguas are added or removed
+ enum() {
+ echo ${#}
+ }
+ [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
+ || die "Numbers of recorded and actual linguas do not match"
+ unset enum
+
+ # Remove localisations
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if ! use l10n_${lingua/_/-}; then
+ sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
+ rm ${PN}_${lingua}.ts || die
+ fi
+ done
+}
+
+src_configure() {
+ sed -i -e '/^RESOURCES/d' unetbootin.pro || die
+
+ UNBN_QTPATH="$(qt5_get_bindir)/"
+ "${UNBN_QTPATH}"lrelease ${PN}.pro || die
+
+ eqmake5 ${PN}.pro || die
+}
+
+src_install() {
+ dobin ${PN}
+
+ domenu ${PN}.desktop
+
+ for file in ${PN}*.png; do
+ size="${file/${PN}_}"
+ size="${size/.png}x${size/.png}"
+ insinto /usr/share/icons/hicolor/${size}/apps
+ newins ${file} ${PN}.png
+ done
+
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if use l10n_${lingua/_/-}; then
+ insinto /usr/share/${PN}
+ doins ${PN}_${lingua}.qm
+ fi
+ done
+}