summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2023-02-22 21:48:47 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-02-27 12:22:26 +0100
commit3e011cd6f314f2032f5e6918dbdda5b308f47edb (patch)
tree4ea6d4459556d4100c0a9b0ff8a1f4ccb6d5f145 /sys-cluster/hpx
parentapp-misc/broot: add 1.20.2 (diff)
downloadgentoo-3e011cd6f314f2032f5e6918dbdda5b308f47edb.tar.gz
gentoo-3e011cd6f314f2032f5e6918dbdda5b308f47edb.tar.bz2
gentoo-3e011cd6f314f2032f5e6918dbdda5b308f47edb.zip
sys-cluster/hpx: Fix build failure
Fix build failure due to missing header file regarding std::intmax_t. Patch taken from upstream master branch. Closes: https://bugs.gentoo.org/895212 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Closes: https://github.com/gentoo/gentoo/pull/29734 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-cluster/hpx')
-rw-r--r--sys-cluster/hpx/files/hpx-1.8.1-fix-intmax-error.patch24
-rw-r--r--sys-cluster/hpx/hpx-1.8.1.ebuild1
2 files changed, 25 insertions, 0 deletions
diff --git a/sys-cluster/hpx/files/hpx-1.8.1-fix-intmax-error.patch b/sys-cluster/hpx/files/hpx-1.8.1-fix-intmax-error.patch
new file mode 100644
index 000000000000..58d6a70a15ff
--- /dev/null
+++ b/sys-cluster/hpx/files/hpx-1.8.1-fix-intmax-error.patch
@@ -0,0 +1,24 @@
+From 9ce60348a5401fe58b6fd7333d3d7e19f0d6d8ac Mon Sep 17 00:00:00 2001
+From: Jonathan Wakely <jwakely@redhat.com>
+Date: Wed, 8 Feb 2023 12:32:11 +0000
+Subject: [PATCH] Add missing header for std::intmax_t
+
+---
+ .../include/hpx/iterator_support/counting_iterator.hpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libs/core/iterator_support/include/hpx/iterator_support/counting_iterator.hpp b/libs/core/iterator_support/include/hpx/iterator_support/counting_iterator.hpp
+index e6e6c7a99cb8..1414648cc2cf 100644
+--- a/libs/core/iterator_support/include/hpx/iterator_support/counting_iterator.hpp
++++ b/libs/core/iterator_support/include/hpx/iterator_support/counting_iterator.hpp
+@@ -18,6 +18,7 @@
+ #include <hpx/type_support/lazy_conditional.hpp>
+
+ #include <cstddef>
++#include <cstdint>
+ #include <iterator>
+ #include <type_traits>
+
+--
+2.39.2
+
diff --git a/sys-cluster/hpx/hpx-1.8.1.ebuild b/sys-cluster/hpx/hpx-1.8.1.ebuild
index 3de266f8b503..a875850567d3 100644
--- a/sys-cluster/hpx/hpx-1.8.1.ebuild
+++ b/sys-cluster/hpx/hpx-1.8.1.ebuild
@@ -47,6 +47,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-1.8.0-python.patch"
+ "${FILESDIR}/${PN}-1.8.1-fix-intmax-error.patch"
)
hpx_memory_requirement() {