summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-07 19:43:46 +0000
committerSam James <sam@gentoo.org>2022-12-07 19:49:41 +0000
commitfa5d1b16c3f24c2cf99d215aadb5228ea27a958b (patch)
treed32c275978a479f57cf60f8b1d35ce320635f3fd /sys-cluster
parentsci-libs/keras-applications: update EAPI 6 -> 8 (diff)
downloadgentoo-fa5d1b16c3f24c2cf99d215aadb5228ea27a958b.tar.gz
gentoo-fa5d1b16c3f24c2cf99d215aadb5228ea27a958b.tar.bz2
gentoo-fa5d1b16c3f24c2cf99d215aadb5228ea27a958b.zip
sys-cluster/pmix: add hwloc dep, rename pquery
Closes: https://bugs.gentoo.org/884765 Closes: https://bugs.gentoo.org/884735 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/pmix/pmix-4.2.2-r1.ebuild (renamed from sys-cluster/pmix/pmix-4.2.2.ebuild)8
1 files changed, 8 insertions, 0 deletions
diff --git a/sys-cluster/pmix/pmix-4.2.2.ebuild b/sys-cluster/pmix/pmix-4.2.2-r1.ebuild
index 4e0cde30caf9..84966f965b68 100644
--- a/sys-cluster/pmix/pmix-4.2.2.ebuild
+++ b/sys-cluster/pmix/pmix-4.2.2-r1.ebuild
@@ -14,6 +14,7 @@ IUSE="debug +munge pmi"
RDEPEND="
dev-libs/libevent:=
+ sys-apps/hwloc:=
sys-cluster/ucx
sys-libs/zlib:=
munge? ( sys-auth/munge )
@@ -27,3 +28,10 @@ src_configure() {
$(use_enable debug) \
$(use_with munge)
}
+
+src_install() {
+ default
+
+ # bug #884765
+ mv "${ED}"/usr/bin/pquery "${ED}"/usr/bin/pmix-pquery || die
+}