summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-05-07 11:14:15 -0700
committerSam James <sam@gentoo.org>2022-05-07 19:23:04 +0100
commit0fa7d95ca750542c919b710247e81b05b27b56c1 (patch)
tree8f5bcb046b11e266dd3446999642f371c6d907d1 /sys-devel
parentnet-fs/nfs-utils: Stabilize 2.6.1 ppc, #843164 (diff)
downloadgentoo-0fa7d95ca750542c919b710247e81b05b27b56c1.tar.gz
gentoo-0fa7d95ca750542c919b710247e81b05b27b56c1.tar.bz2
gentoo-0fa7d95ca750542c919b710247e81b05b27b56c1.zip
sys-devel/slibtool: Fix build with self-hosted clang
When building slibtool with a self-hosted clang as documented on the gentoo wiki the build will fail with many undefined references. The problem is because the ebuild has neglected to use --libdir and the sofort build system will then append -L/usr/lib instead of the correct -L/usr/lib64. Reference: https://wiki.gentoo.org/wiki/Clang#Bootstrapping_the_Clang_toolchain Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/25373 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/slibtool/slibtool-0.5.34.ebuild1
-rw-r--r--sys-devel/slibtool/slibtool-9999.ebuild1
2 files changed, 2 insertions, 0 deletions
diff --git a/sys-devel/slibtool/slibtool-0.5.34.ebuild b/sys-devel/slibtool/slibtool-0.5.34.ebuild
index a25f2ba8e597..c176e886d89c 100644
--- a/sys-devel/slibtool/slibtool-0.5.34.ebuild
+++ b/sys-devel/slibtool/slibtool-0.5.34.ebuild
@@ -32,5 +32,6 @@ src_configure() {
--compiler="$(tc-getCC)" \
--host=${CHOST} \
--prefix="${EPREFIX}"/usr \
+ --libdir="$(get_libdir)" \
|| die
}
diff --git a/sys-devel/slibtool/slibtool-9999.ebuild b/sys-devel/slibtool/slibtool-9999.ebuild
index 632175369588..200a19a514d4 100644
--- a/sys-devel/slibtool/slibtool-9999.ebuild
+++ b/sys-devel/slibtool/slibtool-9999.ebuild
@@ -32,5 +32,6 @@ src_configure() {
--compiler="$(tc-getCC)" \
--host=${CHOST} \
--prefix="${EPREFIX}"/usr \
+ --libdir="$(get_libdir)" \
|| die
}