summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-22 02:01:43 +0100
committerSam James <sam@gentoo.org>2024-09-22 02:01:43 +0100
commit696f6219b94c6344e73aa6f850962752a1c07950 (patch)
tree3b761dcc344c9b019235c305e318d929e57a40ea /sys-devel
parentdev-python/python-tests: Stabilize 3.12.6_p2 ppc64, #939866 (diff)
downloadgentoo-696f6219b94c6344e73aa6f850962752a1c07950.tar.gz
gentoo-696f6219b94c6344e73aa6f850962752a1c07950.tar.bz2
gentoo-696f6219b94c6344e73aa6f850962752a1c07950.zip
sys-devel/clang-common: depend on matching clang-runtime
Same rationale as 0cc229320a24ffa560d9fc101d4d73b03b7ce427, although it'll affect fewer people b/c it's only for default-compiler-rt. We may want to do this for the dep on sys-devel/clang too but the :* should make it okay too. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-15.0.7-r9.ebuild (renamed from sys-devel/clang-common/clang-common-15.0.7-r8.ebuild)2
-rw-r--r--sys-devel/clang-common/clang-common-16.0.6-r5.ebuild (renamed from sys-devel/clang-common/clang-common-16.0.6-r4.ebuild)2
-rw-r--r--sys-devel/clang-common/clang-common-17.0.6-r7.ebuild (renamed from sys-devel/clang-common/clang-common-17.0.6-r5.ebuild)2
-rw-r--r--sys-devel/clang-common/clang-common-17.0.6-r8.ebuild (renamed from sys-devel/clang-common/clang-common-17.0.6-r6.ebuild)2
-rw-r--r--sys-devel/clang-common/clang-common-18.1.8-r2.ebuild (renamed from sys-devel/clang-common/clang-common-18.1.8-r1.ebuild)2
-rw-r--r--sys-devel/clang-common/clang-common-19.1.0-r1.ebuild (renamed from sys-devel/clang-common/clang-common-19.1.0.ebuild)2
-rw-r--r--sys-devel/clang-common/clang-common-19.1.0_rc4.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-20.0.0.9999.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-20.0.0_pre20240830.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-20.0.0_pre20240910.ebuild2
-rw-r--r--sys-devel/clang-common/clang-common-20.0.0_pre20240917.ebuild2
11 files changed, 11 insertions, 11 deletions
diff --git a/sys-devel/clang-common/clang-common-15.0.7-r8.ebuild b/sys-devel/clang-common/clang-common-15.0.7-r9.ebuild
index 4d200fba7af7..3416e3b981a4 100644
--- a/sys-devel/clang-common/clang-common-15.0.7-r8.ebuild
+++ b/sys-devel/clang-common/clang-common-15.0.7-r9.ebuild
@@ -19,7 +19,7 @@ IUSE="
PDEPEND="
sys-devel/clang:*
default-compiler-rt? (
- sys-devel/clang-runtime[compiler-rt]
+ sys-devel/clang-runtime:${PV}[compiler-rt]
llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
diff --git a/sys-devel/clang-common/clang-common-16.0.6-r4.ebuild b/sys-devel/clang-common/clang-common-16.0.6-r5.ebuild
index 8185d75d346e..8f96c70ce638 100644
--- a/sys-devel/clang-common/clang-common-16.0.6-r4.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.6-r5.ebuild
@@ -19,7 +19,7 @@ IUSE="
PDEPEND="
sys-devel/clang:*
default-compiler-rt? (
- sys-devel/clang-runtime[compiler-rt]
+ sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
diff --git a/sys-devel/clang-common/clang-common-17.0.6-r5.ebuild b/sys-devel/clang-common/clang-common-17.0.6-r7.ebuild
index e736620feb37..bb6ffa025ae6 100644
--- a/sys-devel/clang-common/clang-common-17.0.6-r5.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.6-r7.ebuild
@@ -19,7 +19,7 @@ IUSE="
PDEPEND="
sys-devel/clang:*
default-compiler-rt? (
- sys-devel/clang-runtime[compiler-rt]
+ sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
diff --git a/sys-devel/clang-common/clang-common-17.0.6-r6.ebuild b/sys-devel/clang-common/clang-common-17.0.6-r8.ebuild
index 110bac527f16..4e7d8272b374 100644
--- a/sys-devel/clang-common/clang-common-17.0.6-r6.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.6-r8.ebuild
@@ -19,7 +19,7 @@ IUSE="
PDEPEND="
sys-devel/clang:*
default-compiler-rt? (
- sys-devel/clang-runtime[compiler-rt]
+ sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
diff --git a/sys-devel/clang-common/clang-common-18.1.8-r1.ebuild b/sys-devel/clang-common/clang-common-18.1.8-r2.ebuild
index e45a2de975b5..96b90d764032 100644
--- a/sys-devel/clang-common/clang-common-18.1.8-r1.ebuild
+++ b/sys-devel/clang-common/clang-common-18.1.8-r2.ebuild
@@ -19,7 +19,7 @@ IUSE="
PDEPEND="
sys-devel/clang:*
default-compiler-rt? (
- sys-devel/clang-runtime[compiler-rt]
+ sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
diff --git a/sys-devel/clang-common/clang-common-19.1.0.ebuild b/sys-devel/clang-common/clang-common-19.1.0-r1.ebuild
index 8c285440f7e4..4efa71e4b04e 100644
--- a/sys-devel/clang-common/clang-common-19.1.0.ebuild
+++ b/sys-devel/clang-common/clang-common-19.1.0-r1.ebuild
@@ -19,7 +19,7 @@ IUSE="
PDEPEND="
sys-devel/clang:*
default-compiler-rt? (
- sys-devel/clang-runtime[compiler-rt]
+ sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
diff --git a/sys-devel/clang-common/clang-common-19.1.0_rc4.ebuild b/sys-devel/clang-common/clang-common-19.1.0_rc4.ebuild
index 090a45690818..4941ce7d998c 100644
--- a/sys-devel/clang-common/clang-common-19.1.0_rc4.ebuild
+++ b/sys-devel/clang-common/clang-common-19.1.0_rc4.ebuild
@@ -18,7 +18,7 @@ IUSE="
PDEPEND="
sys-devel/clang:*
default-compiler-rt? (
- sys-devel/clang-runtime[compiler-rt]
+ sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
diff --git a/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild
index 56db34cffe17..98626b9813fa 100644
--- a/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild
@@ -18,7 +18,7 @@ IUSE="
PDEPEND="
sys-devel/clang:*
default-compiler-rt? (
- sys-devel/clang-runtime[compiler-rt]
+ sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
diff --git a/sys-devel/clang-common/clang-common-20.0.0_pre20240830.ebuild b/sys-devel/clang-common/clang-common-20.0.0_pre20240830.ebuild
index 090a45690818..4941ce7d998c 100644
--- a/sys-devel/clang-common/clang-common-20.0.0_pre20240830.ebuild
+++ b/sys-devel/clang-common/clang-common-20.0.0_pre20240830.ebuild
@@ -18,7 +18,7 @@ IUSE="
PDEPEND="
sys-devel/clang:*
default-compiler-rt? (
- sys-devel/clang-runtime[compiler-rt]
+ sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
diff --git a/sys-devel/clang-common/clang-common-20.0.0_pre20240910.ebuild b/sys-devel/clang-common/clang-common-20.0.0_pre20240910.ebuild
index 090a45690818..4941ce7d998c 100644
--- a/sys-devel/clang-common/clang-common-20.0.0_pre20240910.ebuild
+++ b/sys-devel/clang-common/clang-common-20.0.0_pre20240910.ebuild
@@ -18,7 +18,7 @@ IUSE="
PDEPEND="
sys-devel/clang:*
default-compiler-rt? (
- sys-devel/clang-runtime[compiler-rt]
+ sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)
diff --git a/sys-devel/clang-common/clang-common-20.0.0_pre20240917.ebuild b/sys-devel/clang-common/clang-common-20.0.0_pre20240917.ebuild
index 56db34cffe17..98626b9813fa 100644
--- a/sys-devel/clang-common/clang-common-20.0.0_pre20240917.ebuild
+++ b/sys-devel/clang-common/clang-common-20.0.0_pre20240917.ebuild
@@ -18,7 +18,7 @@ IUSE="
PDEPEND="
sys-devel/clang:*
default-compiler-rt? (
- sys-devel/clang-runtime[compiler-rt]
+ sys-devel/clang-runtime:${LLVM_MAJOR}[compiler-rt]
llvm-libunwind? ( sys-libs/llvm-libunwind[static-libs] )
!llvm-libunwind? ( sys-libs/libunwind[static-libs] )
)