summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-01-16 00:34:02 +0100
committerDavid Seifert <soap@gentoo.org>2022-01-16 00:34:02 +0100
commita822d01fbb93072086d6548b181c36ca9636f374 (patch)
tree241a72d1c67c180e2e6a96cc25609f8cd3f5a38e /sys-fabric
parentx11-wm/xpra: Drop old 4.2.2 (diff)
downloadgentoo-a822d01fbb93072086d6548b181c36ca9636f374.tar.gz
gentoo-a822d01fbb93072086d6548b181c36ca9636f374.tar.bz2
gentoo-a822d01fbb93072086d6548b181c36ca9636f374.zip
sys-fabric/opensm: add 3.3.24
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-fabric')
-rw-r--r--sys-fabric/opensm/Manifest1
-rw-r--r--sys-fabric/opensm/opensm-3.3.24.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/sys-fabric/opensm/Manifest b/sys-fabric/opensm/Manifest
index 2e1884a41089..db504d42dedd 100644
--- a/sys-fabric/opensm/Manifest
+++ b/sys-fabric/opensm/Manifest
@@ -1,2 +1,3 @@
DIST OFED-3.12-rc1.tgz 22055476 BLAKE2B 49e6411721392f418369a292513709f396fbb0f17001687aa15b5c0acdc91013cc67354e5978df56452178af7fbbd338a7ff408592ff9126a3045b9bb27375fe SHA512 9f834d6982ab7e8ab47a8b5c958ab2e4c238ef983e47798e7f06655f69672ea1e996297939b381f26ed8c39552f6e62156173d5ddd2f0a7b6cad6aecdd973944
DIST opensm-3.3.23.tar.gz 1357906 BLAKE2B 7f085dc1e0a1f284baf1410661aa247ef7e48cdaa696c38ef8a38d5a214e03966b54fb75c035103ac0d6ab9e0a37500d5fad51b0b52c7f5edffb3c3ddfa86eb4 SHA512 249143fcf2cac0504923992d46dfbd6821aad3da55ecc12c92b273b4e59196f88d9d1802d9f58ae6f1ace49958e0222424aea9b48e5aba519e5a5736fc51c3fe
+DIST opensm-3.3.24.tar.gz 1359599 BLAKE2B 0498ea95e83f47d2a60696bbec7242ecd5f538fa3bcdeb083a5473c3f0fd660382cd661b8bce0ac152f64bf7bcd934ca8007e7a9f528b7bd15c25af963780b85 SHA512 292449b1282008589ce6cf6a649bb64afabf359d23a8fa4afa38217801256a6a5f06912c9e463c0fdac30039aff9eceb212e8560bf05c7253c4e73080e16072e
diff --git a/sys-fabric/opensm/opensm-3.3.24.ebuild b/sys-fabric/opensm/opensm-3.3.24.ebuild
new file mode 100644
index 000000000000..b80d8348a508
--- /dev/null
+++ b/sys-fabric/opensm/opensm-3.3.24.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="OpenSM - InfiniBand Subnet Manager and Administration for OpenIB"
+HOMEPAGE="https://github.com/linux-rdma/opensm/"
+SRC_URI="https://github.com/linux-rdma/opensm/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 BSD-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="tools"
+
+DEPEND="sys-cluster/rdma-core"
+RDEPEND="${DEPEND}
+ tools? (
+ net-misc/iputils
+ net-misc/openssh
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.3.17-sldd.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-perf-mgr \
+ --enable-default-event-plugin \
+ --with-osmv="openib"
+}
+
+src_install() {
+ default
+
+ newconfd "${FILESDIR}"/opensm.conf.d opensm
+ newinitd "${FILESDIR}"/opensm.init.d.2 opensm
+
+ insinto /etc/logrotate.d
+ newins scripts/opensm.logrotate opensm
+ # we dont need this int script
+ rm "${ED}"/etc/init.d/opensmd || die "Dropping of upstream initscript failed"
+
+ if use tools; then
+ dosbin scripts/sldd.sh
+ newconfd "${FILESDIR}"/sldd.conf.d sldd
+ newinitd "${FILESDIR}"/sldd.init.d sldd
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ einfo "To automatically configure the infiniband subnet manager on boot,"
+ einfo "edit /etc/opensm.conf and add opensm to your start-up scripts:"
+ einfo "\`rc-update add opensm default\`"
+}