summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-03-03 08:32:02 -0600
committerBen Kohler <bkohler@gentoo.org>2022-03-05 13:48:45 -0600
commit0e78eae25d99b7d744c8642cc0e5cdc9b4101432 (patch)
tree4ff81858e0136ffa9a1cabe8817f6e1d8c1aa264 /sys-fs/udiskie/udiskie-2.4.2.ebuild
parentnet-misc/dropbox: bump to 143.4.4161 (diff)
downloadgentoo-0e78eae25d99b7d744c8642cc0e5cdc9b4101432.tar.gz
gentoo-0e78eae25d99b7d744c8642cc0e5cdc9b4101432.tar.bz2
gentoo-0e78eae25d99b7d744c8642cc0e5cdc9b4101432.zip
sys-fs/udiskie: bump to 2.4.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-fs/udiskie/udiskie-2.4.2.ebuild')
-rw-r--r--sys-fs/udiskie/udiskie-2.4.2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-fs/udiskie/udiskie-2.4.2.ebuild b/sys-fs/udiskie/udiskie-2.4.2.ebuild
new file mode 100644
index 000000000000..43fe883fb3af
--- /dev/null
+++ b/sys-fs/udiskie/udiskie-2.4.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7..10} )
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="An automatic disk mounting service using udisks"
+HOMEPAGE="https://pypi.org/project/udiskie/ https://github.com/coldfix/udiskie"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ sys-fs/udisks:2"
+DEPEND="app-text/asciidoc
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/python-keyutils[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:gtk-update-icon-cache:true:' setup.py || die
+ default
+
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ emake -C doc
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman doc/${PN}.8
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}