summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2023-11-05 22:43:25 +0100
committerSebastian Pipping <sping@gentoo.org>2023-11-05 22:43:25 +0100
commitfee64ee0ff112311626f1910284d70963498caa4 (patch)
treeb3c3745bb1c1827e6b81caf4cd28a07d77141c87 /sys-fs/unionfs-fuse
parentnet-mail/rss2email: Python 3.12 (diff)
downloadgentoo-fee64ee0ff112311626f1910284d70963498caa4.tar.gz
gentoo-fee64ee0ff112311626f1910284d70963498caa4.tar.bz2
gentoo-fee64ee0ff112311626f1910284d70963498caa4.zip
sys-fs/unionfs-fuse: Python 3.12 + EmptyGlobalAssignment
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'sys-fs/unionfs-fuse')
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-3.4-r1.ebuild48
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild3
2 files changed, 49 insertions, 2 deletions
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-3.4-r1.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-3.4-r1.ebuild
new file mode 100644
index 000000000000..d0d835614d1d
--- /dev/null
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-3.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{9..12} )
+inherit python-any-r1 toolchain-funcs
+
+DESCRIPTION="Self-syncing tree-merging file system based on FUSE"
+HOMEPAGE="https://github.com/rpodgorny/unionfs-fuse"
+SRC_URI="https://github.com/rpodgorny/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-fs/fuse:3"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ $(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
+ )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+python_check_deps() {
+ use test || return 0
+ python_has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}
+
+src_test() {
+ [[ -e /dev/fuse ]] || return 0
+ addwrite /dev/fuse
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
index 08cc90ee0955..8a6b2c8190a1 100644
--- a/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
@@ -3,7 +3,7 @@
EAPI="8"
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{9..12} )
inherit git-r3 python-any-r1 toolchain-funcs
DESCRIPTION="Self-syncing tree-merging file system based on FUSE"
@@ -12,7 +12,6 @@ EGIT_REPO_URI="https://github.com/rpodgorny/unionfs-fuse.git"
LICENSE="BSD"
SLOT="0"
-KEYWORDS=""
IUSE="test"
RESTRICT="!test? ( test )"