summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2022-08-31 13:35:47 +0900
committerAlice Ferrazzi <alicef@gentoo.org>2022-08-31 13:35:47 +0900
commitfe62780ba9abbbc7b1e57d919052a4c98e41608b (patch)
tree312a111b8a71fbe7ca932f378bae094fc307ebc5 /sys-kernel/rt-sources
parentapp-forensics/aflplusplus: drop 4.00c (diff)
downloadgentoo-fe62780ba9abbbc7b1e57d919052a4c98e41608b.tar.gz
gentoo-fe62780ba9abbbc7b1e57d919052a4c98e41608b.tar.bz2
gentoo-fe62780ba9abbbc7b1e57d919052a4c98e41608b.zip
sys-kernel/rt-sources: add 5.4.209_p77
Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
Diffstat (limited to 'sys-kernel/rt-sources')
-rw-r--r--sys-kernel/rt-sources/Manifest2
-rw-r--r--sys-kernel/rt-sources/rt-sources-5.4.209_p77.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-kernel/rt-sources/Manifest b/sys-kernel/rt-sources/Manifest
index 452c3dba68ca..fd53aaf47e79 100644
--- a/sys-kernel/rt-sources/Manifest
+++ b/sys-kernel/rt-sources/Manifest
@@ -12,3 +12,5 @@ DIST patch-5.15.55-rt48.patch.xz 80184 BLAKE2B 707bfc30c824b3e58a99fb6f188666a5a
DIST patch-5.15.55.xz 2199420 BLAKE2B c190a25360df8be15a33c3bcff69c86d3def4d41490d6b382eb3d5e9e09265ca29233b327e8099f73a3630b7c2c8641874fd76c03ff26d8f05c26aafd23f35a3 SHA512 ca57514bc525f1fae396ee4ff445a9c9d24e3ad8cf424a1cec39a905d85a81dc7e04f17052214cd4554301946b489e5fe3b671d35b64512c75b590b8382c29ef
DIST patch-5.4.193-rt74.patch.xz 184160 BLAKE2B 02988c8f7856292a6e56aca99b7721be85b4356c4a52218a4bddb9bd1790edccde31f367eb8abf6783aa30a08626fc1c7aabf65a1eb909e76a64dbe5661149ea SHA512 dddd2077b070566135e303cfff3687e9cd72ceb3479f9030d13caec9b29cb4ecfaf2691ed34973c5a14b431c7de8f952a4544c78e5119b1e366c1748eab6c95c
DIST patch-5.4.193.xz 3907812 BLAKE2B a9d3eb2186f8f29d2164f4b3ee1ed0339969890b0ea007c8b03a5f08d2fe6aba7239112af2c661d0e147481dcddec5931f67504f752e4aba73da1c6b5a648244 SHA512 6166943e76285ae6c48fe2ebf6d057c39c18d268869c3c03620883f3e087eb3378293799e601ca3f2e948ed24e52afac0f04df808e23d7686844ec24d812b26e
+DIST patch-5.4.209-rt77.patch.xz 183176 BLAKE2B c17a15064404b6f5ebc0a96516dddd6dbeae193202f135f6869d6bc21f259c1596210c914891c8ea27a53295559fd437333326c913225693596ef00b8e717af9 SHA512 6e0e85470b5589bc53a80f5ff217765854817c7e81bb0e482a0a60616ca2b3726d5dedb4bdc081204caca3b0d49d70e2f1cace4bcceb57489460c3bda1f01dca
+DIST patch-5.4.209.xz 4137436 BLAKE2B 97a20293ac37a7e9b1512a153da1937b0f457e3b262abff0fca39e3d2c6f0cd3371dbfdb9d0c98d2ab1d3770b963e541a9e0e1bf80ac37869a6dcbcfbf3d7ee9 SHA512 e67118e2a5fa5b9e280e2f2e3541c5eca4fe282492c5314ad0344b39dff3e796ad69ebe31c7a5f47a291986520191622d83c96110eafd562b85603833d9ced66
diff --git a/sys-kernel/rt-sources/rt-sources-5.4.209_p77.ebuild b/sys-kernel/rt-sources/rt-sources-5.4.209_p77.ebuild
new file mode 100644
index 000000000000..55e6c5d1d9b1
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-5.4.209_p77.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+KEYWORDS="~amd64 ~arm64"
+
+HOMEPAGE="https://wiki.linuxfoundation.org/realtime/start"
+
+CKV="$(ver_cut 1-3)"
+K_SECURITY_UNSUPPORTED="1"
+RT_PATCHSET="${PV/*_p}"
+
+inherit kernel-2
+detect_version
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
+RT_URI="https://www.kernel.org/pub/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \
+ https://www.kernel.org/pub/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KV_FULL="${PVR/_p/-rt}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+src_prepare() {
+ default
+
+ # 627796
+ sed \
+ "s/default PREEMPT_NONE/default PREEMPT_RT_FULL/g" \
+ -i "${S}/kernel/Kconfig.preempt" || die "sed failed"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."