summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-28 03:58:21 +0000
committerSam James <sam@gentoo.org>2023-12-28 03:58:21 +0000
commit95104945b94bbcbe3f4f684f6eb1e8cddae2a5c1 (patch)
treee9255b8ad2b6ecc40f427e953eb314398a125128 /sys-libs/libnvme/libnvme-1.3-r1.ebuild
parentdev-libs/libintl: drop 0.22-r1, 0.22.2, 0.22.3 (diff)
downloadgentoo-95104945b94bbcbe3f4f684f6eb1e8cddae2a5c1.tar.gz
gentoo-95104945b94bbcbe3f4f684f6eb1e8cddae2a5c1.tar.bz2
gentoo-95104945b94bbcbe3f4f684f6eb1e8cddae2a5c1.zip
sys-libs/libnvme: drop 1.2-r1, 1.3-r1, 1.4, 1.5-r2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/libnvme/libnvme-1.3-r1.ebuild')
-rw-r--r--sys-libs/libnvme/libnvme-1.3-r1.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/sys-libs/libnvme/libnvme-1.3-r1.ebuild b/sys-libs/libnvme/libnvme-1.3-r1.ebuild
deleted file mode 100644
index d5b333357815..000000000000
--- a/sys-libs/libnvme/libnvme-1.3-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-inherit python-r1 meson
-
-DESCRIPTION="C Library for NVM Express on Linux"
-HOMEPAGE="https://github.com/linux-nvme/libnvme"
-LICENSE="LGPL-2.1+"
-SLOT="0"
-IUSE="dbus python ssl +uuid"
-
-SRC_URI="https://github.com/linux-nvme/libnvme/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="amd64 arm64 ~loong ppc64 ~riscv x86"
-
-DEPEND="
- dev-libs/json-c:=
- dbus? ( sys-apps/dbus:= )
- python? ( ${PYTHON_DEPS} )
- ssl? ( >=dev-libs/openssl-1.1:= )
- uuid? ( sys-apps/util-linux:= )
-"
-RDEPEND="${DEPEND}"
-
-BDEPEND="
- dev-lang/swig
-"
-
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-configure-clang-16.patch
-)
-
-src_configure() {
- local emesonargs=(
- -Dpython=false
- $(meson_feature ssl openssl)
- $(meson_feature dbus libdbus)
- $(meson_use python)
- )
- meson_src_configure
-}
-
-python_compile() {
- local emesonargs=(
- -Dpython=true
- )
- meson_src_configure --reconfigure
- meson_src_compile
-}
-
-src_compile() {
- meson_src_compile
-
- if use python; then
- python_copy_sources
- python_foreach_impl python_compile
- fi
-}
-
-python_install() {
- meson_src_install
- use python && python_optimize
-}
-
-src_install() {
- use python && python_foreach_impl python_install
-
- meson_src_install
-}