summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/suacomp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/suacomp')
-rw-r--r--sys-libs/suacomp/Manifest2
-rw-r--r--sys-libs/suacomp/files/suacomp-0.6.14-strtoll.patch44
-rw-r--r--sys-libs/suacomp/metadata.xml14
-rw-r--r--sys-libs/suacomp/suacomp-0.6.13.ebuild60
-rw-r--r--sys-libs/suacomp/suacomp-0.6.14.ebuild64
-rw-r--r--sys-libs/suacomp/suacomp-9999.ebuild60
6 files changed, 244 insertions, 0 deletions
diff --git a/sys-libs/suacomp/Manifest b/sys-libs/suacomp/Manifest
new file mode 100644
index 000000000000..913c45f71c67
--- /dev/null
+++ b/sys-libs/suacomp/Manifest
@@ -0,0 +1,2 @@
+DIST suacomp-0.6.13.tar.gz 35838 SHA256 e8f488cec531dd64b797900a10e13c35758fe20bc6ef97c3da538246318afd3f
+DIST suacomp-0.6.14.tar.gz 36712 SHA256 453c64c9c6c7f255a14fa19250696e7f3acc3a72498340b76eb681eb648df1a2
diff --git a/sys-libs/suacomp/files/suacomp-0.6.14-strtoll.patch b/sys-libs/suacomp/files/suacomp-0.6.14-strtoll.patch
new file mode 100644
index 000000000000..16ee7f4e5c41
--- /dev/null
+++ b/sys-libs/suacomp/files/suacomp-0.6.14-strtoll.patch
@@ -0,0 +1,44 @@
+From a498772e5fe942eafe06ed62a00a21c4b99164b5 Mon Sep 17 00:00:00 2001
+From: David Holm <dholmster@gmail.com>
+Date: Fri, 14 Sep 2012 20:57:30 +0200
+Subject: [PATCH] Fixes build issues on SUA 6.0
+
+The prototypes for strto[u]ll.c in SUA 6.0 use C99 and are defined using (u_)quad_t. This will cause compilation to fail since there is a mismatch between stdlib.h and the implementation in suacomp. This change switches to the C99 definition and undefines strto[u]ll in case stdlib.h wants to map them to existing implementations.
+
+https://sourceforge.net/p/suacomp/tickets/1/
+---
+ strtoll.c | 3 ++-
+ strtoull.c | 3 ++-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/strtoll.c b/strtoll.c
+index 12f9886..c9e34b8 100644
+--- a/strtoll.c
++++ b/strtoll.c
+@@ -9,7 +9,8 @@
+ #include <unistd.h>
+ #include <stdlib.h>
+
+-long long int strtoll(const char* nptr, char** endptr, int base) {
++#undef strtoll
++quad_t strtoll(const char* nptr, char** endptr, int base) {
+ long long int ret;
+ DT("enter: %p, %p, %d\n", nptr, endptr, base);
+
+diff --git a/strtoull.c b/strtoull.c
+index d0e0e67..622ee9b 100644
+--- a/strtoull.c
++++ b/strtoull.c
+@@ -9,7 +9,8 @@
+ #include <unistd.h>
+ #include <stdlib.h>
+
+-long long int strtoull(const char* nptr, char** endptr, int base) {
++#undef strtoull
++u_quad_t strtoull(const char* nptr, char** endptr, int base) {
+ long long int ret;
+ DT("enter: %p, %p, %d\n", nptr, endptr, base);
+
+--
+1.7.6.1
+
diff --git a/sys-libs/suacomp/metadata.xml b/sys-libs/suacomp/metadata.xml
new file mode 100644
index 000000000000..8465ca57d980
--- /dev/null
+++ b/sys-libs/suacomp/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>haubi@gentoo.org</email>
+ <name>Michael Haubenwallner</name>
+</maintainer>
+<longdescription lang="en">
+ A small library, trying to overcome the problems occuring when building
+ (and using) gentoo-prefix on an interix based system. This has no use
+ on non-interix systems.
+</longdescription>
+</pkgmetadata>
+
diff --git a/sys-libs/suacomp/suacomp-0.6.13.ebuild b/sys-libs/suacomp/suacomp-0.6.13.ebuild
new file mode 100644
index 000000000000..34dbaf08e663
--- /dev/null
+++ b/sys-libs/suacomp/suacomp-0.6.13.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="library wrapping the interix lib-c to make it less buggy"
+HOMEPAGE="http://suacomp.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BEER-WARE"
+SLOT="0"
+KEYWORDS="-* ~x86-interix"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND=""
+
+get_opts() {
+ local shlibc=
+ local stlibc=
+
+ for dir in /usr/lib /usr/lib/x86; do
+ [[ -f ${dir}/libc.a ]] && stlibc=${dir}/libc.a
+
+ for name in libc.so.5.2 libc.so.3.5; do
+ [[ -f ${dir}/${name} ]] && { shlibc=${dir}/${name}; break; }
+ done
+
+ [[ -f ${shlibc} && -f ${stlibc} ]] && break
+ done
+
+ echo "SHARED_LIBC=${shlibc} STATIC_LIBC=${stlibc}"
+}
+
+pkg_setup() {
+ if use debug; then
+ append-flags -D_DEBUG -D_DEBUG_TRACE
+ fi
+}
+
+src_compile() {
+ emake all CC=$(tc-getCC) $(get_opts) CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}" $(get_opts) \
+ CFLAGS="${CFLAGS}" || die "emake install failed"
+}
+
+src_test() {
+ local v=
+
+ use debug && v="TEST_VERBOSE=1"
+ use debug && export SUACOMP_DEBUG_OUT=stderr
+
+ emake check $(get_opts) ${v} || die "emake check failed"
+}
diff --git a/sys-libs/suacomp/suacomp-0.6.14.ebuild b/sys-libs/suacomp/suacomp-0.6.14.ebuild
new file mode 100644
index 000000000000..9fe7f79cc5aa
--- /dev/null
+++ b/sys-libs/suacomp/suacomp-0.6.14.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="library wrapping the interix lib-c to make it less buggy"
+HOMEPAGE="http://suacomp.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BEER-WARE"
+SLOT="0"
+KEYWORDS="-* ~x86-interix"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND=""
+
+get_opts() {
+ local shlibc=
+ local stlibc=
+
+ for dir in /usr/lib /usr/lib/x86; do
+ [[ -f ${dir}/libc.a ]] && stlibc=${dir}/libc.a
+
+ for name in libc.so.5.2 libc.so.3.5; do
+ [[ -f ${dir}/${name} ]] && { shlibc=${dir}/${name}; break; }
+ done
+
+ [[ -f ${shlibc} && -f ${stlibc} ]] && break
+ done
+
+ echo "SHARED_LIBC=${shlibc} STATIC_LIBC=${stlibc}"
+}
+
+pkg_setup() {
+ if use debug; then
+ append-flags -D_DEBUG -D_DEBUG_TRACE
+ fi
+}
+
+src_prepare() {
+ [[ ${CHOST} == *-interix6* ]] && epatch "${FILESDIR}"/${P}-strtoll.patch
+}
+
+src_compile() {
+ emake all CC=$(tc-getCC) $(get_opts) CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}" $(get_opts) \
+ CFLAGS="${CFLAGS}" || die "emake install failed"
+}
+
+src_test() {
+ local v=
+
+ use debug && v="TEST_VERBOSE=1"
+ use debug && export SUACOMP_DEBUG_OUT=stderr
+
+ emake check $(get_opts) ${v} || die "emake check failed"
+}
diff --git a/sys-libs/suacomp/suacomp-9999.ebuild b/sys-libs/suacomp/suacomp-9999.ebuild
new file mode 100644
index 000000000000..6760c43633fd
--- /dev/null
+++ b/sys-libs/suacomp/suacomp-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs flag-o-matic git-2
+
+DESCRIPTION="library wrapping the interix lib-c to make it less buggy"
+HOMEPAGE="http://suacomp.sf.net"
+EGIT_REPO_URI="http://git.code.sf.net/p/suacomp/git"
+
+LICENSE="BEER-WARE"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug"
+
+DEPEND=""
+RDEPEND=""
+
+get_opts() {
+ local shlibc=
+ local stlibc=
+
+ for dir in /usr/lib /usr/lib/x86; do
+ [[ -f ${dir}/libc.a ]] && stlibc=${dir}/libc.a
+
+ for name in libc.so.5.2 libc.so.3.5; do
+ [[ -f ${dir}/${name} ]] && { shlibc=${dir}/${name}; break; }
+ done
+
+ [[ -f ${shlibc} && -f ${stlibc} ]] && break
+ done
+
+ echo "SHARED_LIBC=${shlibc} STATIC_LIBC=${stlibc}"
+}
+
+pkg_setup() {
+ if use debug; then
+ append-flags -D_DEBUG -D_DEBUG_TRACE
+ fi
+}
+
+src_compile() {
+ emake all CC=$(tc-getCC) $(get_opts) CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}" $(get_opts) \
+ CFLAGS="${CFLAGS}"
+}
+
+src_test() {
+ local v=
+
+ use debug && v="TEST_VERBOSE=1"
+ use debug && export SUACOMP_DEBUG_OUT=stderr
+
+ emake check $(get_opts) ${v}
+}