summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-10-04 09:49:02 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-10-04 09:53:07 +0200
commit032a975369ce573c4ea62004a1cac88ebd7f4491 (patch)
treed792145e9ad1b7bcafa7b8509846d12514867128 /sys-process/bottom
parentdev-build/kas: fix test fetch, #940685 (diff)
downloadgentoo-032a975369ce573c4ea62004a1cac88ebd7f4491.tar.gz
gentoo-032a975369ce573c4ea62004a1cac88ebd7f4491.tar.bz2
gentoo-032a975369ce573c4ea62004a1cac88ebd7f4491.zip
sys-process/bottom: add 0.10.2
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-process/bottom')
-rw-r--r--sys-process/bottom/Manifest1
-rw-r--r--sys-process/bottom/bottom-0.10.2.ebuild280
2 files changed, 281 insertions, 0 deletions
diff --git a/sys-process/bottom/Manifest b/sys-process/bottom/Manifest
index 11f2b15285dd..ac31bb3fb97b 100644
--- a/sys-process/bottom/Manifest
+++ b/sys-process/bottom/Manifest
@@ -30,6 +30,7 @@ DIST bitflags-1.3.2.crate 23021 BLAKE2B eb990bb27b2bdeb66fd7212ce582cb36e1c616de
DIST bitflags-2.4.0.crate 36954 BLAKE2B 1d6cfeb0a17dc53a6249a83c8c7ad7c102985ffcfd7f7f76506889684235e78fe489d23b5a5f9018f0bd526a38d6b1449784c62322fb01f4bb507c0af8bd545c SHA512 0c3d6667abea48811a792749702136ee3db97518b33bc4c7d35737505bf56315e0e5810deeea28b7a1b540ec0e21bd319ba0b3c5c4aef0ba8ed5499ffdfd9b0c
DIST bitflags-2.6.0.crate 45357 BLAKE2B 3a368bd2eb58c095b7b4a46680cc2d90a28e24b2e37c854bbf8647c861c4b8fb37eca827599673c5c7df763048149dd82123d1ede1f8a0e58a6bc23c8250f7e6 SHA512 f9bb3c48931ed7e7e05ec6d13305af5da6b6c18861ff307d7dc17c658f63972c87b70b0527287b3625c8592befc207cfe15550654995faf3862bb12a6d95bacf
DIST bottom-0.10.1.crate 225057 BLAKE2B caaf7d5fe801a63045481ab952f4a5ef4d851dffe117de32cf2c82b33a82f49dd1f8a12722d04ad40e4399aa86aa7870bb344fe10d45c70145b284b19f196225 SHA512 402f280191765a9c99e97b30ffda78b28687596c114074643735d0516203c561e637fed6c05d6d311946852ac9ac7fc404434dbbc0466188df86d2bc195e7267
+DIST bottom-0.10.2.tar.gz 3252410 BLAKE2B fdfa725ead52bfe59f0294a3e1783962d00f4c2ff7d3aa495ed3142d2a8c84ca02620b1905b9bd7b4f78e6d206c912ae5bd6884b1f691b6f6a5103723d41500f SHA512 79359181d04434bd85496392dd15eb737bc33441a0d8984b15c3caf26e60efb08d93769e499b56732f7c76a0bdb2e0ea946eee7e799de32e80e8ce0ddf4d8945
DIST bottom-0.9.6.crate 202358 BLAKE2B d3128d2966bb1190e6127b99e2459a0092417fd815310498d1ec7417cb65d7ef60a6134160d433d63d7424dd5beed814b6362ddbf2268a154854caf7d048902e SHA512 6cf258e9329d3419e8ce7f4626c4a915dc087b06ac1614208e750bc538d1bd803f18b55e9333311e4d1e2befbd78d678e58895cfbda47a3d9dacf10d85253edf
DIST bstr-1.10.0.crate 380426 BLAKE2B 19330a5a293430c09908d2174ff814351b16419f60de6463abf9b8a9dff06a4e6845e889d8047a710cef54842f2790d9cd5080b92cdcb113d89742b869979c74 SHA512 823abdbda9b13802facc7d6b1ed9ad809ed3b0b827d26e418348ffb8481b5f5735f129c5a9a8c7b2ab010d7f32ca57cba69a1ee10a64225c54c6ceacd22c05d2
DIST bstr-1.6.0.crate 385877 BLAKE2B c83895b56381b066d17bfed179fca86f69b1284299887d7590be1cf6821cb6ae21e07fdbaeac65cab4a8b2310ea18a316e25c2e5d05c0fbfb926193183cef046 SHA512 094e914ae7087caa6f340a1e26d0ca94927b1c92f0d7f907e4472b3b5c142b63b14759056d537d04be6a7901103fdd47b14f3c6315f68e8c8266155d133cb1dc
diff --git a/sys-process/bottom/bottom-0.10.2.ebuild b/sys-process/bottom/bottom-0.10.2.ebuild
new file mode 100644
index 000000000000..abd96a27fc25
--- /dev/null
+++ b/sys-process/bottom/bottom-0.10.2.ebuild
@@ -0,0 +1,280 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+ addr2line@0.22.0
+ adler@1.0.2
+ ahash@0.8.11
+ aho-corasick@1.1.3
+ allocator-api2@0.2.18
+ anstream@0.6.15
+ anstyle-parse@0.2.5
+ anstyle-query@1.1.1
+ anstyle-wincon@3.0.4
+ anstyle@1.0.8
+ anyhow@1.0.86
+ assert_cmd@2.0.15
+ autocfg@1.3.0
+ backtrace@0.3.73
+ base64@0.22.1
+ bitflags@1.3.2
+ bitflags@2.6.0
+ bstr@1.10.0
+ byteorder@1.5.0
+ cargo-husky@1.5.0
+ cassowary@0.3.0
+ castaway@0.2.3
+ cc@1.1.7
+ cfg-if@1.0.0
+ cfg_aliases@0.1.1
+ cfg_aliases@0.2.1
+ clap@4.5.13
+ clap_builder@4.5.13
+ clap_complete@4.5.12
+ clap_complete_fig@4.5.2
+ clap_complete_nushell@4.5.3
+ clap_derive@4.5.13
+ clap_lex@0.7.2
+ clap_mangen@0.2.23
+ colorchoice@1.0.2
+ compact_str@0.7.1
+ concat-string@1.0.1
+ core-foundation-sys@0.8.6
+ core-foundation@0.9.4
+ crossbeam-deque@0.8.5
+ crossbeam-epoch@0.9.18
+ crossbeam-utils@0.8.20
+ crossterm@0.27.0
+ crossterm_winapi@0.9.1
+ ctrlc@3.4.4
+ darling@0.20.10
+ darling_core@0.20.10
+ darling_macro@0.20.10
+ deranged@0.3.11
+ difflib@0.4.0
+ dirs-sys@0.4.1
+ dirs@5.0.1
+ doc-comment@0.3.3
+ downcast-rs@1.2.1
+ dyn-clone@1.0.17
+ either@1.13.0
+ enum-as-inner@0.6.0
+ equivalent@1.0.1
+ errno@0.3.9
+ fern@0.6.2
+ filedescriptor@0.8.2
+ float-cmp@0.9.0
+ fnv@1.0.7
+ getrandom@0.2.15
+ gimli@0.29.0
+ hashbrown@0.14.5
+ heck@0.4.1
+ heck@0.5.0
+ humantime@2.1.0
+ ident_case@1.0.1
+ indexmap@2.3.0
+ indoc@2.0.5
+ ioctl-rs@0.1.6
+ is_terminal_polyfill@1.70.1
+ itertools@0.13.0
+ itoa@1.0.11
+ lazy_static@1.5.0
+ lazycell@1.3.0
+ libc@0.2.155
+ libloading@0.8.5
+ libredox@0.1.3
+ linux-raw-sys@0.4.14
+ lock_api@0.4.12
+ log@0.4.22
+ lru@0.12.4
+ mach2@0.4.2
+ memchr@2.7.4
+ memoffset@0.6.5
+ miniz_oxide@0.7.4
+ mio@0.8.11
+ nix@0.25.1
+ nix@0.28.0
+ nix@0.29.0
+ normalize-line-endings@0.3.0
+ ntapi@0.4.1
+ num-conv@0.1.0
+ num-traits@0.2.19
+ num_threads@0.1.7
+ nvml-wrapper-sys@0.8.0
+ nvml-wrapper@0.10.0
+ object@0.36.2
+ once_cell@1.19.0
+ option-ext@0.2.0
+ parking_lot@0.12.3
+ parking_lot_core@0.9.10
+ paste@1.0.15
+ pin-utils@0.1.0
+ plist@1.7.0
+ portable-pty@0.8.1
+ powerfmt@0.2.0
+ predicates-core@1.0.8
+ predicates-tree@1.0.11
+ predicates@3.1.2
+ proc-macro2@1.0.86
+ quick-xml@0.32.0
+ quote@1.0.36
+ ratatui@0.27.0
+ rayon-core@1.12.1
+ rayon@1.10.0
+ redox_syscall@0.5.3
+ redox_users@0.4.5
+ regex-automata@0.4.7
+ regex-syntax@0.8.4
+ regex@1.10.5
+ roff@0.2.2
+ rustc-demangle@0.1.24
+ rustix@0.38.34
+ rustversion@1.0.17
+ ryu@1.0.18
+ same-file@1.0.6
+ schemars@0.8.21
+ schemars_derive@0.8.21
+ scopeguard@1.2.0
+ serde@1.0.204
+ serde_derive@1.0.204
+ serde_derive_internals@0.29.1
+ serde_json@1.0.121
+ serde_spanned@0.6.7
+ serial-core@0.4.0
+ serial-unix@0.4.0
+ serial-windows@0.4.0
+ serial@0.4.0
+ shared_library@0.1.9
+ shell-words@1.1.0
+ signal-hook-mio@0.2.4
+ signal-hook-registry@1.4.2
+ signal-hook@0.3.17
+ smallvec@1.13.2
+ stability@0.2.1
+ starship-battery@0.9.1
+ static_assertions@1.1.0
+ strsim@0.11.1
+ strum@0.26.3
+ strum_macros@0.26.4
+ syn@2.0.72
+ sysctl@0.5.5
+ sysinfo@0.30.13
+ terminal_size@0.3.0
+ termios@0.2.2
+ termtree@0.4.1
+ thiserror-impl@1.0.63
+ thiserror@1.0.63
+ time-core@0.1.2
+ time-macros@0.2.18
+ time@0.3.36
+ toml_datetime@0.6.8
+ toml_edit@0.22.20
+ typenum@1.17.0
+ unicode-ellipsis@0.2.0
+ unicode-ident@1.0.12
+ unicode-segmentation@1.11.0
+ unicode-truncate@1.1.0
+ unicode-width@0.1.13
+ uom@0.36.0
+ utf8parse@0.2.2
+ version_check@0.9.5
+ wait-timeout@0.2.0
+ walkdir@2.5.0
+ wasi@0.11.0+wasi-snapshot-preview1
+ winapi-i686-pc-windows-gnu@0.4.0
+ winapi-util@0.1.8
+ winapi-x86_64-pc-windows-gnu@0.4.0
+ winapi@0.3.9
+ windows-core@0.52.0
+ windows-core@0.58.0
+ windows-implement@0.58.0
+ windows-interface@0.58.0
+ windows-result@0.2.0
+ windows-strings@0.1.0
+ windows-sys@0.48.0
+ windows-sys@0.52.0
+ windows-targets@0.48.5
+ windows-targets@0.52.6
+ windows@0.52.0
+ windows@0.58.0
+ windows_aarch64_gnullvm@0.48.5
+ windows_aarch64_gnullvm@0.52.6
+ windows_aarch64_msvc@0.48.5
+ windows_aarch64_msvc@0.52.6
+ windows_i686_gnu@0.48.5
+ windows_i686_gnu@0.52.6
+ windows_i686_gnullvm@0.52.6
+ windows_i686_msvc@0.48.5
+ windows_i686_msvc@0.52.6
+ windows_x86_64_gnu@0.48.5
+ windows_x86_64_gnu@0.52.6
+ windows_x86_64_gnullvm@0.48.5
+ windows_x86_64_gnullvm@0.52.6
+ windows_x86_64_msvc@0.48.5
+ windows_x86_64_msvc@0.52.6
+ winnow@0.6.18
+ winreg@0.10.1
+ wrapcenum-derive@0.4.1
+ zerocopy-derive@0.7.35
+ zerocopy@0.7.35
+"
+
+inherit cargo shell-completion
+
+DESCRIPTION="A graphical process/system monitor with a customizable interface"
+HOMEPAGE="https://github.com/ClementTsang/bottom"
+SRC_URI="
+ https://github.com/ClementTsang/bottom/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+
+LICENSE="MIT"
+# Dependent crate licenses
+LICENSE+=" Apache-2.0 ISC MIT MPL-2.0 Unicode-DFS-2016"
+# cargo-husky-1.5.0
+LICENSE+=" MIT "
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+IUSE="+battery +gpu +zfs"
+
+# Rust packages ignore CFLAGS and LDFLAGS so let's silence the QA warnings
+QA_FLAGS_IGNORED="usr/bin/btm"
+
+src_prepare() {
+ # Stripping symbols should be the choice of the user.
+ sed -i '/strip = "symbols"/d' Cargo.toml || die "Unable to patch out symbol stripping"
+
+ default
+}
+
+src_configure() {
+ local myfeatures=(
+ $(usev battery)
+ $(usev gpu)
+ $(usev zfs)
+ )
+
+ # This will turn on generation of shell completion scripts
+ export BTM_GENERATE=true
+
+ # https://github.com/ClementTsang/bottom/blob/bacaca5548c2b23d261ef961ee6584b609529567/Cargo.toml#L63
+ # fern and log features are for debugging only, so disable default features
+ cargo_src_configure $(usev !debug --no-default-features)
+}
+
+src_install() {
+ cargo_src_install
+
+ pushd target/tmp/bottom/completion > /dev/null || die
+ newbashcomp btm.bash btm
+ dofishcomp btm.fish
+ dozshcomp _btm
+ popd > /dev/null || die
+
+ doman target/tmp/bottom/manpage/btm.1
+
+ local DOCS=( README.md )
+ einstalldocs
+}