summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-01-29 10:54:16 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-01-29 10:54:16 -0800
commit35351dba4127c200cfc7d3c21be146a43c3f2fd6 (patch)
treec8d9a3beeaa3f9c5bc4c649fda20d718f4c15bcb /sys-process/bpytop
parentsys-process/bpytop-1.0.61-r1: revbump, fix theme installation again (diff)
downloadgentoo-35351dba4127c200cfc7d3c21be146a43c3f2fd6.tar.gz
gentoo-35351dba4127c200cfc7d3c21be146a43c3f2fd6.tar.bz2
gentoo-35351dba4127c200cfc7d3c21be146a43c3f2fd6.zip
sys-process/bpytop: Remove old
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-process/bpytop')
-rw-r--r--sys-process/bpytop/Manifest1
-rw-r--r--sys-process/bpytop/bpytop-1.0.52.ebuild27
-rw-r--r--sys-process/bpytop/files/bpytop-1.0.51-tests.patch45
3 files changed, 0 insertions, 73 deletions
diff --git a/sys-process/bpytop/Manifest b/sys-process/bpytop/Manifest
index e75ecda8a442..8e28c20d0866 100644
--- a/sys-process/bpytop/Manifest
+++ b/sys-process/bpytop/Manifest
@@ -1,2 +1 @@
-DIST bpytop-1.0.52.tar.gz 616111 BLAKE2B f586189f1ae2067b1873a41235ac05f116aae5a6a965372d0ee778d714f80e6a41c163288ad1829313c0bef68f0f07235989d11351c48f4c78b953ceb4a4cb81 SHA512 68189c87890b637b9b3ff40ec4b0518a45023d3af0966cf0556c9dcc884d28660c42af37c69c06bbd03b514e198e5313fce143974ef11b67b95132070a77bfd4
DIST bpytop-1.0.61.tar.gz 626468 BLAKE2B 84a9bbaec6af27b06af53acbe2e735421de3bc4567fcf7fb29d05f801f7414b4e035e67a2fecb27a45d4d91c1d6ef527a16775f44c2e5620ecf797794969a2d2 SHA512 639e0d94bd500477b8288400c6fa1769f1b7327733bec8292e72eb3024e26f6242901970dfc539d9fb309f69299ea934e02ab93226f907ddbbefb670bffb027c
diff --git a/sys-process/bpytop/bpytop-1.0.52.ebuild b/sys-process/bpytop/bpytop-1.0.52.ebuild
deleted file mode 100644
index 0621a07dc62f..000000000000
--- a/sys-process/bpytop/bpytop-1.0.52.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-inherit distutils-r1
-
-DESCRIPTION="Linux/OSX/FreeBSD resource monitor"
-HOMEPAGE="https://github.com/aristocratos/bpytop"
-SRC_URI="https://github.com/aristocratos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/psutil-5.7.1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}/bpytop-1.0.51-tests.patch"
-)
diff --git a/sys-process/bpytop/files/bpytop-1.0.51-tests.patch b/sys-process/bpytop/files/bpytop-1.0.51-tests.patch
deleted file mode 100644
index 3e5de4751fd9..000000000000
--- a/sys-process/bpytop/files/bpytop-1.0.51-tests.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff --git a/bpytop.py b/bpytop.py
-index a1c2b3a..b1cc28e 100755
---- a/bpytop.py
-+++ b/bpytop.py
-@@ -64,23 +64,27 @@ args.add_argument("-p" , "--proc" ,action="store_true" ,help ="Start in minimal
- args.add_argument("-s" , "--stat" ,action="store_true" ,help ="Start in minimal mode without process box")
- args.add_argument("-v" , "--version" ,action="store_true" ,help ="Show version info and exit")
- args.add_argument("--debug" ,action="store_true" ,help ="Start with loglevel set to DEBUG overriding value set in config")
--stdargs = args.parse_args()
--
--if stdargs.version:
-- print(f'bpytop version: {VERSION}\n'
-- f'psutil version: {".".join(str(x) for x in psutil.version_info)}')
-- raise SystemExit(0)
-
- ARG_MODE: str = ""
-
--if stdargs.full:
-- ARG_MODE = "full"
--elif stdargs.proc:
-- ARG_MODE = "proc"
--elif stdargs.stat:
-- ARG_MODE = "stat"
-+if __name__ == "__main__":
-+ stdargs = args.parse_args()
-+
-+ if stdargs.version:
-+ print(f'bpytop version: {VERSION}\n'
-+ f'psutil version: {".".join(str(x) for x in psutil.version_info)}')
-+ raise SystemExit(0)
-
--DEBUG = stdargs.debug
-+ if stdargs.full:
-+ ARG_MODE = "full"
-+ elif stdargs.proc:
-+ ARG_MODE = "proc"
-+ elif stdargs.stat:
-+ ARG_MODE = "stat"
-+
-+ DEBUG = stdargs.debug
-+else:
-+ DEBUG = False
-
- #? Variables ------------------------------------------------------------------------------------->
-