summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-12-07 15:46:37 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-12-07 15:46:57 +0100
commitfcb9a9dd103f542b2382497615c72817ab61ad73 (patch)
tree9b33974ce23d5caa3606f332b5c99efad6c8ac9a /sys-process
parentx11-misc/grub2-theme-preview: Drop old versions causing PythonCompatUpdate (diff)
downloadgentoo-fcb9a9dd103f542b2382497615c72817ab61ad73.tar.gz
gentoo-fcb9a9dd103f542b2382497615c72817ab61ad73.tar.bz2
gentoo-fcb9a9dd103f542b2382497615c72817ab61ad73.zip
sys-process/htop: Fixed build with USE="-unicode"
Closes: https://bugs.gentoo.org/690840 Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/files/htop-3.0.3-tinfo.patch38
-rw-r--r--sys-process/htop/htop-3.0.2.ebuild4
-rw-r--r--sys-process/htop/htop-3.0.3.ebuild4
3 files changed, 45 insertions, 1 deletions
diff --git a/sys-process/htop/files/htop-3.0.3-tinfo.patch b/sys-process/htop/files/htop-3.0.3-tinfo.patch
new file mode 100644
index 000000000000..ea65a799ed7a
--- /dev/null
+++ b/sys-process/htop/files/htop-3.0.3-tinfo.patch
@@ -0,0 +1,38 @@
+From ead978bce6236a55d75b72e059686766fa708db4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Christian=20G=C3=B6ttsche?= <cgzones@googlemail.com>
+Date: Mon, 7 Dec 2020 15:30:56 +0100
+Subject: [PATCH] configure: check for additional linker flags for keypad(3)
+
+Gentoo requires an explicit addition of -ltinfo
+
+Resolves: https://bugs.gentoo.org/show_bug.cgi?id=690840
+---
+ configure.ac | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 460b16aa..f91d8e92 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -217,6 +217,10 @@ if test "x$enable_unicode" = xyes; then
+ [AC_CHECK_HEADERS([ncurses/ncurses.h],[:],
+ [AC_CHECK_HEADERS([ncurses/curses.h],[:],
+ [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])])
++
++ # check if additional linker flags are needed for keypad(3)
++ # (at this point we already link against a working ncurses library with wide character support)
++ AC_SEARCH_LIBS([keypad], [tinfow tinfo])
+ else
+ HTOP_CHECK_SCRIPT([ncurses6], [refresh], [HAVE_LIBNCURSES], "ncurses6-config",
+ HTOP_CHECK_SCRIPT([ncurses], [refresh], [HAVE_LIBNCURSES], "ncurses5-config",
+@@ -229,6 +233,10 @@ else
+ [AC_CHECK_HEADERS([ncurses/curses.h],[:],
+ [AC_CHECK_HEADERS([ncurses/ncurses.h],[:],
+ [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])])
++
++ # check if additional linker flags are needed for keypad(3)
++ # (at this point we already link against a working ncurses library)
++ AC_SEARCH_LIBS([keypad], [tinfo])
+ fi
+
+ if test "$my_htop_platform" = "freebsd"; then
diff --git a/sys-process/htop/htop-3.0.2.ebuild b/sys-process/htop/htop-3.0.2.ebuild
index a9fd130d98b2..9a0da288eaf7 100644
--- a/sys-process/htop/htop-3.0.2.ebuild
+++ b/sys-process/htop/htop-3.0.2.ebuild
@@ -25,7 +25,9 @@ DOCS=( ChangeLog README )
CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
-PATCHES=()
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.3-tinfo.patch" #690840
+)
pkg_setup() {
if ! has_version sys-process/lsof; then
diff --git a/sys-process/htop/htop-3.0.3.ebuild b/sys-process/htop/htop-3.0.3.ebuild
index 3e1ec19ce2ee..32795d9586ec 100644
--- a/sys-process/htop/htop-3.0.3.ebuild
+++ b/sys-process/htop/htop-3.0.3.ebuild
@@ -29,6 +29,10 @@ CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
S="${WORKDIR}/${P/_}"
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.3-tinfo.patch" #690840
+)
+
pkg_setup() {
if ! has_version sys-process/lsof; then
ewarn "To use lsof features in htop (what processes are accessing"