summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_authnz_persona
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_authnz_persona')
-rw-r--r--www-apache/mod_authnz_persona/Manifest1
-rw-r--r--www-apache/mod_authnz_persona/files/70_mod_authnz_persona.conf3
-rw-r--r--www-apache/mod_authnz_persona/metadata.xml11
-rw-r--r--www-apache/mod_authnz_persona/mod_authnz_persona-0.8.1.ebuild32
4 files changed, 47 insertions, 0 deletions
diff --git a/www-apache/mod_authnz_persona/Manifest b/www-apache/mod_authnz_persona/Manifest
new file mode 100644
index 000000000000..c61c771714e9
--- /dev/null
+++ b/www-apache/mod_authnz_persona/Manifest
@@ -0,0 +1 @@
+DIST mod_authnz_persona-0.8.1.tar.gz 22809 SHA256 b583f54b19aefc1c8a2bbaf9ea8e2d1170d9f1ed39fa91c7b76fdab55cfb9b39 SHA512 38e0231427509f5d6a2ee22c427040347d04c243cdb4d767990bfd4918cdb8ce1da043c8762389ca78898536fa0a86b88d52360e05367169bf86a3575a484de7 WHIRLPOOL 3e66a53cacd29e4ad4e0efb3234bd62cd051b952b1b0a2acc4bca3e2ac1dec5b00adbdce6157b881025f89c06b9247860fdaf45e68fe744af00eb8b3d2931063
diff --git a/www-apache/mod_authnz_persona/files/70_mod_authnz_persona.conf b/www-apache/mod_authnz_persona/files/70_mod_authnz_persona.conf
new file mode 100644
index 000000000000..e61f7536fa9e
--- /dev/null
+++ b/www-apache/mod_authnz_persona/files/70_mod_authnz_persona.conf
@@ -0,0 +1,3 @@
+<IfDefine PERSONA_AUTHNZ>
+LoadModule authnz_persona_module modules/mod_authnz_persona.so
+</IfDefine>
diff --git a/www-apache/mod_authnz_persona/metadata.xml b/www-apache/mod_authnz_persona/metadata.xml
new file mode 100644
index 000000000000..4dd420b5e2bc
--- /dev/null
+++ b/www-apache/mod_authnz_persona/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>djc@gentoo.org</email>
+ <name>Dirkjan Ochtman</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mozilla/mod_authnz_persona</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-apache/mod_authnz_persona/mod_authnz_persona-0.8.1.ebuild b/www-apache/mod_authnz_persona/mod_authnz_persona-0.8.1.ebuild
new file mode 100644
index 000000000000..fcd92f86ed0a
--- /dev/null
+++ b/www-apache/mod_authnz_persona/mod_authnz_persona-0.8.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit apache-module eutils
+
+DESCRIPTION="An Apache2 module for easy Persona authentication"
+HOMEPAGE="https://github.com/mozilla/mod_authnz_persona"
+SRC_URI="https://github.com/mozilla/mod_authnz_persona/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/yajl
+ net-misc/curl"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="70_${PN}"
+APACHE2_MOD_DEFINE="PERSONA_AUTHNZ"
+APACHE2_MOD_FILE="${S}/build/.libs/${PN}.so"
+
+DOCFILES="README.md"
+
+need_apache2
+
+src_compile() {
+ emake APXS_PATH="${APXS}" all
+}