summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_perl/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_perl/files')
-rw-r--r--www-apache/mod_perl/files/2.0.3/75_mod_perl.2.2.conf50
-rw-r--r--www-apache/mod_perl/files/2.0.3/75_mod_perl.conf54
-rw-r--r--www-apache/mod_perl/files/2.0.3/apache2-mod_perl-startup.pl24
-rw-r--r--www-apache/mod_perl/files/mod_perl-2.0.1-sneak-tmpdir.patch11
-rw-r--r--www-apache/mod_perl/files/mod_perl-2.0.4-inline.patch22
-rw-r--r--www-apache/mod_perl/files/mod_perl-2.0.7-bundled-Apache-Test.patch134
-rw-r--r--www-apache/mod_perl/files/mod_perl-2.0.8-bundled-Apache-Test.patch127
-rw-r--r--www-apache/mod_perl/files/use-client_ip-client_add-instead-of-remote_ip-remote.patch47
-rw-r--r--www-apache/mod_perl/files/use-log.level-instead-of-loglevel.patch27
9 files changed, 496 insertions, 0 deletions
diff --git a/www-apache/mod_perl/files/2.0.3/75_mod_perl.2.2.conf b/www-apache/mod_perl/files/2.0.3/75_mod_perl.2.2.conf
new file mode 100644
index 000000000000..596d2cc73c6e
--- /dev/null
+++ b/www-apache/mod_perl/files/2.0.3/75_mod_perl.2.2.conf
@@ -0,0 +1,50 @@
+<IfDefine PERL>
+LoadModule perl_module modules/mod_perl.so
+
+#PerlTrace all
+PerlRequire "/etc/apache2/modules.d/apache2-mod_perl-startup.pl"
+PerlModule ModPerl::Registry
+
+# Provide two aliases to the same cgi-bin directory, to see the effects of the
+# 2 different mod_perl modes for Apache2::Registry Mode
+Alias /perl/ /var/www/localhost/perl/
+# for Apache2::Perlrun Mode
+Alias /cgi-perl/ /var/www/localhost/perl/
+
+<Location /perl-status>
+ SetHandler perl-script
+ PerlResponseHandler Apache2::Status
+ Order deny,allow
+ Deny from all
+ Allow from 127.0.0.1
+</Location>
+
+<Directory /home/*/public_html/perl>
+ SetHandler perl-script
+ PerlResponseHandler ModPerl::PerlRun
+ Options -Indexes ExecCGI
+ PerlOptions +ParseHeaders
+</Directory>
+
+# set Apache::Registry Mode for /perl Alias
+<Location /perl/*.pl>
+ SetHandler perl-script
+ PerlResponseHandler ModPerl::Registry
+ Options -Indexes ExecCGI
+ PerlSendHeader On
+ Order allow,deny
+ Allow from all
+</Location>
+
+# set Apache::PerlRun Mode for /cgi-perl Alias
+<Location /cgi-perl/*.pl>
+ SetHandler perl-script
+ PerlResponseHandler ModPerl::PerlRun
+ Options -Indexes ExecCGI
+ PerlSendHeader On
+ Order allow,deny
+ Allow from all
+</Location>
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_perl/files/2.0.3/75_mod_perl.conf b/www-apache/mod_perl/files/2.0.3/75_mod_perl.conf
new file mode 100644
index 000000000000..9cf7b7b4394f
--- /dev/null
+++ b/www-apache/mod_perl/files/2.0.3/75_mod_perl.conf
@@ -0,0 +1,54 @@
+<IfDefine PERL>
+LoadModule perl_module modules/mod_perl.so
+
+#PerlTrace all
+PerlRequire "/etc/apache2/modules.d/apache2-mod_perl-startup.pl"
+PerlModule ModPerl::Registry
+
+# Provide two aliases to the same cgi-bin directory, to see the effects of the
+# 2 different mod_perl modes for Apache2::Registry Mode
+Alias /perl/ /var/www/localhost/perl/
+# for Apache2::Perlrun Mode
+Alias /cgi-perl/ /var/www/localhost/perl/
+
+<Location /perl-status>
+ SetHandler perl-script
+ PerlResponseHandler Apache2::Status
+ Require host localhost
+</Location>
+
+<Directory /home/*/public_html/perl>
+ SetHandler perl-script
+ PerlResponseHandler ModPerl::PerlRun
+ PerlOptions +ParseHeaders
+
+ # Clear all existing options and only permit cgi.
+ Options ExecCGI
+</Directory>
+
+# set Apache::Registry Mode for /perl Alias
+<Location /perl/*.pl>
+ SetHandler perl-script
+ PerlResponseHandler ModPerl::Registry
+ PerlSendHeader On
+
+ # Clear all existing options and only permit cgi.
+ Options ExecCGI
+
+ Require all granted
+</Location>
+
+# set Apache::PerlRun Mode for /cgi-perl Alias
+<Location /cgi-perl/*.pl>
+ SetHandler perl-script
+ PerlResponseHandler ModPerl::PerlRun
+ PerlSendHeader On
+
+ # Clear all existing options and only permit cgi.
+ Options ExecCGI
+
+ Require all granted
+</Location>
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_perl/files/2.0.3/apache2-mod_perl-startup.pl b/www-apache/mod_perl/files/2.0.3/apache2-mod_perl-startup.pl
new file mode 100644
index 000000000000..afc048ac125b
--- /dev/null
+++ b/www-apache/mod_perl/files/2.0.3/apache2-mod_perl-startup.pl
@@ -0,0 +1,24 @@
+use lib qw(/home/httpd/perl);
+
+# enable if the mod_perl 1.0 compatibility is needed
+#use Apache2::compat ();
+
+use ModPerl::Util (); #for CORE::GLOBAL::exit
+
+use Apache2::RequestRec ();
+use Apache2::RequestIO ();
+use Apache2::RequestUtil ();
+
+use Apache2::ServerRec ();
+use Apache2::ServerUtil ();
+use Apache2::Connection ();
+use Apache2::Log ();
+
+use APR::Table ();
+
+use ModPerl::Registry ();
+
+use Apache2::Const -compile => ':common';
+use APR::Const -compile => ':common';
+
+1;
diff --git a/www-apache/mod_perl/files/mod_perl-2.0.1-sneak-tmpdir.patch b/www-apache/mod_perl/files/mod_perl-2.0.1-sneak-tmpdir.patch
new file mode 100644
index 000000000000..0930278aeba3
--- /dev/null
+++ b/www-apache/mod_perl/files/mod_perl-2.0.1-sneak-tmpdir.patch
@@ -0,0 +1,11 @@
+--- t/conf/modperl_extra.pl.orig 2005-05-16 18:27:45.000000000 +1000
++++ t/conf/modperl_extra.pl 2005-05-16 18:34:46.000000000 +1000
+@@ -136,6 +136,8 @@
+ sub test_modperl_env {
+ # see t/response/TestModperl/env.pm
+ $ENV{MODPERL_EXTRA_PL} = __FILE__;
++ $ENV{TMPDIR} = __FILE__;
++ $ENV{TMPDIR} =~ s,/work/.*,/temp,;
+ }
+
+ 1;
diff --git a/www-apache/mod_perl/files/mod_perl-2.0.4-inline.patch b/www-apache/mod_perl/files/mod_perl-2.0.4-inline.patch
new file mode 100644
index 000000000000..5c51a803b816
--- /dev/null
+++ b/www-apache/mod_perl/files/mod_perl-2.0.4-inline.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/550244
+
+taken from Fedora:
+http://pkgs.fedoraproject.org/cgit/mod_perl.git/tree/mod_perl-2.0.4-inline.patch?h=f22
+
+fixes building with gcc-5:
+apache2: Syntax error on line 148 of /etc/apache2/httpd.conf:
+Syntax error on line 2 of /etc/apache2/modules.d/75_mod_perl.conf:
+Cannot load modules/mod_perl.so into server:
+/usr/lib64/apache2/modules/mod_perl.so: undefined symbol: modperl_handler_name
+
+--- mod_perl-2.0.4/src/modules/perl/modperl_common_util.h.inline
++++ mod_perl-2.0.4/src/modules/perl/modperl_common_util.h
+@@ -22,7 +22,7 @@
+ #ifdef MP_DEBUG
+ #define MP_INLINE
+ #else
+-#define MP_INLINE APR_INLINE
++#define MP_INLINE
+ #endif
+
+ #ifdef CYGWIN
diff --git a/www-apache/mod_perl/files/mod_perl-2.0.7-bundled-Apache-Test.patch b/www-apache/mod_perl/files/mod_perl-2.0.7-bundled-Apache-Test.patch
new file mode 100644
index 000000000000..478495e5d769
--- /dev/null
+++ b/www-apache/mod_perl/files/mod_perl-2.0.7-bundled-Apache-Test.patch
@@ -0,0 +1,134 @@
+diff --git a/Makefile.PL b/Makefile.PL
+index c4a0430..e85cf01 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -24,7 +24,7 @@ BEGIN {
+
+ }
+
+-use lib qw(lib Apache-Test/lib);
++use lib qw(lib);
+
+ use Config;
+ use File::Spec::Functions;
+@@ -117,16 +117,6 @@ sub get_DEFINE {
+ }
+
+ sub configure {
+-
+- # mod_perl test suite relies on having Apache-Test bundled with
+- # the mod_perl source, since any pre-installed version may not do
+- # the right thing
+- unless (-d "Apache-Test") {
+- error "Can't find a sub-directory Apache-Test. " .
+- "Make sure that you are using a complete source distribution";
+- exit 1;
+- }
+-
+ set_modperl_version();
+
+ if ($old_modperl_version) {
+@@ -798,14 +788,9 @@ run_tests : test_clean
+ run_subtests ::
+ cd ModPerl-Registry && $(MAKE) test
+
+-run_subtests ::
+- cd Apache-Reload && $(MAKE) test
+-
+ EOF
+
+ $preamble .= <<'EOF' unless $build->mpm_is_threaded();
+-run_subtests ::
+- cd Apache-SizeLimit && $(MAKE) test
+
+ EOF
+
+@@ -816,36 +801,6 @@ EOF
+ return $preamble;
+ }
+
+-sub MY::postamble {
+- my $self = shift;
+-
+- my $string = $self->ModPerl::BuildMM::MY::postamble;
+-
+- $string .= <<'EOF';
+-mydist : Apache-Test/META.yml mod_perl.spec manifest tardist
+-
+-rpm: dist
+- @[ -d $(PWD)/rpm ] || mkdir $(PWD)/rpm
+- rpmbuild -ta --define "_rpmdir $(PWD)/rpm" \
+- --define "_srcrpmdir $(PWD)/rpm" \
+- $(DISTVNAME).tar.gz
+- @mv $(PWD)/rpm/*/*.rpm $(PWD)/rpm/
+- @rm -rf $(PWD)/rpm/*/
+-
+-mod_perl.spec: build/make_rpm_spec
+- $(PERL) build/make_rpm_spec
+-
+-Apache-Test/META.yml:
+- cd Apache-Test && make metafile
+-
+-tag :
+- svn copy https://svn.apache.org/repos/asf/perl/modperl/branches/release/$(VERSION_SYM) https://svn.apache.org/repos/asf/perl/modperl/tags/$(VERSION_SYM)
+- svn copy https://svn.apache.org/repos/asf/perl/modperl/docs/trunk https://svn.apache.org/repos/asf/perl/modperl/docs/tags/$(VERSION_SYM)
+-EOF
+-
+- return $string;
+-}
+-
+ # this is a workaround so that ModPerl::MM will move MY::constants
+ # away, and Apache-Test/Makefile.PL which has its own MY::constants
+ # won't get complaints on MY::constants redefined
+diff --git a/ModPerl-Registry/Makefile.PL b/ModPerl-Registry/Makefile.PL
+index e72e65c..8610935 100644
+--- a/ModPerl-Registry/Makefile.PL
++++ b/ModPerl-Registry/Makefile.PL
+@@ -14,7 +14,7 @@ use Apache::TestMM qw(test clean);
+
+ # prerequisites
+ my %require = (
+- "Apache::Test" => "", # any version will do?
++ "Apache::Test" => 0, # any version will do?
+ );
+
+ my @scripts = qw(t/TEST t/SMOKE);
+diff --git a/lib/ModPerl/BuildMM.pm b/lib/ModPerl/BuildMM.pm
+index 1c729e2..8651999 100644
+--- a/lib/ModPerl/BuildMM.pm
++++ b/lib/ModPerl/BuildMM.pm
+@@ -38,12 +38,10 @@ my @methods = grep *{$stash->{$_}}{CODE}, keys %$stash;
+ ModPerl::MM::override_eu_mm_mv_all_methods(@methods);
+ use strict 'refs';
+
+-my $apache_test_dir = catdir Cwd::getcwd(), "Apache-Test", "lib";
+-
+ #to override MakeMaker MOD_INSTALL macro
+ sub mod_install {
+ q{$(PERL) -I$(INST_LIB) -I$(PERL_LIB) \\}."\n" .
+- qq{-I$apache_test_dir -MModPerl::BuildMM \\}."\n" .
++ qq{-MModPerl::BuildMM \\}."\n" .
+ q{-e "ExtUtils::Install::install({@ARGV},'$(VERBINST)',0,'$(UNINST)');"}."\n";
+ }
+
+@@ -269,7 +267,7 @@ sub ModPerl::BuildMM::MY::postamble {
+
+ push @target,
+ '$(FULLPERL) -I$(INST_LIB) ' .
+- "-I$apache_test_dir -MModPerl::BuildMM " .
++ "-MModPerl::BuildMM " .
+ "-e ModPerl::BuildMM::glue_pod $pm $podpath $blib";
+
+ # Win32 doesn't normally install man pages
+diff --git a/lib/ModPerl/Manifest.pm b/lib/ModPerl/Manifest.pm
+index 1e856bc..9f1833c 100644
+--- a/lib/ModPerl/Manifest.pm
++++ b/lib/ModPerl/Manifest.pm
+@@ -33,7 +33,6 @@ our @EXPORT_OK = qw(mkmanifest);
+ my @add_files = qw{
+ MANIFEST
+ mod_perl.spec
+- Apache-Test/META.yml
+ };
+
+ sub get_svn_files {
diff --git a/www-apache/mod_perl/files/mod_perl-2.0.8-bundled-Apache-Test.patch b/www-apache/mod_perl/files/mod_perl-2.0.8-bundled-Apache-Test.patch
new file mode 100644
index 000000000000..2e4da922aeaf
--- /dev/null
+++ b/www-apache/mod_perl/files/mod_perl-2.0.8-bundled-Apache-Test.patch
@@ -0,0 +1,127 @@
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -24,7 +24,7 @@ BEGIN {
+
+ }
+
+-use lib qw(lib Apache-Test/lib);
++use lib qw(lib);
+
+ use Config;
+ use File::Spec::Functions;
+@@ -117,16 +117,6 @@ sub get_DEFINE {
+ }
+
+ sub configure {
+-
+- # mod_perl test suite relies on having Apache-Test bundled with
+- # the mod_perl source, since any pre-installed version may not do
+- # the right thing
+- unless (-d "Apache-Test") {
+- error "Can't find a sub-directory Apache-Test. " .
+- "Make sure that you are using a complete source distribution";
+- exit 1;
+- }
+-
+ set_modperl_version();
+
+ if ($old_modperl_version) {
+@@ -798,14 +788,9 @@ run_tests : test_clean
+ run_subtests ::
+ cd ModPerl-Registry && $(MAKE) test
+
+-run_subtests ::
+- cd Apache-Reload && $(MAKE) test
+-
+ EOF
+
+ $preamble .= <<'EOF' unless $build->mpm_is_threaded();
+-run_subtests ::
+- cd Apache-SizeLimit && $(MAKE) test
+
+ EOF
+
+@@ -816,37 +801,6 @@ EOF
+ return $preamble;
+ }
+
+-sub MY::postamble {
+- my $self = shift;
+-
+- my $string = $self->ModPerl::BuildMM::MY::postamble;
+-
+- $string .= <<'EOF';
+-mydist : Apache-Test/META.yml mod_perl.spec manifest tardist
+-
+-rpm: dist
+- @[ -d $(PWD)/rpm ] || mkdir $(PWD)/rpm
+- rpmbuild -ta --define "_rpmdir $(PWD)/rpm" \
+- --define "_srcrpmdir $(PWD)/rpm" \
+- $(DISTVNAME).tar.gz
+- @mv $(PWD)/rpm/*/*.rpm $(PWD)/rpm/
+- @rm -rf $(PWD)/rpm/*/
+-
+-mod_perl.spec: build/make_rpm_spec
+- $(PERL) build/make_rpm_spec
+-
+-Apache-Test/META.yml:
+- cd Apache-Test && make metafile
+-
+-tag :
+- svn copy https://svn.apache.org/repos/asf/perl/modperl/trunk https://svn.apache.org/repos/asf/perl/modperl/branches/release/$(VERSION_SYM)
+- svn copy https://svn.apache.org/repos/asf/perl/modperl/branches/release/$(VERSION_SYM) https://svn.apache.org/repos/asf/perl/modperl/tags/$(VERSION_SYM)
+- svn copy https://svn.apache.org/repos/asf/perl/modperl/docs/trunk https://svn.apache.org/repos/asf/perl/modperl/docs/tags/$(VERSION_SYM)
+-EOF
+-
+- return $string;
+-}
+-
+ # this is a workaround so that ModPerl::MM will move MY::constants
+ # away, and Apache-Test/Makefile.PL which has its own MY::constants
+ # won't get complaints on MY::constants redefined
+--- a/ModPerl-Registry/Makefile.PL
++++ b/ModPerl-Registry/Makefile.PL
+@@ -14,7 +14,7 @@ use Apache::TestMM qw(test clean);
+
+ # prerequisites
+ my %require = (
+- "Apache::Test" => "", # any version will do?
++ "Apache::Test" => 0, # any version will do?
+ );
+
+ my @scripts = qw(t/TEST t/SMOKE);
+--- a/lib/ModPerl/BuildMM.pm
++++ b/lib/ModPerl/BuildMM.pm
+@@ -38,12 +38,10 @@ my @methods = grep *{$stash->{$_}}{CODE}
+ ModPerl::MM::override_eu_mm_mv_all_methods(@methods);
+ use strict 'refs';
+
+-my $apache_test_dir = catdir Cwd::getcwd(), "Apache-Test", "lib";
+-
+ #to override MakeMaker MOD_INSTALL macro
+ sub mod_install {
+ q{$(PERL) -I$(INST_LIB) -I$(PERL_LIB) \\}."\n" .
+- qq{-I$apache_test_dir -MModPerl::BuildMM \\}."\n" .
++ qq{-MModPerl::BuildMM \\}."\n" .
+ q{-e "ExtUtils::Install::install({@ARGV},'$(VERBINST)',0,'$(UNINST)');"}."\n";
+ }
+
+@@ -269,7 +267,7 @@ sub ModPerl::BuildMM::MY::postamble {
+
+ push @target,
+ '$(FULLPERL) -I$(INST_LIB) ' .
+- "-I$apache_test_dir -MModPerl::BuildMM " .
++ "-MModPerl::BuildMM " .
+ "-e ModPerl::BuildMM::glue_pod $pm $podpath $blib";
+
+ # Win32 doesn't normally install man pages
+--- a/lib/ModPerl/Manifest.pm
++++ b/lib/ModPerl/Manifest.pm
+@@ -33,7 +33,6 @@ our @EXPORT_OK = qw(mkmanifest);
+ my @add_files = qw{
+ MANIFEST
+ mod_perl.spec
+- Apache-Test/META.yml
+ };
+
+ sub get_svn_files {
diff --git a/www-apache/mod_perl/files/use-client_ip-client_add-instead-of-remote_ip-remote.patch b/www-apache/mod_perl/files/use-client_ip-client_add-instead-of-remote_ip-remote.patch
new file mode 100644
index 000000000000..1a695b85409c
--- /dev/null
+++ b/www-apache/mod_perl/files/use-client_ip-client_add-instead-of-remote_ip-remote.patch
@@ -0,0 +1,47 @@
+From 3fb7843aa2aa992be430068929f4e1cc7787a233 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Tue, 3 Apr 2012 19:25:41 +0200
+Subject: [PATCH] use client_ip/client_add instead of remote_ip/remote_addr
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ xs/maps/apache2_structures.map | 4 ++--
+ xs/tables/current/Apache2/StructureTable.pm | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/xs/maps/apache2_structures.map b/xs/maps/apache2_structures.map
+index f86ec93..c0fcf78 100644
+--- a/xs/maps/apache2_structures.map
++++ b/xs/maps/apache2_structures.map
+@@ -106,8 +106,8 @@ $ limit_req_fields
+ < local_addr
+ < local_ip
+ < local_host
+-< remote_addr
+- remote_ip
++< client_addr
++ client_ip
+ < remote_host
+ - remote_logname
+ < aborted
+diff --git a/xs/tables/current/Apache2/StructureTable.pm b/xs/tables/current/Apache2/StructureTable.pm
+index af50be1..0c0465a 100644
+--- a/xs/tables/current/Apache2/StructureTable.pm
++++ b/xs/tables/current/Apache2/StructureTable.pm
+@@ -2708,11 +2708,11 @@ $Apache2::StructureTable = [
+ },
+ {
+ 'type' => 'apr_sockaddr_t *',
+- 'name' => 'remote_addr'
++ 'name' => 'client_addr'
+ },
+ {
+ 'type' => 'char *',
+- 'name' => 'remote_ip'
++ 'name' => 'client_ip'
+ },
+ {
+ 'type' => 'char *',
+--
+1.7.8.5
+
diff --git a/www-apache/mod_perl/files/use-log.level-instead-of-loglevel.patch b/www-apache/mod_perl/files/use-log.level-instead-of-loglevel.patch
new file mode 100644
index 000000000000..aeb8d98af79d
--- /dev/null
+++ b/www-apache/mod_perl/files/use-log.level-instead-of-loglevel.patch
@@ -0,0 +1,27 @@
+From 0d6ac25c1c7871be52e8399c6e8bc8509ed5f3d9 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Tue, 3 Apr 2012 19:30:33 +0200
+Subject: [PATCH] use log.level instead of loglevel
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ xs/maps/apache2_structures.map | 2 +-
+ xs/tables/current/Apache2/StructureTable.pm | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/xs/tables/current/Apache2/StructureTable.pm b/xs/tables/current/Apache2/StructureTable.pm
+index 0c0465a..439184e 100644
+--- a/xs/tables/current/Apache2/StructureTable.pm
++++ b/xs/tables/current/Apache2/StructureTable.pm
+@@ -3245,7 +3245,7 @@ $Apache2::StructureTable = [
+ },
+ {
+ 'type' => 'int',
+- 'name' => 'loglevel'
++ 'name' => 'log.level'
+ },
+ {
+ 'type' => 'int',
+--
+1.7.8.5
+