summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_vhost_ldap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_vhost_ldap')
-rw-r--r--www-apache/mod_vhost_ldap/Manifest1
-rw-r--r--www-apache/mod_vhost_ldap/files/99_mod_vhost_ldap.conf10
-rw-r--r--www-apache/mod_vhost_ldap/metadata.xml5
-rw-r--r--www-apache/mod_vhost_ldap/mod_vhost_ldap-2.4.0.ebuild46
4 files changed, 62 insertions, 0 deletions
diff --git a/www-apache/mod_vhost_ldap/Manifest b/www-apache/mod_vhost_ldap/Manifest
new file mode 100644
index 000000000000..0945e28eacdd
--- /dev/null
+++ b/www-apache/mod_vhost_ldap/Manifest
@@ -0,0 +1 @@
+DIST mod_vhost_ldap-2.4.0.tar.xz 9628 SHA256 5f4394bb3b6ad8c1e380ef5a7ee3a45e8310d83beea98f228ca022f196e039d3 SHA512 b9715881ca704207fd852dfa2370dd71993bc85f390b353201aaf40c4252978e720abeda8b29b6c676f3cac66e50b67989825d7a6d3992829fbbfed725c75330 WHIRLPOOL 05dc93d086fbc90e95903dda3ec9b81ec2255667455cd09cf6fb96b3bb4e6e55a6da97f290b73f298242338e91dc378347dfea0b9e9d8d5ba493f90c2c0d2bf5
diff --git a/www-apache/mod_vhost_ldap/files/99_mod_vhost_ldap.conf b/www-apache/mod_vhost_ldap/files/99_mod_vhost_ldap.conf
new file mode 100644
index 000000000000..dd563150dcbc
--- /dev/null
+++ b/www-apache/mod_vhost_ldap/files/99_mod_vhost_ldap.conf
@@ -0,0 +1,10 @@
+<IfDefine VHOST_LDAP>
+LoadModule vhost_ldap_module modules/mod_vhost_ldap.so
+
+VhostLDAPEnabled on
+VhostLDAPUrl "ldap://127.0.0.1/ou=vhosts,ou=web,dc=localhost"
+VhostLdapBindDN "cn=admin,dc=localhost"
+VhostLDAPBindPassword "changeme"
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_vhost_ldap/metadata.xml b/www-apache/mod_vhost_ldap/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/www-apache/mod_vhost_ldap/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_vhost_ldap/mod_vhost_ldap-2.4.0.ebuild b/www-apache/mod_vhost_ldap/mod_vhost_ldap-2.4.0.ebuild
new file mode 100644
index 000000000000..e5d61228e287
--- /dev/null
+++ b/www-apache/mod_vhost_ldap/mod_vhost_ldap-2.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit apache-module depend.apache
+
+DESCRIPTION="Store and configure Apache virtual hosts using LDAP"
+HOMEPAGE="http://modvhostldap.alioth.debian.org/"
+SRC_URI="http://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+APACHE2_MOD_CONF="99_${PN}"
+APACHE2_MOD_DEFINE="VHOST_LDAP LDAP"
+
+DOCFILES="AUTHORS ChangeLog README"
+
+# apache[ldap] is needed to run, but not to compile.
+DEPEND=""
+RDEPEND="=www-servers/apache-2*[ldap]"
+
+need_apache2
+
+src_prepare() {
+ sed -i "s/MOD_VHOST_LDAP_VERSION/\"${PV}\"/g" "${PN}.c" || \
+ die "failed to sed version string"
+}
+
+src_install() {
+ apache-module_src_install
+ insinto /etc/openldap/schema
+ doins mod_vhost_ldap.schema
+}
+
+pkg_postinst() {
+ apache-module_pkg_postinst
+ einfo
+ einfo "Your LDAP server needs to include mod_vhost_ldap.schema and should"
+ einfo "also maintain indices on apacheServerName and apacheServerAlias."
+ einfo
+}