summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony Ryan <anthonyryan1@gmail.com>2024-07-11 21:07:33 -0400
committerViorel Munteanu <ceamac@gentoo.org>2024-07-12 09:47:50 +0300
commit5aa58af2cf231ebc6e6e23036903bbc57ef501f1 (patch)
treeb076aaaffc47c7757668de2d4e56372051775fd1 /www-apps
parentwww-apps/rutorrent: add 4.3.6 (diff)
downloadgentoo-5aa58af2cf231ebc6e6e23036903bbc57ef501f1.tar.gz
gentoo-5aa58af2cf231ebc6e6e23036903bbc57ef501f1.tar.bz2
gentoo-5aa58af2cf231ebc6e6e23036903bbc57ef501f1.zip
www-apps/rutorrent: drop 4.3.4
Signed-off-by: Anthony Ryan <anthonyryan1@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/37523 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/rutorrent/Manifest1
-rw-r--r--www-apps/rutorrent/rutorrent-4.3.4.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
index 4ef84da3d238..a27fac2a5a2a 100644
--- a/www-apps/rutorrent/Manifest
+++ b/www-apps/rutorrent/Manifest
@@ -1,3 +1,2 @@
-DIST rutorrent-4.3.4.tar.gz 2377757 BLAKE2B 476026f255d22bf39c94284556403e7cc3ec9ed6dc1ed04f25ac6c82c14e7be32c17dca4e542cc8354673dbf572d1b1ebf0d6af3f013b16fae07cdf31aa4a01b SHA512 b141e58584d71ec42dc6c81b19036f9927afe16c79b74a6d881ad35946fe9e1b5c9f5bdbe99b1619396b59a08501e9123e9171da50e337cea8ad05daa7a76795
DIST rutorrent-4.3.5.tar.gz 2377763 BLAKE2B 7424a45d29a7257b88a1c54b225bc287e9df4be796eb72cf112432ed06ed4fe02465815746a193f3b4cc6f47fa0929dae98166d599100ce2faf7cb563a399b4e SHA512 04694aaea5000f8dd60cc806f6352735aa4445434198aa9ab4a34c1a2070ef1e087856704f1ccddcaa8d03376da8e489dbb1ee8387f79fe9a00de8266e799d27
DIST rutorrent-4.3.6.tar.gz 2377710 BLAKE2B f3bab570ebf7e577d0587ed4fef7e1cb5c40e256f9b4bc6f8cdb603ef516ad6a666ea52314f4c3f6e0ab4991e6027e12e5d6c76320b58747eaf37d0e52e6d6a8 SHA512 bfed8e799b0261f974678f24056070339b443cd24fa53db14585d141e31237c391d51a0bb4675c39930a3288d6cd758524dc77711f7e46e3af0d1df4bbc97917
diff --git a/www-apps/rutorrent/rutorrent-4.3.4.ebuild b/www-apps/rutorrent/rutorrent-4.3.4.ebuild
deleted file mode 100644
index 97453fadf5c8..000000000000
--- a/www-apps/rutorrent/rutorrent-4.3.4.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit webapp optfeature
-
-DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
-HOMEPAGE="https://github.com/Novik/ruTorrent"
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Novik/ruTorrent.git"
-else
- SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc ~x86"
- S="${WORKDIR}/ruTorrent-${PV}"
-fi
-
-LICENSE="GPL-2+ MIT"
-
-RDEPEND="
- dev-lang/php[xml,gd]
- virtual/httpd-php
-"
-
-need_httpd_cgi
-
-pkg_setup() {
- webapp_pkg_setup
-}
-
-src_install() {
- webapp_src_preinst
-
- rm -r .github || die
- find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
- if [[ ${PV} == 9999 ]]; then
- rm -r .git .gitattributes || die
- fi
-
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- # can not use fperms beacuse of globbing
- chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
- "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
-
- keepdir "${MY_HTDOCSDIR}"/conf/users
- keepdir "${MY_HTDOCSDIR}"/share/settings
- keepdir "${MY_HTDOCSDIR}"/share/torrents
- keepdir "${MY_HTDOCSDIR}"/share/users
-
- webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
- webapp_serverowned -R "${MY_HTDOCSDIR}"/share
-
- webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
- webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
- webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
- webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
- webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
-
- webapp_src_install
-}
-
-pkg_postinst() {
- webapp_pkg_postinst
-
- optfeature "Show audio file spectogram" media-sound/sox
- optfeature "Display media file information" media-video/mediainfo
- optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
-}