summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-04 23:27:52 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-04 23:28:35 -0500
commita9dea26730b21bb7194bb04caeedcd7fd94157b7 (patch)
treed2dc3f5a650dbd0ca89064d308cdb9192531132b /www-apps
parentmedia-gfx/graphviz: Stable for HPPA PPC64 (bug #529462). (diff)
downloadgentoo-a9dea26730b21bb7194bb04caeedcd7fd94157b7.tar.gz
gentoo-a9dea26730b21bb7194bb04caeedcd7fd94157b7.tar.bz2
gentoo-a9dea26730b21bb7194bb04caeedcd7fd94157b7.zip
www-apps/icingaweb2: adding
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.0.0.ebuild66
-rw-r--r--www-apps/icingaweb2/metadata.xml14
3 files changed, 81 insertions, 0 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
new file mode 100644
index 000000000000..ef3ac07f8c9f
--- /dev/null
+++ b/www-apps/icingaweb2/Manifest
@@ -0,0 +1 @@
+DIST icingaweb2-2.0.0.tar.gz 9854668 SHA256 a6a5383049e632108ce19b4b85f16a7fdd2f5acb3a6d2af3935254e2bc7fb2e6 SHA512 fb0094b19429d7da533f05ffcb601b47a231e0d5af076775ea8a7c487b0584884172041f443851132bc27634de341190a97e76c750b529dc91b23d166e70ed58 WHIRLPOOL 2d88174296a29b576ba1d4bcf0bcf5a75d166e41c0972327c4c418d3e7bb54ebd74d5d59318c40dc9767d2271954750f9f7248072c8cced6c892a96e5ff5900a
diff --git a/www-apps/icingaweb2/icingaweb2-2.0.0.ebuild b/www-apps/icingaweb2/icingaweb2-2.0.0.ebuild
new file mode 100644
index 000000000000..99333ebc4519
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.0.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit depend.apache eutils multilib user
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 ldap mysql nginx postgres"
+KEYWORDS="~amd64"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-lang/php:*[apache2?,cli,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-php/pecl-imagick
+ apache2? ( >=www-servers/apache-2.4.0 )
+ nginx? ( >=www-servers/nginx-1.7.0:* )"
+RDEPEND="${DEPEND}"
+
+use apache2 && want_apache2
+
+pkg_setup() {
+ if use apache2 ; then
+ depend.apache_pkg_setup
+ fi
+
+ enewgroup icingaweb2
+ enewgroup icingacmd
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache2
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ mkdir -p "${D}/usr/share/${PN}"
+ cp -R "${S}"/* "${D}/usr/share/${PN}"
+ chmod -R a+rX "${D}/usr/share/${PN}/public"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config ${CATEGORY}/${PF}' to finish setup."
+}
diff --git a/www-apps/icingaweb2/metadata.xml b/www-apps/icingaweb2/metadata.xml
new file mode 100644
index 000000000000..ff36ae7481aa
--- /dev/null
+++ b/www-apps/icingaweb2/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Icinga Web 2 - Frontend for icinga2
+ </longdescription>
+ <use>
+ <flag name="nginx">Adds support for nginx</flag>
+ </use>
+</pkgmetadata>