summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Quinn <code@danielquinn.org>2015-12-16 15:36:45 +0000
committerDaniel Quinn <code@danielquinn.org>2015-12-17 01:10:25 +0000
commitc6f1f438fbcb0a81c7474fb05ddc95a45fa545a9 (patch)
tree8ef60263d3c3b8cddda6ce9b3779f6fef75ee092 /www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.0.6.ebuild
parentsys-kernel/hardened-sources: version bump to 4.3.3 (diff)
downloadgentoo-c6f1f438fbcb0a81c7474fb05ddc95a45fa545a9.tar.gz
gentoo-c6f1f438fbcb0a81c7474fb05ddc95a45fa545a9.tar.bz2
gentoo-c6f1f438fbcb0a81c7474fb05ddc95a45fa545a9.zip
www-client/ripe-atlas-cousteau: Initial commit
Diffstat (limited to 'www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.0.6.ebuild')
-rw-r--r--www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.0.6.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.0.6.ebuild b/www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.0.6.ebuild
new file mode 100644
index 000000000000..157abbe3aaf5
--- /dev/null
+++ b/www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.0.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+MY_PN=${PN//-/.}
+DESCRIPTION="A Python wrapper around the RIPE Atlas API"
+HOMEPAGE="https://atlas.ripe.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/ripe.atlas.cousteau/ripe.atlas.cousteau-${PVR}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S="${WORKDIR}/${MY_PN}-${PVR}"
+
+RDEPEND="
+ >=dev-python/socketio-client-0.6.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ "${RDEPEND}"
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
+
+python_test() {
+ nosetests --verbose || die "Tests failed with ${EPYTHON}"
+}