summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2021-08-21 17:50:47 -0500
committerJohn Helmert III <ajak@gentoo.org>2021-08-21 18:20:54 -0500
commit3389dce3eacb0fe318123ccff9be7f76e8a98ba2 (patch)
treec3b4ee0cd53599a37065c4550d2b24ec3ddf65b7 /www-misc
parentnet-misc/apt-cacher-ng: propagate some fixes to live ebuild (diff)
downloadgentoo-3389dce3eacb0fe318123ccff9be7f76e8a98ba2.tar.gz
gentoo-3389dce3eacb0fe318123ccff9be7f76e8a98ba2.tar.bz2
gentoo-3389dce3eacb0fe318123ccff9be7f76e8a98ba2.zip
www-misc/buku: python bump, fix DISTUTILS_USE_SETUPTOOLS, fix test bug
This test suite isn't compatible with pytest-verbose-parametrize, so force it to be ignored at test time. Closes: https://bugs.gentoo.org/809371 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/buku/buku-4.6-r1.ebuild (renamed from www-misc/buku/buku-4.6.ebuild)9
1 files changed, 2 insertions, 7 deletions
diff --git a/www-misc/buku/buku-4.6.ebuild b/www-misc/buku/buku-4.6-r1.ebuild
index d7dd628bd781..27a0923bc31d 100644
--- a/www-misc/buku/buku-4.6.ebuild
+++ b/www-misc/buku/buku-4.6-r1.ebuild
@@ -3,9 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9,10} )
PYTHON_REQ_USE="sqlite"
-DISTUTILS_USE_SETUPTOOLS=rdepend
inherit bash-completion-r1 distutils-r1
@@ -37,10 +36,6 @@ DEPEND="${RDEPEND}
)
"
-PATCHES=(
- #"${FILESDIR}/${P}-hypothesis-fix.patch"
-)
-
python_prepare_all() {
# Remove support for bukuserver - complex depgraph which isn't all
# sufficiently packaged in Gentoo
@@ -91,5 +86,5 @@ python_test() {
)
# tests/test_server.py is bukuserver tests, ignore it
- pytest -v --ignore tests/test_server.py ${skipped_tests[@]/#/--deselect } || die "Tests failed with ${EPYTHON}"
+ pytest -p no:verbose-parametrize -v --ignore tests/test_server.py ${skipped_tests[@]/#/--deselect } || die "Tests failed with ${EPYTHON}"
}