summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-09-02 03:25:56 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-09-02 03:25:56 +0200
commitb53f89fb0f2921c136fcba534591ba2007747900 (patch)
treede43981eb298ae8f8d6fd59e1a4b52e743be1af6 /x11-drivers
parentmedia-libs/mesa: radeonsi requires x11-libs/libdrm[video_cards_amdgpu] (diff)
downloadgentoo-b53f89fb0f2921c136fcba534591ba2007747900.tar.gz
gentoo-b53f89fb0f2921c136fcba534591ba2007747900.tar.bz2
gentoo-b53f89fb0f2921c136fcba534591ba2007747900.zip
x11-drivers/xf86-video-amdgpu: initial commit
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-amdgpu/Manifest1
-rw-r--r--x11-drivers/xf86-video-amdgpu/metadata.xml8
-rw-r--r--x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-0.0.01_pre20150814.ebuild29
-rw-r--r--x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild29
4 files changed, 67 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-amdgpu/Manifest b/x11-drivers/xf86-video-amdgpu/Manifest
new file mode 100644
index 000000000000..0c8af44e7d9f
--- /dev/null
+++ b/x11-drivers/xf86-video-amdgpu/Manifest
@@ -0,0 +1 @@
+DIST xf86-video-amdgpu-0.0.01_pre20150814.tar.xz 58024 SHA256 5654e22fcb051e04f5862576c84e8e7ab765f1097586874d3be75fefd49e159c SHA512 4885f92febd6ab1663c3b27b7db8af98eaa0d7f4c91c65e7ce8d9a8756ea0a051c65183d2d5fec3ed29b90d18de4bb81956bf585128f417a7e4471a12e2e9222 WHIRLPOOL 9b98505f0f9823661c084eaaad2e91bb2fb0956c07cf0cf22f6e4849ad9464134417f7caef9ab92c34e7881a24fabe8e6caa55300eebb3d887b04b150d42495d
diff --git a/x11-drivers/xf86-video-amdgpu/metadata.xml b/x11-drivers/xf86-video-amdgpu/metadata.xml
new file mode 100644
index 000000000000..b19c4dca8ea3
--- /dev/null
+++ b/x11-drivers/xf86-video-amdgpu/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+<use>
+ <flag name="glamor">Enable Glamor OpenGL 2D acceleration</flag>
+</use>
+</pkgmetadata>
diff --git a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-0.0.01_pre20150814.ebuild b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-0.0.01_pre20150814.ebuild
new file mode 100644
index 000000000000..7266714f6fe8
--- /dev/null
+++ b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-0.0.01_pre20150814.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+XORG_DRI="always"
+XORG_EAUTORECONF=yes
+inherit xorg-2
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Accelerated Open Source driver for AMDGPU cards"
+
+IUSE="glamor"
+
+RDEPEND="x11-libs/libdrm[video_cards_amdgpu]
+ x11-base/xorg-server[glamor(-)?]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS="$(use_enable glamor)"
+ xorg-2_src_configure
+}
diff --git a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
new file mode 100644
index 000000000000..7266714f6fe8
--- /dev/null
+++ b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+XORG_DRI="always"
+XORG_EAUTORECONF=yes
+inherit xorg-2
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Accelerated Open Source driver for AMDGPU cards"
+
+IUSE="glamor"
+
+RDEPEND="x11-libs/libdrm[video_cards_amdgpu]
+ x11-base/xorg-server[glamor(-)?]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS="$(use_enable glamor)"
+ xorg-2_src_configure
+}