summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-05-02 01:55:06 +0200
committerMatt Turner <mattst88@gentoo.org>2021-05-02 11:24:47 -0400
commit19eab8e2d4497e06e68d48281e161dc952688bc8 (patch)
treeca7a6e8ffaa5f2a70aa57803993867df2e132d38 /x11-libs
parentx11-libs/libpciaccess: Define XORG_CONFIGURE_OPTIONS in src_configure (diff)
downloadgentoo-19eab8e2d4497e06e68d48281e161dc952688bc8.tar.gz
gentoo-19eab8e2d4497e06e68d48281e161dc952688bc8.tar.bz2
gentoo-19eab8e2d4497e06e68d48281e161dc952688bc8.zip
x11-libs/libX11: Define XORG_CONFIGURE_OPTIONS in src_configure
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libX11/libX11-1.7.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/x11-libs/libX11/libX11-1.7.0.ebuild b/x11-libs/libX11/libX11-1.7.0.ebuild
index caba9f751d6a..903e051b027c 100644
--- a/x11-libs/libX11/libX11-1.7.0.ebuild
+++ b/x11-libs/libX11/libX11-1.7.0.ebuild
@@ -22,17 +22,18 @@ DEPEND="${RDEPEND}
x11-libs/xtrans"
BDEPEND="test? ( dev-lang/perl )"
-pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
$(use_with doc xmlto)
$(use_enable doc specs)
$(use_enable ipv6)
--without-fop
CPP="$(tc-getPROG CPP cpp)"
)
+ xorg-3_src_configure
}
src_install() {
xorg-3_src_install
- rm -Rf "${ED}/usr/share/X11/locale"
+ rm -rf "${ED}"/usr/share/X11/locale || die
}