summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-16 23:46:06 +0000
committerSam James <sam@gentoo.org>2022-11-16 23:46:06 +0000
commit429d6d3e55f8cbe1856ea6899b6b02aad822ce41 (patch)
treefcbc3e53e4f01c30fe7cb6c9a40a3b60ee140638 /x11-libs
parentnet-dns/updatedd: add savannah-nongnu upstream metadata (diff)
downloadgentoo-429d6d3e55f8cbe1856ea6899b6b02aad822ce41.tar.gz
gentoo-429d6d3e55f8cbe1856ea6899b6b02aad822ce41.tar.bz2
gentoo-429d6d3e55f8cbe1856ea6899b6b02aad822ce41.zip
x11-libs/libast: further Clang 16 fixes
Closes: https://bugs.gentoo.org/871705 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libast/files/libast-0.8-configure-clang16.patch65
-rw-r--r--x11-libs/libast/libast-0.8-r1.ebuild (renamed from x11-libs/libast/libast-0.8.ebuild)9
2 files changed, 72 insertions, 2 deletions
diff --git a/x11-libs/libast/files/libast-0.8-configure-clang16.patch b/x11-libs/libast/files/libast-0.8-configure-clang16.patch
new file mode 100644
index 000000000000..3d339a2aeb34
--- /dev/null
+++ b/x11-libs/libast/files/libast-0.8-configure-clang16.patch
@@ -0,0 +1,65 @@
+https://github.com/mej/libast/pull/5
+https://bugs.gentoo.org/871705
+
+From 6c50760566499ef34cfd34ee38945e2612f4f7bf Mon Sep 17 00:00:00 2001
+From: Ryan Schmidt <git@ryandesign.com>
+Date: Mon, 7 Dec 2020 01:34:46 -0600
+Subject: [PATCH] Fix implicit declaration of library function exit
+
+--- a/libast.m4
++++ b/libast.m4
+@@ -505,10 +505,10 @@ char ovbuf[7];
+ int i;
+ for (i=0; i<7; i++) ovbuf[i]='x';
+ snprintf(ovbuf, 4,"foo%s", "bar");
+-if (ovbuf[5]!='x') exit(1);
++if (ovbuf[5]!='x') return 1;
+ snprintf(ovbuf, 4,"foo%d", 666);
+-if (ovbuf[5]!='x') exit(1);
+-exit(0);
++if (ovbuf[5]!='x') return 1;
++return 0;
+ } >>
+ changequote([, ])
+ , dps_cv_snprintf_bug=0, dps_cv_snprintf_bug=1, dps_cv_snprintf_bug=2)
+@@ -550,10 +550,10 @@ int main(void)
+ char ovbuf[8] = "xxxxxxx";
+ int i;
+ prnt(ovbuf, "foo%s", "bar");
+- if (ovbuf[5]!='x') {fprintf(stderr, "buffer: %s\n", ovbuf); exit(1);}
++ if (ovbuf[5]!='x') {fprintf(stderr, "buffer: %s\n", ovbuf); return 1;}
+ prnt(ovbuf, "foo%d", 666);
+- if (ovbuf[5]!='x') {fprintf(stderr, "buffer: %s\n", ovbuf); exit(1);}
+- exit(0);
++ if (ovbuf[5]!='x') {fprintf(stderr, "buffer: %s\n", ovbuf); return 1;}
++ return 0;
+ } >>
+ changequote([, ])
+ , dps_cv_vsnprintf_bug=0, dps_cv_vsnprintf_bug=1, dps_cv_vsnprintf_bug=2)
+@@ -651,10 +651,10 @@ AC_DEFUN([dps_rlimit_nproc], [
+ AC_TRY_RUN(
+ changequote(<<, >>)dnl
+ <<
+-#ifndef HAVE_STDLIB_H
++#ifdef HAVE_STDLIB_H
+ #include <stdlib.h>
+ #endif /* HAVE_STDLIB_H */
+-#ifndef HAVE_SIGNAL_H
++#ifdef HAVE_SIGNAL_H
+ #include <signal.h>
+ #endif /* HAVE_SIGNAL_H */
+ #ifdef HAVE_UNISTD_H
+@@ -699,10 +699,10 @@ AC_DEFUN([dps_rlimit_memlock], [
+ AC_TRY_RUN(
+ changequote(<<, >>)dnl
+ <<
+-#ifndef HAVE_STDLIB_H
++#ifdef HAVE_STDLIB_H
+ #include <stdlib.h>
+ #endif /* HAVE_STDLIB_H */
+-#ifndef HAVE_SIGNAL_H
++#ifdef HAVE_SIGNAL_H
+ #include <signal.h>
+ #endif /* HAVE_SIGNAL_H */
+ #ifdef HAVE_UNISTD_H
+
diff --git a/x11-libs/libast/libast-0.8.ebuild b/x11-libs/libast/libast-0.8-r1.ebuild
index 396c0cb77b4d..a508619651b6 100644
--- a/x11-libs/libast/libast-0.8.ebuild
+++ b/x11-libs/libast/libast-0.8-r1.ebuild
@@ -16,16 +16,21 @@ IUSE="imlib cpu_flags_x86_mmx pcre"
RDEPEND="
!sci-astronomy/ast
+ media-libs/freetype
x11-base/xorg-proto
x11-libs/libXt
x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
- media-libs/freetype
imlib? ( media-libs/imlib2 )
- pcre? ( dev-libs/libpcre )"
+ pcre? ( dev-libs/libpcre )
+"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8-configure-clang16.patch
+)
+
src_prepare() {
default