summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-05-04 08:57:11 -0400
committerMatt Turner <mattst88@gentoo.org>2021-05-04 15:21:04 -0400
commit674b462afd20d8b7586262b19389914b6c15b911 (patch)
tree787ec6be011c84ec1b87d33475d15e7def29318b /x11-libs
parentmail-mta/exim: Stabilize 4.94.2 amd64, #786945 (diff)
downloadgentoo-674b462afd20d8b7586262b19389914b6c15b911.tar.gz
gentoo-674b462afd20d8b7586262b19389914b6c15b911.tar.bz2
gentoo-674b462afd20d8b7586262b19389914b6c15b911.zip
x11-libs/pango: Fix USE=-gtk-doc issues
This prevents pango from installing its own bundled gi-docgen when it's not installed as a dependency, and it avoids trying to rename a missing documentation directory. Closes: https://bugs.gentoo.org/788091 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pango/pango-1.48.4.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-libs/pango/pango-1.48.4.ebuild b/x11-libs/pango/pango-1.48.4.ebuild
index 53dc3cde0ba8..e856f644a63d 100644
--- a/x11-libs/pango/pango-1.48.4.ebuild
+++ b/x11-libs/pango/pango-1.48.4.ebuild
@@ -52,6 +52,9 @@ src_prepare() {
multilib_src_configure() {
local emesonargs=(
+ # Never use gi-docgen subproject
+ --wrap-mode nofallback
+
$(meson_feature sysprof)
-Dcairo=enabled
-Dfontconfig=enabled
@@ -78,7 +81,10 @@ multilib_src_install() {
}
multilib_src_install_all() {
- mv "${ED}"/usr/share/doc/{${PN},${P}} || die
+ if use gtk-doc; then
+ mv "${ED}"/usr/share/doc/{${PN},${P}} || die
+ fi
+ einstalldocs
}
pkg_postinst() {