summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-04-15 19:13:10 +0000
committerJimi Huotari <chiitoo@gentoo.org>2023-04-18 01:06:06 +0300
commit2a9e936dd182db3442e230cd0a715d9ab0d0e47e (patch)
tree11f214de1245f2456f51aa427b8b95e19d6fbea6 /x11-misc/qps
parentx11-misc/pcmanfm-qt: add 1.3.0 (diff)
downloadgentoo-2a9e936dd182db3442e230cd0a715d9ab0d0e47e.tar.gz
gentoo-2a9e936dd182db3442e230cd0a715d9ab0d0e47e.tar.bz2
gentoo-2a9e936dd182db3442e230cd0a715d9ab0d0e47e.zip
x11-misc/qps: add 2.7.0
Signed-off-by: Michael Vetter <jubalh@iodoru.org> Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'x11-misc/qps')
-rw-r--r--x11-misc/qps/Manifest1
-rw-r--r--x11-misc/qps/qps-2.7.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/qps/Manifest b/x11-misc/qps/Manifest
index b5419ea8d47c..e191b0d59a1f 100644
--- a/x11-misc/qps/Manifest
+++ b/x11-misc/qps/Manifest
@@ -1 +1,2 @@
DIST qps-2.6.0.tar.xz 295320 BLAKE2B e6a917993b64ace2333fec11d2406a0d9770bd8f3287ba38c586b7debd2572c342ebfb6e5e8c42f71f7ae6b6135995ba21f597258948538da5721daa8cde69c4 SHA512 c405841b2a455daeaf57e86c90a85e2d1e7c9a012d29262cba2b25f4b26ef693ae902d7d97b82504124d1b4562341af9c782b06745903616f1d3b809979d569a
+DIST qps-2.7.0.tar.xz 269192 BLAKE2B 90cb86f854d7c7df92ad206558741284a758b569ad117e9c4c0fcf063ec86539e9dc45e25e02449c63063b335056d01b5926ec760fde505b014ba3eb76c4ca2f SHA512 76285f37869f057fccd895eccf965547c11e49dd8315ef8ac4ea199734aae449be8e7782d41fb8582b0fa60715952857595d4bef7a3afcb47e83f31a168fd3c7
diff --git a/x11-misc/qps/qps-2.7.0.ebuild b/x11-misc/qps/qps-2.7.0.ebuild
new file mode 100644
index 000000000000..aa9eb3943b63
--- /dev/null
+++ b/x11-misc/qps/qps-2.7.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI Process Manager"
+HOMEPAGE="https://lxqt-project.org/"
+SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2 GPL-2+ LGPL-2.1+ QPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.13.0
+"
+DEPEND="
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ >=lxqt-base/liblxqt-1.3:=
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}