summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-12-03 15:19:51 +0100
committerSam James <sam@gentoo.org>2022-12-04 23:57:35 +0000
commitda8be2e6b4210e2d25c161485a34aaeadca1b2d0 (patch)
tree8d2b4f7e5a83b9014fced1281e283bfe2ff9d432 /x11-misc/trayer
parentx11-misc/trayer-srg: add myself as a maintainer (diff)
downloadgentoo-da8be2e6b4210e2d25c161485a34aaeadca1b2d0.tar.gz
gentoo-da8be2e6b4210e2d25c161485a34aaeadca1b2d0.tar.bz2
gentoo-da8be2e6b4210e2d25c161485a34aaeadca1b2d0.zip
x11-misc/trayer: fix incompatible pointer types
Closes: https://bugs.gentoo.org/881081 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Closes: https://github.com/gentoo/gentoo/pull/28523 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/trayer')
-rw-r--r--x11-misc/trayer/files/trayer-1.0-fix-incompatible-pointer-types.patch19
-rw-r--r--x11-misc/trayer/trayer-1.0-r5.ebuild42
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/trayer/files/trayer-1.0-fix-incompatible-pointer-types.patch b/x11-misc/trayer/files/trayer-1.0-fix-incompatible-pointer-types.patch
new file mode 100644
index 000000000000..e2d750641214
--- /dev/null
+++ b/x11-misc/trayer/files/trayer-1.0-fix-incompatible-pointer-types.patch
@@ -0,0 +1,19 @@
+Clang16 will not allow incompatible pointer types by default.
+
+Bug: https://bugs.gentoo.org/881081
+
+Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
+--- a/plugin.h
++++ b/plugin.h
+@@ -9,6 +9,8 @@
+ #include <stdio.h>
+ #include "panel.h"
+
++struct _plugin;
++
+ typedef struct {
+ /* common */
+ char *fname;
+--
+2.38.1
+
diff --git a/x11-misc/trayer/trayer-1.0-r5.ebuild b/x11-misc/trayer/trayer-1.0-r5.ebuild
new file mode 100644
index 000000000000..051d15d92456
--- /dev/null
+++ b/x11-misc/trayer/trayer-1.0-r5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lightweight GTK+ based systray for UNIX desktop"
+HOMEPAGE="https://sourceforge.net/projects/fvwm-crystal/"
+SRC_URI="https://sourceforge.net/projects/fvwm-crystal/files/${PN}/${PV}/${P}.tar.gz/download -> ${P}-sourceforge.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-dont-include-gdk-pixbuf-xlib.patch
+ "${FILESDIR}"/${P}-dont-include-libXmu.patch
+ "${FILESDIR}"/${P}-as-needed-and-pre-stripped.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-fix-incompatible-pointer-types.patch
+)
+
+src_compile() {
+ tc-export PKG_CONFIG
+
+ emake "CC=$(tc-getCC)" CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" -C systray
+ emake "CC=$(tc-getCC)" CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}"
+}
+
+src_install() {
+ dobin trayer
+ doman "${FILESDIR}"/trayer.1
+ einstalldocs
+}