summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-01-22 20:46:01 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-01-22 20:46:01 +0300
commitf1fcb7f8fe61b6e0c026a206b5545ed56344bd88 (patch)
treef74a92cf85e1a9f94ce08bf364ae2a50c9244f7b /x11-misc/wdm
parentsys-apps/qingy: install pam files conditionally (diff)
downloadgentoo-f1fcb7f8fe61b6e0c026a206b5545ed56344bd88.tar.gz
gentoo-f1fcb7f8fe61b6e0c026a206b5545ed56344bd88.tar.bz2
gentoo-f1fcb7f8fe61b6e0c026a206b5545ed56344bd88.zip
x11-misc/wdm: install pam files conditionally
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'x11-misc/wdm')
-rw-r--r--x11-misc/wdm/wdm-1.28-r6.ebuild (renamed from x11-misc/wdm/wdm-1.28-r4.ebuild)7
-rw-r--r--x11-misc/wdm/wdm-1.28-r7.ebuild (renamed from x11-misc/wdm/wdm-1.28-r5.ebuild)7
2 files changed, 10 insertions, 4 deletions
diff --git a/x11-misc/wdm/wdm-1.28-r4.ebuild b/x11-misc/wdm/wdm-1.28-r6.ebuild
index f6b3385ca80a..1ba2a83d76c2 100644
--- a/x11-misc/wdm/wdm-1.28-r4.ebuild
+++ b/x11-misc/wdm/wdm-1.28-r6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -41,5 +41,8 @@ src_install() {
default
rm -f "${ED%/}"/etc/pam.d/wdm || die
- pamd_mimic system-local-login wdm auth account password session
+
+ if use pam; then
+ pamd_mimic system-local-login wdm auth account password session
+ fi
}
diff --git a/x11-misc/wdm/wdm-1.28-r5.ebuild b/x11-misc/wdm/wdm-1.28-r7.ebuild
index 797dafa1bf98..d94c24004807 100644
--- a/x11-misc/wdm/wdm-1.28-r5.ebuild
+++ b/x11-misc/wdm/wdm-1.28-r7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -53,5 +53,8 @@ src_install() {
default
rm -f "${ED}"/etc/pam.d/wdm || die
- pamd_mimic system-local-login wdm auth account password session
+
+ if use pam; then
+ pamd_mimic system-local-login wdm auth account password session
+ fi
}