summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xwinwrap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xwinwrap')
-rw-r--r--x11-misc/xwinwrap/Manifest1
-rw-r--r--x11-misc/xwinwrap/metadata.xml9
-rw-r--r--x11-misc/xwinwrap/xwinwrap-0_p4.ebuild33
3 files changed, 43 insertions, 0 deletions
diff --git a/x11-misc/xwinwrap/Manifest b/x11-misc/xwinwrap/Manifest
new file mode 100644
index 000000000000..c634fca85d73
--- /dev/null
+++ b/x11-misc/xwinwrap/Manifest
@@ -0,0 +1 @@
+DIST xwinwrap-0_p4.tar.gz 4905 SHA256 d2df2dd04c79546f41f6fca3d6948eaf1b07b4742aec3cabfd2739509ca0763b SHA512 c209e1e0be366e63180f1e58844e7870d83786e912edd2e21912c6d404b44e9186a5f91be6f12ccb78c96c5bac23df02cc6d3d8fdb54743be3ef2586604bd853 WHIRLPOOL 91ccb7e80ae36c4612f59bdd5b05d3e3807f4eea9ac124beacfb67a6e45bffb128209d9032df268e26f01e8d316e029b925ac0611b2970f70b980669e6a5f5a5
diff --git a/x11-misc/xwinwrap/metadata.xml b/x11-misc/xwinwrap/metadata.xml
new file mode 100644
index 000000000000..59acc2cc580e
--- /dev/null
+++ b/x11-misc/xwinwrap/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/x11-misc/xwinwrap/xwinwrap-0_p4.ebuild b/x11-misc/xwinwrap/xwinwrap-0_p4.ebuild
new file mode 100644
index 000000000000..6b7770e9a1af
--- /dev/null
+++ b/x11-misc/xwinwrap/xwinwrap-0_p4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs vcs-snapshot
+
+DESCRIPTION="replace a desktop background with a movie or screensaver"
+HOMEPAGE="http://tech.shantanugoel.com/projects/linux/shantz-xwinwrap"
+SRC_URI="http://bazaar.launchpad.net/~shantanu-goel/xwinwrap/devel/tarball/4 -> ${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libXrender"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}/${PN}/devel
+
+src_compile() {
+ local cmd="$(tc-getCC) -Wall ${CFLAGS} ${PN}.c -o ${PN} ${LDFLAGS} \
+ $(pkg-config --libs x11 xext xrender)"
+ echo $cmd
+ $cmd || die
+}
+
+src_install() {
+ dobin ${PN}
+}