summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-03-02 21:27:50 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-03-02 21:27:50 +0100
commit2e285d4432b75c2dd58d4a4e33994ff951c9e1e7 (patch)
tree00a8cf2e777b2db7b1469c0bc7f6efe8456f5840 /x11-misc
parentapp-editors/vim: depend on vim-core unconditionally (diff)
downloadgentoo-2e285d4432b75c2dd58d4a4e33994ff951c9e1e7.tar.gz
gentoo-2e285d4432b75c2dd58d4a4e33994ff951c9e1e7.tar.bz2
gentoo-2e285d4432b75c2dd58d4a4e33994ff951c9e1e7.zip
x11-misc/dunst: add 1.8.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/dunst/Manifest1
-rw-r--r--x11-misc/dunst/dunst-1.8.1.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/x11-misc/dunst/Manifest b/x11-misc/dunst/Manifest
index 29ad301d4c5e..ac0deb9ee533 100644
--- a/x11-misc/dunst/Manifest
+++ b/x11-misc/dunst/Manifest
@@ -1,2 +1,3 @@
DIST dunst-1.7.3.tar.gz 4596283 BLAKE2B dff61659b777a92cd2add9b15551a7fa471eb9adda47b31bd48d6b20a34192f3f9e7147a4249047f6993a595d0d0cf9895d9a7cc84f5bbc64972f4e111e924ad SHA512 e8bd8555bd9ea3dc5ae85c2459ad1fa29bbc5d575346381e828fc6efd618db1e87c40b4fceeb89aef83bb7f5df6b246d8a354ce8b13ec549f3452cb32c918d62
DIST dunst-1.8.0.tar.gz 4603966 BLAKE2B 796cd76f782772cc91af27d797db92f6d3a35511d8a907e060a6363604a4b58a52f1cfc755d60a158e57ccb8b612ad119c36e8bbe960d354eed59acab93c0fde SHA512 b8e7f0884bb66aee8627858f667ef4db31664b07f7d7ede27c37d88fff6d7f47c62739d07fe7ab26628f95a13b13efa7704ea318dea4d0bcf0193a3fba6124bd
+DIST dunst-1.8.1.tar.gz 4603941 BLAKE2B c694503087425a69eecd40e4e50c5cfe5e5d3e9525d259b04dacd7e2bc05ff188aad14a331c41e6ecdd91b7c43d87d5902662b8a510675f3450da7097b7da1e9 SHA512 bd8605844eacb24ec1beafbd62be1defa8ff9f6fc2e93a4746acaba483e86d0fa3937045c20dbba71c46310102d8878c8ec987a3081328b02a09d7f9fde974d9
diff --git a/x11-misc/dunst/dunst-1.8.1.ebuild b/x11-misc/dunst/dunst-1.8.1.ebuild
new file mode 100644
index 000000000000..e3f5d7b97fd2
--- /dev/null
+++ b/x11-misc/dunst/dunst-1.8.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="Lightweight replacement for common notification daemons"
+HOMEPAGE="https://dunst-project.org/ https://github.com/dunst-project/dunst"
+SRC_URI="https://github.com/dunst-project/dunst/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="wayland"
+
+DEPEND="
+ dev-libs/glib:2
+ sys-apps/dbus
+ x11-libs/cairo[X,glib]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libnotify
+ x11-libs/pango[X]
+ x11-misc/xdg-utils
+ wayland? ( dev-libs/wayland )
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig
+ wayland? ( dev-libs/wayland-protocols )
+"
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-Os//' -i config.mk || die
+
+ # Use correct path for dbus and system unit
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" -i dunst.systemd.service.in || die
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" -i org.knopwob.dunst.service.in || die
+}
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+
+ default
+}
+
+src_compile() {
+ local myemakeargs=(
+ SYSCONFDIR="${EPREFIX}/etc/xdg"
+ SYSTEMD="0"
+ WAYLAND="$(usex wayland 1 0)"
+ )
+
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ local myemakeargs=(
+ PREFIX="${ED}/usr"
+ SYSCONFDIR="${ED}/etc/xdg"
+ SYSTEMD="0"
+ WAYLAND="$(usex wayland 1 0)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ systemd_newuserunit dunst.systemd.service.in dunst.service
+}