summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Schroeder <chris.schroeder.public@gmail.com>2021-10-07 19:09:16 +0200
committerSam James <sam@gentoo.org>2021-10-20 02:41:10 +0000
commit3f99aff1b352066b103f74e1cc284f1a4f1bbc96 (patch)
treeb16c0e00e18f439512014f944500bbd0fea0e8ee /x11-misc
parentapp-text/master-pdf-editor: make QA_PREBUILT relative (diff)
downloadgentoo-3f99aff1b352066b103f74e1cc284f1a4f1bbc96.tar.gz
gentoo-3f99aff1b352066b103f74e1cc284f1a4f1bbc96.tar.bz2
gentoo-3f99aff1b352066b103f74e1cc284f1a4f1bbc96.zip
x11-misc/copyq: version bump to 5.0.0
- Removed bash completion patch (bug fixed by upstream). Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Christian Schroeder <chris.schroeder.public@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22510 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/copyq/Manifest1
-rw-r--r--x11-misc/copyq/copyq-5.0.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/x11-misc/copyq/Manifest b/x11-misc/copyq/Manifest
index f976b7203c8b..db723c3427ff 100644
--- a/x11-misc/copyq/Manifest
+++ b/x11-misc/copyq/Manifest
@@ -1,2 +1,3 @@
DIST copyq-3.13.0.tar.gz 2917941 BLAKE2B e8fc963e6a773ae70ca5a39f9ea55a98de5c5d129b845d0da9ed08ffec65d88ed8b5dd138dea11a33d563b899f0497929ed3c40d418574e50c2a1fbbd7b1a9f6 SHA512 898d4501002202849f0b5302d7315e8c539f8b0f8d5198641b3d3a647839581841e2ef1e2519c690d3cc95f85fdc921c979f2879348184de42767d31e081c307
DIST copyq-4.1.0.tar.gz 2999036 BLAKE2B 1252a66a3bbde3d4435ced9934792ed97066229b23cd5ec21a6187d4f36718d46ac5e16ff19c45afee8715a32686bfe8e47af1bbb37d61a1cacb4e9395dc7bc9 SHA512 538be8b5b60dc054cb8220174461516a4d1e9d6f7c1a03406770f143b83f9a23875b0cf663406e16d83a762b6170587f0e44c386a7d9d552ec6f914b3673206d
+DIST copyq-5.0.0.tar.gz 3019807 BLAKE2B d39c02867ed4a23eeeec7283f0cbf02a77a3c3fc3ece0a7323d67de9d2b8f03749318d066c23221ccd393923217c7cf357657bdf70802087edae7f4128a63529 SHA512 b6ff28bd7529bf371c7f9d10372eeafd5f291fd1f6bbed5416938973db43e43f0113a8f6ba4619840a7edd95d26ccb9369f8a58d30b740944d3f8510482b1405
diff --git a/x11-misc/copyq/copyq-5.0.0.ebuild b/x11-misc/copyq/copyq-5.0.0.ebuild
new file mode 100644
index 000000000000..2125729eeefa
--- /dev/null
+++ b/x11-misc/copyq/copyq-5.0.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Clipboard manager with advanced features"
+HOMEPAGE="https://github.com/hluk/CopyQ"
+SRC_URI="https://github.com/hluk/CopyQ/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/wayland
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwayland:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ kde-frameworks/knotifications:5
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+
+S="${WORKDIR}/CopyQ-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_BUILD_TYPE=Release
+ -DPLUGIN_INSTALL_PREFIX="/usr/$(get_libdir)/${PN}/plugins"
+ -DWITH_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}