summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-03 12:07:51 +0000
committerSam James <sam@gentoo.org>2023-02-03 12:14:19 +0000
commit3cd86d51f04e50e2c0c1ea3680050871809b2d00 (patch)
treed2d7ea01f57f551c42c4b684bd3d9e5d11058607 /x11-plugins/gkwebmon
parentsys-libs/libcap: add 2.67 (diff)
downloadgentoo-3cd86d51f04e50e2c0c1ea3680050871809b2d00.tar.gz
gentoo-3cd86d51f04e50e2c0c1ea3680050871809b2d00.tar.bz2
gentoo-3cd86d51f04e50e2c0c1ea3680050871809b2d00.zip
x11-plugins/gkwebmon: add 0.2.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins/gkwebmon')
-rw-r--r--x11-plugins/gkwebmon/Manifest1
-rw-r--r--x11-plugins/gkwebmon/gkwebmon-0.2.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/x11-plugins/gkwebmon/Manifest b/x11-plugins/gkwebmon/Manifest
index d8d8da7ff8de..563c5f47244f 100644
--- a/x11-plugins/gkwebmon/Manifest
+++ b/x11-plugins/gkwebmon/Manifest
@@ -1 +1,2 @@
+DIST gkwebmon-0.2.1.tgz 14576 BLAKE2B 12014eef1f73c4b398aeb7e5f5e7821561dd01c2de7d1705f567d60252ce7ce376266612602b58f90bc16dc587d8c5449d791dfd01a9c810fe9c6fb6d05970ce SHA512 f71a106372018c55ca1e31140aedd669df66cb6c3e9613fe5341831fad55e8bdd23c46281c38c553c09d350436bc1e44cee07602a24fc637c7f21f4e0d50cc39
DIST gkwebmon-0.2.tgz 14163 BLAKE2B c6c0c9352e2f68eca56f981abb8188a7a300604c8c0fc05c1b0b95f0cdc117c12e55aeace66f9c3dcc16a13acb2b44683a77de36a83d9e9b7c273ec619173235 SHA512 0af4eaa8636b43232e209e6381a3852eb92b9505da4b19e31137766f4bee7977bf4e4bed40518df0fcc3aef2dc62767c85169e70f1fbfc738bb428ae8affac63
diff --git a/x11-plugins/gkwebmon/gkwebmon-0.2.1.ebuild b/x11-plugins/gkwebmon/gkwebmon-0.2.1.ebuild
new file mode 100644
index 000000000000..506413a96789
--- /dev/null
+++ b/x11-plugins/gkwebmon/gkwebmon-0.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="A web monitor plugin for GKrellM2"
+HOMEPAGE="http://gkwebmon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+# The Makefile links with -lssl.
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ dev-libs/glib:2
+ dev-libs/openssl:=
+ x11-libs/gtk+:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2-cc-cflags-ldflags.patch
+ "${FILESDIR}"/${PN}-0.2-fno-common.patch
+)
+
+src_compile() {
+ tc-export PKG_CONFIG
+
+ emake CC="$(tc-getCC)"
+}